3

I upgraded SharePoint 2010 to 2013 using Attached Content Database method. I followed below steps

  1. Took backup of Content database of 2010 from Sql 2008

  2. Created New Web Application in 2013

  3. Installed WSP in 2013 Farm solution using Add-SPSolution "c:\example.wsp"

  4. Restored in Sql 2012

  5. Attached Database to the 2013 Application using PowerShell with stsadm

  6. Operation completed Successfully

My web application got upgraded to SharePoint 2013, but my web part doesn't work after the upgrade.

The following page is shown:

enter image description here

  • Hi, can you please post the actual error form the ULS logs. – JP Roelofse Mar 5 '14 at 5:30
  • I didn't get any error while upgrading. Other than web part ,everything works fine – SharePointMan Mar 5 '14 at 5:41
  • Did you upgrade the web part to be SP 2013 compatible. Also look for the correlation ID in the ULS logs. That will give an indication as to what might be wrong. – Nadeem Yousuf Mar 5 '14 at 5:44
  • When I upgraded the Webpart, the upgrade got errors. when i directly installed 2010 ".WSP" in 2013 farm, upgrade got succesfull. then my site got opened on 2013.everything works fine but when i try to add that webpart it shows above error.than i upgraded my webpart and than deployed .but still the same error – SharePointMan Mar 5 '14 at 5:49
  • What is the error in ULS? – Nadeem Yousuf Mar 5 '14 at 6:05
4

It's an easy fix, at least this worked for me. Steps:

  1. Double click package in Visual Studio

  2. Go to Advanced tab

  3. Change the product version to 14.0

and you are good to go

2

What @luckydeveloper answered is a solution but it is better you upgrade your solutions to SP2013 version aswell. You must make the package product version to 15.0.

You are getting the error because your user controls .cs file has a CONTROLTEMPLATES which you have to convert to CONTROLTEMPLATES/15/. Check my thread on

How to upgrade a SharePoint 2010 Project to SharePoint 2013 (WebParts, MasterPage, App Page, User Controls) in Visual Studio 2012 -Point 6

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.