7

I migrated a SharePoint 2010 site collection containing a custom site definition to SharePoint 2013 using database attach. The site collection has several sub sites created using the custom site definition. I also deployed the SP 2010 WSP containing the Site Definition to 14 hive initially. The new site collection worked properly in SP 2010 mode.

Now in order to upgrade to SP 2013, I upgraded the project containing the site definition in Visual Studio 2012. I created a new WSP and deployed it to 15 hive. I can see the webtemp_siteDefinitionName.xml file in \15\TEMPLATE\1033\XML. Also if I run the PowerShell command:Get-SPWebTemplate -CompatibilityLevel 15, the custom site definition shows up. However, when I try to perform the actual upgrade either from UI or Powershell command Upgrade-SPSite I get the error:

The following sites are using templates that are not yet supported after upgrade

4

I found the solution to this issue:

Both versions of the site definitions (14 and 15) need to be present in respective hives at the time of performing upgrade. If either of them is absent the error will show up.

See here for more information: http://sharepointnadeem.blogspot.com/2014/01/sharepoint-following-sites-are-using.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.