1

somehow my branding elemnt disappeared. If I try to get it from Powershell it is still there

PS C:\temp> $app = Get-SPWebApplication http://myintranet
PS C:\temp> Write-Host $app.SuiteBarBrandingElementHtml
<div class=ms-core-brandingText>MyIntranet</div>
PS C:\temp> Write-Host $app.Name
MyIntranet

But it doesn't show up on the site? It's not hidden by css. Do you know what could be the problem or how to solve it?

Thanks

EDIT: This is what is rendered:

<div id="suiteBarLeft">
<div class="ms-table ms-fullWidth">
    <div class="ms-tableRow">
            <div class="ms-tableCell ms-verticalAlignMiddle">

                </div>

While a working site collection has the following code:

<div id="suiteBarLeft">
    <div class="ms-table ms-fullWidth">
    <div class="ms-tableRow">
        <div class="ms-tableCell ms-verticalAlignMiddle">
            <div class="ms-core-brandingText">SharePoint</div>

                </div>

I am using a custom master page but not a custom solution. Going back to a seattle masterpage doesn't solve.

2
  • not a good solution but I've forced the text with jquery
    – Gyonder
    Feb 3 '14 at 10:47
  • 1
    Does there exist something like an official solution to this issue? I am struggling with exactly the same problem and don't know where to search anymore. When creating a new site collection on the same server with the same design, it works properly. Shouldn't in the master-file exist a line, which integrates the SuteBarBrandingElementHtml or something like that? Regards, Eddie
    – eddie-666
    Mar 24 '14 at 13:41
1

Another way to do this (that's better than using JavaScript) is to create a user control that inherits and deploy it as a delegate control in a feature.

Tobias Zimmergren wrote an article about the different new delegates in SP 2013 that can help you override the left or the right side of the SuiteLinks bar:

SP 2013: Some new DelegateControl additions to the SharePoint 2013 master pages

0

You are missing " around the class attribute. This probably makes your browser a bit angry.

Try to set it like:

<div class="ms-core-brandingText">MyIntranet</div>

and then do an $app.Update()

3
  • It doesn't wotrk. I have also simply tried : $webapp.SuiteBarBrandingElementHtml = "MyIntranet" but no luck
    – Gyonder
    Feb 3 '14 at 8:22
  • Does it get rendered at all? And do you have any custom solutions installed? Could be something overriding the whole SuiteBar element Feb 3 '14 at 8:24
  • It' doesn't get rendered at all. I've edited with what is rendered. I'm not using a custom solution
    – Gyonder
    Feb 3 '14 at 8:36
0

For resolving your issue , you need to activate this feature:

Go to CA

Click System Settings->Manage farm features under Farm Management

Scroll to the feature 'Social Tags and Note Board Ribbon Controls', activate it

original post is here under "update"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.