0

I have setup a Sharepoint Foundations 2010 server on a fresh install of Windows Server 2012R2 in a VM so I could mess around with Sharepoint, though I'm stuck on what I consider to be a pretty basic feature: Anonymous Access.

Every guide that I've found says the same thing, which I'll briefly reiterate:

  • Go to Central administration > Manage web applications, select the 'Sharepoint - 80' row, click 'Authentication Providers', click 'Default', check off 'Enable anonymous access' and click save.
  • Click 'Anonymous Policy', select 'None' for 'Anonymous Policy' and click save.

  • Site Actions > Site Settings > Site Permissions and click the 'Anonymous Access' button.

Though I don't have a button for that, which according to what I've read means I haven't checked the 'Enable anonymous access' despite it being enabled. If I go to /_layouts/setanon.aspx, the options are all grayed out.

Any suggestions?

  • 1
    What happens if you try with Server 2012, as SharePoint 2013 does not support Server 2012 R2. – Trevor Seward Jan 20 '14 at 4:09
  • did you say you select "None"..Click 'Anonymous Policy', select 'None' for 'Anonymous User Policy' and click save." you should select from 1st and 2nd options. – Waqas Sarwar MVP Jan 20 '14 at 4:38
  • Sorry, I meant to say the "Anonymous Policy" button. Everything else that I've tried works, so unless I really have to, I won't be downgrading to 2008 or something. – Ben Jan 20 '14 at 13:51
0

If you want to enable anonymous access like your above steps. You must create a new web application with the option "Allow Anonymous" is yes. Once the web application is created. You can configure the anonymous access by your steps in above.

enter image description here

  • Thanks, that worked. I didn't get the Anonymous Access button, though once I went to /_layouts/setanon.aspx again, the options weren't grayed out and I was able to make the changes. – Ben Jan 24 '14 at 15:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.