0

I have tried to enable anonymous access in SharePoint 2010 for quite a while now, but it just won't work. I have followed many of the guides out there to enable anonymous access, eg Enable Anonymous Access in SharePoint 2010.

When I try to access my SharePoint site anonymously I don't get any login dialog, but I get a 403 FORBIDDEN error.

I have checked that the "Anonymous Authentication" is enabled in the IIS. I get the same error regardless browser.

Anyone?

2

Few things that you should see:

  • Make sure the default page is checked-in and approved (if its checked-out or pending for approval, it won't be available to anonymous users)

  • Make sure all items in Style Library/Site Assets are checked-in and all these libraries have Anonymous Access (sometimes Style Library/Site Assets are not inheriting permissions from Site, so you need to explicitly tell these to inherit or turn on Anonymous Access)

0

Problem solved. Commented out all the code that has SPContext.Current and then it works. Read this blog post: http://steveclements.net/blog/Gotcha-403-and-401-errors-in-SharePoint-using-Anonymous-access.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.