1

I have 1 App server and 2 WFEs. Web Application service is stopped on App server while it is started on WFEs.

I created a new web application and I noticed the URL is of App server for e.g. http://appserver

I thought since I have stopped web application service so URL will be something like http://wfe01 or http://wfe02 but looks like that's not the case.

Is this normal?

4

When you create the Web Application you decide what should be the URL of it. And in your setup it should not be the URL of any of your servers, but the URL for the load balancer which distributes the work between wfe01 and wfe02.

And normally you'll leave the web application service running on the App server as well and let Search Crawl use that locally by having the hosts file on the App server point the load balanced URL to itself.

  • But when I created web application, it didn't give me any option to chose URL specially that of load balancer. How do I do that? – Frank Martin Oct 24 '13 at 8:27
  • 1
    When you create your web app you have the option of specifying Host Header (and port number) that's the building blocks for the URL – Per Jakobsen Oct 24 '13 at 8:45
  • Ok I see now there is Host Header option. But I was also able to change URL by going to Alternate Mapping Access and then changing appserver to wfe01 and then adding another Internal URL as wfe02. Did I do it right? – Frank Martin Oct 24 '13 at 9:40
  • No it should not be wfe01 or wfe02 but the Load balancing URL. Take a look at Prepare SharePoint Farm – Part 3 Prepare NLB for SharePoint Web Front End WFE Servers and the next part of that series even though that's for SP2010 – Per Jakobsen Oct 24 '13 at 12:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.