3

I believe we're on SharePoint Server 2013. I'm a user running Firefox 64-bit.

I'm looking for a one-click solution to opening a Word doc or PowerPoint in my desktop application, instead of right-clicking, clicking Edit, waiting for the web app to load, and clicking Edit in the PowerPoint Web App. I also want to make sure the Coauthoring feature is working.

When Open in the client application from Site Settings | Advanced is enabled, clicking a file will give me a prompt to open or download the file. Coauthoring does not work from these locally downloaded files. Clicking Edit will continue to open it in the browser web app, even if Open in client application is working.

I find the Office Web Apps are clunky and missing crucial features I need, so I want to use the Web App 0% of the time. This is driving me crazy because I feel like I used to have it work the way I want, but something changed and I always have to go through the web app.

3

You will need to activate 'Open Documents in Client Applications by Default' feature under the site collection feature and also the Open in the client application under list setting. Have a look at this

I tested this and it is working as expected i.e. documents are opening in the client application rather than in the browser.

| improve this answer | |
  • 1
    There's a known bug in SP 2013 where Firefox and Chrome completely ignores that setting. We've tried a CU after the supposed fix was put in place but never managed to get it to work. – Greg W Aug 25 '17 at 6:00
  • 1
    Thanks you. Greg's identified the bug I am experiencing, and I've confirmed that it works in IE as expected. It's unfortunate how many bugs and broken SharePoint features plague Firefox/Chrome users. – Glen Y Aug 28 '17 at 14:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.