MOSS 2007 :)

I am having problems deploying a webpart.. This webpart was successfully installed and deployed on a similar environment with no problems. However when trying to deploy it in its intended site it's having some strange problems..

  1. I installed the webpart to the server (through stsadm) - return message "Operation completed successfully."
  2. I deployed the webpart to the intended site - return message "Operation completed successfully."
  3. I performed an IIS reset and navigated to the 'site features' area to find no trace of the webpart to activate.

I ran the 'stsadm -o enumsolutions' command to view the solutions that are deployed, and I see my webpart here:

<Solution Name="solutionname.wsp">
<LastOperationTime>9/21/2010 3:19 AM</LastOperationTime>    

As you can see, it is listed as 'FALSE' for 'deployed', yet the last operation result was 'DeploymentSucceeded'...

I have uninstalled the solution completely, and went through the same steps for the exact same result. Any idea what could cause this and how to resolve the issue?

3 Answers 3


Check that the WSS administration service is started on all of your servers. I had exactly this problem today funnily enough. Was down to the service not running on the sql server.

  • That makes sense, yey I dont seem to have that service on my SQL server, yet I've deployed things in the past?
    – Anonymous
    Sep 22, 2010 at 1:19
  • Check it on all your web servers. Even though its set to Automatic start it doesn't always start, even on reboot. Manually start it on each server and try it again.
    – FatalFrenchy
    Sep 22, 2010 at 6:33

Restart your front end servers. That will usually sort this one out.

  • Unfortunately not, any other ideas?
    – Anonymous
    Sep 21, 2010 at 8:50
  • I agree with FatalFrenchy. Check all your servers in the farm and make sure the sharepoint services you expect to be running are started.
    – user790
    Sep 22, 2010 at 8:46

Check the webpart gallery. I doubt your webpart file is there. Upload it and see if that allows you to activate the feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.