In central administration, the option "My Settings" is displayed in the right profile fields.

i.e When I log in the CA with the credentials of the administrator, or of an-in-purpose-given-access-simple user, and choose "My Settings" the fields show up normaly, giving me the option to edit them (after choosing EDIT). The name, the Last Name and the E-mail Address field is ok.

The problem occurs when I am logged into another site (not CA).

For example http:portal:80 - I log in with the same user, I choose "My Settings" and I see Name, Last Name, but instead of Mail, I see Work E-mail.

If I choose "EDIT", there is nothing to edit.

The User Profile Sync has started and works OK. I have imported ALL of my profiles from AD.

What could I do please?

I realized that I had created the site collection (my host- which the UPS uses) on the second web application I have, not the maim one. So I deleted the whole web application (the second) and created a second site collection (my hosts) on the already created MAIN WEB APP. Now the sync is ok.

Where I would like assistance on, is:

  1. When each user accesses his profile, many useless fields show up. I can't delete them from "Users Properties" inside the UPS.

  2. Even though I have followed Spencer Harbar's tutorial about writing back to the AD, I can't get it to work.

1 Answer 1


Set the email address in AD and rerun the sync. After the timer job updates the profiles, your new "work email" should be available.

Whatever mapping you have in UPS will determine in which field the update appears.

If you have fiddled with UPS, it may not be getting all the info to the SharePoint site(s). So, you may have to manually (PS) update the fields. After you get them updated, normal UPS sync should work for subsequent updates.

PowerShell option1 Set-SPUser cmdlet along with the -SyncFromAD parameter.

PowerShell option2 set-spuser -identity 'domain\username' -web http://yoursite.com -email '[email protected]'

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.