0

When developing against SharePoint 2019 on-premises with the last supported SPFx v1.4.1, which is the newest supported version of @pnp/sp that works?

I see that v1.3.9 works - the solution can be built and executed via gulp serve but I don't want to try by trial and error.

I cannot find it on their documentation and it does not work with current 2.8.0 even with [typescript version workaround] (https://pnp.github.io/pnpjs/SPFx-on-premises/) described on their site.

1 Answer 1

0

it work fine with pnpjs v1.3

{
  "name": "extension-spfx-2019",
  "version": "0.0.1",
  "private": true,
  "main": "lib/index.js",
  "engines": {
    "node": ">=0.10.0"
  },
  "scripts": {
    "build": "gulp bundle",
    "clean": "gulp clean",
    "test": "gulp test"
  },
  "dependencies": {
    "@microsoft/sp-core-library": "~1.4.0",
    "@microsoft/decorators": "~1.4.0",
    "@types/webpack-env": "1.13.1",
    "@types/es6-promise": "0.0.33",
    "@microsoft/sp-listview-extensibility": "~1.4.0",
    "@microsoft/sp-dialog": "~1.4.0",
    "@pnp/common": "^1.3.0",
    "@pnp/graph": "^1.2.8",
    "@pnp/logging": "^1.3.0",
    "@pnp/odata": "^1.3.0",
    "@pnp/sp": "^1.3.0",
    "office-ui-fabric-react": "^5.135.0"
  },
  "devDependencies": {
    "@microsoft/sp-build-web": "~1.4.1",
    "@microsoft/sp-module-interfaces": "~1.4.1",
    "@microsoft/sp-webpart-workbench": "~1.4.1",
    "@microsoft/sp-tslint-rules": "1.4.0",
    "gulp": "~3.9.1",
    "@types/chai": "3.4.34",
    "@types/mocha": "2.2.38",
    "ajv": "~5.2.2"
  }
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.