0

Content editor is not showing in newly created SharePoint Online, till now I did following steps:

  1. Enabled SharePoint Server Publishing Infrastructure in site collection features and SharePoint Server Publishing in Site features.
  2. Enabled Custom Script from SharePoint admin
  3. Also ran powershell online Set-SPOsite -DenyAddAndCustomizePages 0

But still Content editor webpart is not showing in Media and Content webpart forlder of SharePoint Online, is it deprecated as mentioned in few articles.

2
  • Are you using modern communication site or team site? Jul 17, 2020 at 12:02
  • Ganesh it is team site
    – SPDev
    Jul 17, 2020 at 14:38

1 Answer 1

1

Please go to site settings->site permissions->check permissions, check if the user deny with “Add and customize pages”.

enter image description here

If yes, it might cause we cannot view the Content Editor Web Part, to resolve this issue, please run the SharePoint Online Management Shell as administrator. And then run the following commands:

Connect-SPOService -Url https://tanent -admin.sharepoint.com/

Set-SPOSite -Identity https://<yourdomain>.sharepoint.com -DenyAddAndCustomizePages $false

Then check if you can view the Web Part.

1
  • Thank you Lisa for reply, I am getting your mentioned Deny thingy on subsite but not on root site
    – SPDev
    Jul 21, 2020 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.