0

I'm using Sharepoint Pnp PowerShell against a SharePoint 2013 server on-prem and whenever I try to use Get-PnpFolder, it gives the error:

Method "GetFolderByServerRelativePath" does not exist

The Rename-PnpFolder also gives the same error.

I've tried using it on both my workstation (Windows 10) and on one of the SharePoint 2013 Server web front ends. Both get the same error. All the other cmdlets I have used work just fine.

It is connecting to the site because I can use the cmdlets to access lists for example.

The docs don't seem to indicate that this shouldn't work with 2013. Any ideas?

  • are you using the SharePoint online and SharePoint 2013 PNP pwoershell side by side? – Waqas Sarwar MVP Oct 23 at 19:39
  • That is most likely the case, since I can connect to either on-prem or SPO. – mannaggia Oct 24 at 0:30
1

Unfortunately the modules are often not cross-version compatible due to the different CSOM versions supported between the products. this is what your problem looks like, read this blog how to run it side by side: Using SharePoint PnP PowerShell Modules Side-by-Side (2013, 2016, & Online)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.