1

We are in the process of migrating the SharePoint 2007 contents to SharePoint 2010, using database attach method.

Having installed SharePoint 2010 on the server, upgraded the content database and attached.

It was upgraded successfully and attached however contents are accessible only for the system account. Means that, user whoever has permission on the site are getting access denied error message.

Users are able to access if and only if they are readded again on the site. Even we have granted read access to "nt autherity/authenticated users" before the migration on the site but it failed and the workaround is just to readd the account.

What could the issue? Whenever i try to readd the user name is not getting displayed properly.

6
  • Is the 07 farm and the 10 farm in the same domain?
    – Dave Wise
    Nov 23, 2011 at 18:35
  • yes. Both are in same domain. Nov 24, 2011 at 0:51
  • Did the authentication method change between 2007 and 2010? I.e. are both NTLM or is one NTLM and the other Kerberos?
    – Dave Wise
    Nov 28, 2011 at 15:52
  • oh ho, Thanks Dave. It is an authentication misconfiguration issue, have created a new webapplication with classic (NTLM) authentication and attached the migrated content DBs. Dec 1, 2011 at 3:50
  • 1
    @dave-wise could you add this as answer please? Dec 23, 2011 at 7:12

1 Answer 1

2

If the authentication method changed between 2007 and 2010 then users that were added under the original method will not have permissions on the new site as the "nt authority" is now different. The fix would be to either use the same authentication in 10 as was used in 07 or to manually rebuild your security in 10 with the new method, which is tedious to say the least.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.