0

I'm trying to Edit a page, add a table to it and upload a picture. What I'm expecting (and was getting before today) - to get that picture in the cell of a table which I can then change the size etc using the top bar above the ribbon for editing purposes. What I'm actually getting - the picture gets uploaded to SiteAssets library, I get the window prompted to add in Title and E-mail and the actual picture is not appearing on the screen then. I believe I've changed something in the Content Types for either Picture / Item while working on my picture library app. However, I can't understand what happened here. Is there any chance to either set these default content types to their default parameters?

0

Verify the picture was properly uploaded to the site assets library and the link to the picture is pointing to the proper location

if the picture is on draft mode (due filling all the required fields) you might not be able to see it.

additionally i would recommend as a best practice to upload your images in a specific repository for images and the add the link to image from a SharePoint Location to your page

  • Thanks, Erin! What's weird though - before I was able to add the image through Edit options, it would be saved to Site Assets library automatically and at the same time it would occur on the page straight away. It doesn't happen anymore for some reason. I've compared content types settings with out of the box SP2013 - it's all same. So I've definitely have something else incorrect here as the image now is only saved to the SiteAsset library and doesn't appear on the site view straight away – Eva Griskene Mar 14 '18 at 17:22
  • the normal behavior of SharePoint is to create a folder in the site assets, then a folder called "pages" or "sitePages", inside that folder a folder with your page name and inside of that is your image, check if you have permissions to all of those folders, it seems to me like you are not being allowed to publish to those folders anymore – Mike Mar 14 '18 at 18:55
0

Right, so after working on it for the full day I've finally fixed it with some help. Basically it is what I thought - content types were screwed. I used the command to run in SP powershell to reset all of the content types:

stsadm -o deactivatefeature -name Fields -url http://sitecoll -force stsadm -o activatefeature -name Fields -url http://sitecoll -force

Ran successfully but didn't help to solve my issue. I had a great chance to compare my modified SP page with fresh out of the box SP page and then updated the Content Types accordingly as how it is in OOTB version. Still didn't sort my issue. And then in the SP Designer we went to each site of the SP > Lists and Libraries > Site Assets > edit columns > deleted "E-mail" column that shouldn't be there at all (I think this what was causing the actual issue). Then went back to Site Assets, Content Types "Document" and then pushed changes to sites and lists. I am now able to upload the image from my computer which automatically goes to the SiteAssets library and also gets displayed on the screen at the same time.

Thanks for advice though, it's good to know another way of working with those images!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.