3

In my environment when I go to CA > Manage Content DB settings; the preferred server for timer jobs in the dropdown is not shown and is empty. Also OOB timer jobs which have job lock type of content database, do not run and I cannot see them in the history or failed jobs page even after running them manually.

Here is what I have tried:

  • Reset the timer cache on all SharePoint servers (2 FE + 2 APP) by removing and regenerating the XML files

  • Running Products configuration wizard

Any suggestions to help resolve this issue? And what could be the cause?

  • which OOB timer job you ran (give me exact name), also what are the MinRole for your Servers? – Waqas Sarwar MVP Aug 22 '17 at 13:13
  • All servers are in custom role, 2 FE and 2 APP servers. I have to setup Document ID service feature on my publishing site collections. The jobs I am running are 1) DocIdEnable - "Document ID enable/disable job" and the 2) DocIdAssignment - "Document ID assignment job". Both jobs have lock type of Content Database. To identify the issue, I tried deploying my custom timer job too with lock type of Content Database and it didn't work. If I change the lock type to 'None' it works. I have checked the event viewers, and ULS logs. Nothing there :( – Muhammad Usman Aug 23 '17 at 6:57
  • @WaqasSarwarMVP any suggestions you might have to resolve this issue? Or is there anyway we can bump this post for the community to see? – Muhammad Usman Aug 26 '17 at 19:11
  • You mention all servers are custom Minrole role not dedicated like fe or app server etc.... – Waqas Sarwar MVP Aug 26 '17 at 19:16
  • Yes, and this is why it is frustrating, don't know why is it happening, nothing in logs or event viewer !! – Muhammad Usman Aug 27 '17 at 14:25
0

I was facing the same type of problem. My issue was the timer jobs were not running on Web application scope.

Originally I created a single server farm with a custom role and it works perfectly fine. After few months, I added another server as WFE server with a minimum service related to WFE (Custom role). So My setup was App server (custom role) + WFE server (custom role). This caused the timer jobs stops working.

To solve this issue I converted the app server to Application with Search role and WFE to FrontEnd with distributed cache. After changing roles I ran config wizard on both servers and rebooted the servers.

This change makes my timer job started working again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.