1

Today i ran in to an error "One or more field types are not installed properly. Go to the list settings page to delete these fields".

I activated the SharePoint Sever Publishing Infrastructure feature on that site collection along with a few other features and when i went in to create sub sites, i ran in to this error.

I tried following this document https://shipoint.com/2013/01/28/fixing-one-or-more-field-types-are-not-installed-properly-go-to-list-settings-page-to-delete-these-fields/, but issues is not resolved.

I run in to this error, when i try to use Team site template to create sub sites. for all other templates, no errors.

Any suggestions are helpful.

  • Did you ever get a fix for this? I'm having this same issue with several of my Site Collections but others seems to work fine. I have a ticket in with Microsoft but am not getting anywhere. – DeborahH Mar 23 '17 at 15:35
  • Are you using On prem or Online environment? If its Online, i had a ticket open with Microsoft, they ran some internal scripts and that resolved the issue. @DeborahH – AXA240778 Mar 23 '17 at 20:14
  • @AXA240778 Did they tell you what it was? Im having the same issue... – TigerBear Sep 29 '17 at 12:50
  • Hello @TigerBear, MS support people ran some internal scripts and asked me to activate a few features through id. I would suggest to check if you have all system generated site content types and site columns. If not, you have to get them back by activating features (Powershell). – AXA240778 Oct 9 '17 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.