1

I am trying to join two WFE's to a new farm, but when I run PSCONFIGGUI it fails on step 4.

Failed to connect to the configuration database

In the error it then states

An exception of type Sytem.IO.DirectoryNotFoundException was thrown. Additional exception information:
Could not find a part of the path 'E\SharePoint\Logs'

I throught to begin with, that this was becuase drive E wasn't on my two WFE's - so I went into central admin, changed it to D:\SharePoint\Logs and made sure that that was available on both the WFE's and the app server - it is.

I've also rebooted all three servers, but each time I run PSCONFIGUI I'm met with the same issue.

It's like it's being cached somewhere.

I've cleared out the cache files on the app and WFE's from C:\ProgramData\Microsoft\SharePoint\Config but still no luck.

Any ideas how I can fully flush the config and make a new GUID for it ?

  • 1
    Please try to recreate that log folder as stated in the error message and retry. If that doesnt work try -force parameter in PSCONFIG command in powershell. – allegro octopus Dec 9 '15 at 17:40
  • I tried to recreate the folder, without success and a reboot, so I'll try the -force option and report back, thanks. – Rob Sked Dec 9 '15 at 21:32
  • On your working WFE, are logs actually being written to the latest diagnostics log location on D:\SharePoint\Logs? Or, have you tried using the default location instead? c:\program files\common files\Microsoft shared\web server extensions\15\logs – Erik Perez Dec 10 '15 at 5:26
  • This is the first time I'm configuring the WFE's - the app server is correctly generating the log files in any location I specify. It just seems to have got the config cached. – Rob Sked Dec 10 '15 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.