10

I need your help regarding one weird issue. I have two 2012 Datacenter WinServers acting like WFE & APP and one separate 2012 SQL Server for databases with instance, alias, properly enabled TCP/IP and so on, that actually holds databases from another two SP 2013 environments as well.

I downloaded latest SP 2013 Foundation SP1 from Microsoft site, install binaries, run first graphical configuration wizard, create new farm and Central Administration was automaticaly launched. However, that's all. The End. Nothing else can be done.

I cannot apply language pack, I cannot apply patch for search or create search service at all (PowerShell or wizard), every try to run pscofing ends with locked databases, unaccessible CA and stopped services (OK, Search service configuration ends with time-out and than services are stopped...) Not the worse thing, let's continue.

The situation is the same on both servers, so no exception just for one environment, but both are virtuals from the same image. Than, I tried to install own SQL Express on the server with APP role, (just for tests, because original SQL server contains a lot of other databases, it is remote and already holds config dbs from previous attempts) and the result was the same - even there psconfig failed, even without any additional configuration change. I tried to:

  • clean the cache (with whole process that belongs to this operation)
  • restart servers
  • hit an iisreset many times
  • manualy start the services
  • use stsadm -o setproperty -pn command-line-upgrade-running cmd
  • checked service accounts on "Log on" tabs & IIS pool accounts
  • checked DB rights & roles
  • checked "Farm configuration wizard" on-time jobs (none)
  • did the installation three times
  • use Stsadm -o updatefarmcredentials cmd (just for sure, I already checked all accounts and I am logged to server under one of theese, so passwords works)

Messages:

Operations started by an earlier run of the Farm Configuration Wizard 
are still in progress. You must wait for those operations to complete 
before running the wizard again. You can monitor the status of these
operations by looking at the "Farm Configuration Wizard" timer job on the 
Timer Job Status page in the Monitoring section of Central Administration.

ULS logs

Message for task upgrade is An exception of type Microsoft.SharePoint.Administration.
SPUpdatedConcurrencyException was thrown. Additional exception information:
An update conflict has occurred, and you must re-try this action. The object
SPUpgradeSession Name=Upgrade-20150505-133224-212 was updated by (account),
in the PSCONFIG (3752) process, on machine (name).  View the tracing log for
more information about the conflict.

Psconfig

enter image description here

... and PSCDiagnostic log shows something similar to this:

This local server is joined to a farm.  
Attempt to upgrade administration content database SPContentDatabase Name=SP_CA_Content 
Returning SchemaVersion [15.0.146.0] for Database SP_CA_Content, Status = Online.   
Returning SchemaVersion [15.0.146.0] for Database SP_CA_Content, Status = Online.   
UpgradableBuildBypassInternal = 0   
UpgradableBuildBypass = 0   
Returning SchemaVersion [15.0.14.0] for Database SP_CA_Content, Status = Online.    
Returning SchemaVersion [15.0.14.0] for Database SP_CA_Content, Status = Online.    
UpgradableBuildBypassInternal = 0   
UpgradableBuildBypass = 0   
CanUpgrade [SPContentDatabase Name=SP_CA_Content] returned: True.   0
Returning SchemaVersion [15.0.146.0] for Database SP_CA_Content, Status = Online.   
Returning SchemaVersion [15.0.14.0] for Database SP_CA_Content, Status = Online.    
NeedsUpgrade [SPContentDatabase Name=SP_CA_Content] returned: False.    
calling Prejoined farm level actions.   
Entering upgrade for [SPPrejoinedFarm]
Delegate [Microsoft.SharePoint.Search.Upgrade.SPSearchServiceSequence2] returned not applicable for [SPPrejoinedFarm].  
Delegate [Microsoft.Office.Server.Search.Upgrade.SearchServiceSequence2] returned not applicable for [SPPrejoinedFarm]. 
CanUpgrade [SPPrejoinedFarm] returned: True.    
[SPTree Value=SPPrejoinedFarm] added to dependency cache by lookup  
[SPPrejoinedFarm] IsGrown=False IsRoot=True IsLeaf=True.    
NeedsUpgrade [SPPrejoinedFarm] returned: False. 
Skip upgrading [SPPrejoinedFarm].   
Exiting upgrade for [SPPrejoinedFarm].  Elapsed Time=[00:00:00]
Using local farm SPFarm Name=SP_Config.

... and what confuse me as well are the build numbers, I’m installing 15.0.4569.1506, not something like .146… Event log is clean (beside theese two messages). Also good to be mentioned: this is clean new installation, not upgrade or migration.

Google or stackexchange gives me a lot of (2010) articles where clearing the cache or password for account helps, but not in my case :( What I overlooked? I will be glad for any suggestions, thank you.

  • 1
    i appreciate the way you present your questions...Quick question. You said that 1st config wizard run successfully and you can access the central admin....after that did you create the state service using the wizard from central admin? – Waqas Sarwar MVP May 5 '15 at 14:10
  • Thank you. First round was done through PowerShell only, until Search Service stop responding. That lock my databases and stop services for the first time. I think I did something wrong and re-install it, than try PowerShell for some things (state, subscription) and the last round was done through wizard completely (the basic set of services). – Molik May 5 '15 at 14:27
  • If basic farm configured using the GUI and you can access the central admin. then what happen when you try to provision the state service...please check the uLS logs and Event Log and SQL logs...this will give the idea....i am thinking may be account permission issue – Waqas Sarwar MVP May 5 '15 at 15:45
  • Should be... I'm not able even run installed SQLE under account, which was used for installation because of missing "Log on as a service" rights, suddently disabled by GPO I think. I will try to solve this issue and try my SP installation for 4th time – Molik May 7 '15 at 11:11
  • that's what i were thinking, log on as service & log on as batch rights of the account. – Waqas Sarwar MVP May 7 '15 at 11:12
0

What i am thinking, it is permission issue. You service account don't have enough rights to provision this.

Make sure Services account should have following rights.

  • log on as batch rights
  • Log on as a service

A very good reference about the service account.SharePoint 2013: Group Policy Considerations for a SharePoint Farm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.