As the subject says - i'm trying to remove an application pool using the SP Management Shell (using Administrator).

I have a pool named SharePoint - User Profiles

I try to remove this app pool by running the remove-spserviceapplicationpool command and then typing SharePoint - User Profiles and it blows up on me...

Here's an example of the input/output:

PS C:\Users\shsetup> remove-spserviceapplicationpool

cmdlet Remove-SPServiceApplicationPool at command pipeline position 1 Supply values for the following parameters: Identity: SharePoint - User Profiles

Remove-SPServiceApplicationPool : Object not found. At line:1 char:32 + remove-spserviceapplicationpool <<<< + CategoryInfo : ObjectNotFound: (Microsoft.Share...ApplicationPo ol:SPCmdletRemoveI...ApplicationPool) [Remove-SPServiceApplicationPool], I nvalidOperationException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRemoveIi sWebServiceApplicationPool

Remove-SPServiceApplicationPool : Object reference not set to an instance of an object. At line:1 char:32 + remove-spserviceapplicationpool <<<< + CategoryInfo : InvalidData: (Microsoft.Share...ApplicationPool: SPCmdletRemoveI...ApplicationPool) [Remove-SPServiceApplicationPool], Null ReferenceException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRemoveIi sWebServiceApplicationPool

Any help would be much appreciated! Thanks, Taps

  • I have the exact same issue, was your issue resolved?? There is no typo and the Get-spserviceapplicationpool does list the object Name ProcessAccountName ---- ------------------ SecurityTokenServiceApplicationPool BROWER\SPP_Admin SharePoint - User Profiles BROWER\SPP_Ups but Remove-SPServiceApplicationPool -Identity "SharePoint - User Profiles" does not work neither does, Remove-SPServiceApplicationPool "SharePoint - User Profiles" Any help is appreciated!! Thanks.
    – user6589
    Jan 26, 2012 at 20:55

3 Answers 3


Hyphen in name of the service application pool is not a problem. I just created and removed it without any problem. Make sure there is no typo. Also make sure make sure it is listed in Get-spserviceapplicationpool


Try: remove-spserviceapplicationpool -identity "SharePoint - User Profiles"

That should help.


Tip: I found out that when I tried to use
"remove-spserviceapplicationpool [Applicationpool name]" and
"remove-spserviceapplicationpool [GUID]"
both returned "object not found" and "object reference not set to an instance of an object" However,
"get-spserviceapplicationpool | select name,id"
did return the AppPool listed with all the other AppPools. Tried many things before I found out that there was an unintentional space in the AppPoolName. As soon as I entered the AppPoolName with quotationmarks, leaving the space where it was, I had no problems removing it...
So, yes, this was a typo, but one where I least expected it to be. I wonder whether this incorrect use of the naming of the AppPool was what caused the errors in my Search Service App...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.