1

Ran this

$account = Get-SPManagedAccount "domain\svc_spspfarm"

Then I ran this

$appPool = New-SPServiceApplicationPool -Name SubscriptionServiceAppPool -Account $account

The app pool is displayed when I run: Get-SPSeriviceApplicationPool.

Running this

$appSubSvc = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPoolSubSvc -Name "SubscriptionServiceAppPool" -DatabaseName "SettingsServiceDB"

Fails with

New-SPSubscriptionSettingsServiceApplication : Cannot validate argument on parameter 'ApplicationPool'. The argument is null. Supply a non-null argument and try the command again. At line:1 char:76 + $appSubSvc = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appP ... + ~~~~~ + CategoryInfo : InvalidData: (:) [New-SPSubscript...viceApplication], ParameterBindingValidationException + FullyQualifiedErrorId : ParameterArgumentValidationError,Microsoft.SharePoint.PowerShell.SPCmdletNewSubscriptionSettingsServiceApplication

$proxySubSvc = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $appSubSvc

1 Answer 1

0

In your New-SPSubscriptionSettingsServiceApplication command, you referenced the app pool as:

-ApplicationPool $appPoolSubSvc

But in the code earlier you defined the app pool as: $appPool = [...]

Perhaps you meant:

$appSubSvc = New-SPSubscriptionSettingsServiceApplication -ApplicationPool $appPool -Name "SubscriptionServiceAppPool" -DatabaseName "SettingsServiceDB"
4
  • TY for input, can't believe I missed the variable issue! Still not working though. Should I attempt to delete what was created and start over? The App management service is running, I did that through CA. I haven't messed with this stuff in a long time so I appreciate your help. Feb 22, 2017 at 14:57
  • I'm not sure what you mean by "still not working". Feb 22, 2017 at 16:43
  • Did you create the proxy? $proxySubSvc = New-SPSubscriptionSettingsServiceApplicationProxy -ServiceApplication $appSubSvc Only other thing I can think of is permissions - from technet: Verify that you have the following memberships: -securityadmin fixed server role on the SQL Server instance. -db_owner fixed database role on all databases that are to be updated. -Administrators group on the server on which you are running the Windows PowerShell cmdlets. Feb 22, 2017 at 16:47
  • After deleting the app pool I closed the PS window, and retried the process. It worked just fine this time. The only thing I did differently this time was to close the PS window after I deleted the App Pool from the previous attempt. Thanks for hanging in there with my poorly articulated half-thoughts! Feb 22, 2017 at 18:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.