We are using SP2013 on-premise. On a site collection there is a document library. There are several users with "Manage Permission" permission. Based on their need, they will change the permission on individual documents (permission inheritance is broken).

However, when they try to share the document to other users, the default permission level choice is always "Edit". Can we change the default choice to be "Contribute". (Screenshot for reference only, could get with EDIT access)

enter image description here

2 Answers 2


If you have enough rights in the library, I think you already have in this situation, you could invite/add user directly in classic interface of library for changing permissions. Click Share with => Choose Advanced => Add someone in the library with contribute rights.

  • When I try to add them, by default access Level is EDIT, i can change it to contribute, but I want this to be default Contribute . Out come should be as shown in attached screenshot.
    – Rohit
    Commented Jul 23, 2015 at 7:41

When user click Share , in pop up you will find two options in dropdown 1. Can Edit --> This will add user as Contribute level access 2. Can View --> This will add user as Read level access

Screenshot for reference

  • We are going through Advanced option, as permissions are being given at the Folder level Above suggestion works at document level.
    – Rohit
    Commented Jul 23, 2015 at 8:19
  • Is your problem solved or need any other help ? Commented Jul 23, 2015 at 9:15
  • please see my comment
    – Rohit
    Commented Jul 23, 2015 at 10:14
  • Can you elaboreate a little. Finding difficuly in understanding your comment. Commented Jul 23, 2015 at 10:24
  • If I go to one of the subfolder in document library . Click on "Shared with" => Advanced permissios=> Now break the inheritance => Click Grant permission => Here I see that by default EDIT permission level is chose, I have to manually change it to Contribute. ANy way to make it contibute by default?
    – Rohit
    Commented Jul 23, 2015 at 10:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.