0

I'm trying to get some data from external content type from SQL server by using my windows identity, but when I add a new connection in SPD, and choose user's identity to connect, a error message pop up stating this:

enter image description here

I confirmed there were no typo in sever name and DB name as I used them in data source page(I was able to add my SQL server as a data source with a user's sql login).

I confirmed my windows identity has permission to access my SQL server since I was able to log in to SQL server management studio and view tables with my windows authentication.

So, what's potentially causing this problem, and how should I troubleshoot/fix it? Thank you!

  • can you check the logs for potential error? – Waqas Sarwar MVP Jul 14 '15 at 14:24
  • are you accessing the site with your user identity? that might be an issue – Waqas Sarwar MVP Jul 14 '15 at 14:26
  • @ Waqas Sarwar MCSE, I'm checking the log, yes, I'm accessing the site with my user identity, but it's same as my windows credential. – SSilicon Jul 14 '15 at 14:36
1

You need to check the Uls Logs(may be enable the verbos for BCS) and also check the Application logs on sharepoint server as well as on the SQL server.

  • Thanks for your help! I resolved this error by set SQL server browser service to automatically start in "service", and in SQL configuration manager, I set "built-in account" of SQL server browser to "network service", and I was able to start the SQL server browser service, and I thus I was able to connect to SQL server from my computer. – SSilicon Jul 14 '15 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.