0

I have set up a certificate in IIS and added it to the website binding for a newly migrated SharePoint 2013. The certificate has been moved from Production which was 2010 environment. I Have migrated User Profile Sync and sucesfully done a sync. Certificate has been added to trust under Security in SharePoint administration.

No matter what domain\user i try it will not log into my "https://intra.sharepoint.com".

Any ideas on how to solve it or get into the SharePoint site?

  • When you say it will not log on, are you repeatedly getting logon prompts? Are you logging in from the server or a client machine? – Simon Doy May 28 '15 at 11:30
  • logging in from server, inputs login, it thinks for 1 second then I recieve just a New request for login – Skruf May 28 '15 at 11:30
  • Is authentication via Windows and NTLM rather than Kerberos? – Simon Doy May 28 '15 at 11:35
  • It's set up for Windows auth since migrated database from sp2010 was this type of login – Skruf May 28 '15 at 11:36
0

A couple of things then:-

  • what happens when you login from a client machine?

You could be hitting an issue where the server will reject the request as its coming from itself. See this article on approaches to fix, I recommend the BackConnectHostNames approach.

https://support.microsoft.com/en-us/kb/896861

You will need to reboot the server after implementing the registry fix. Make sure you add all the Web Application URLs that you can access SharePoint using, think about the mysites web application and central admin.

To ensure SharePoint and IIS respond to the url https://intra.sharepoint.com you will need to do the following:-

  • ensure that you can resolve the name intra.sharepoint.com to the IP address of your server that is hosting SharePoint. Create a host entry in c:\windows\system32\drivers\etc\hosts file. If your server has the ip address 192.168.1.10 then add the entry 192.168.1.10 intra.sharepoint.com

Presuming that we only have https://intra.sharepoint.com bound to port 443 and we have a single IP address assigned to the server then you could remove any SNI bindings for the SSL connection in IIS.

Lastly setup SharePoint Alternate Access Mappings through Central Admin->System Settings->Alternate Access Mappings and add https://intra.sharepoint.com as a public url.

https://technet.microsoft.com/en-us/library/cc263208.aspx

  • At the time nothing can Reach it, still in test environment – Skruf May 28 '15 at 11:38
  • Once implemented and server rebooted you'll be able to login. – Simon Doy May 28 '15 at 12:17
  • Thanks but this fix is intended for much older Versions of Windows, i am using server 2012 With sp2013. Still safe? – Skruf May 28 '15 at 12:41
  • Yep still the same thing, I do it on all my 2012 r2 builds. – Simon Doy May 28 '15 at 12:47
  • Implemented, only now there is not request for login just simply "page can not be displayed" – Skruf May 28 '15 at 13:41
0

It turns out the main problem was not SSl at all. Since my setup involves a Remote blob store, i need Libraries added for this on my webservers. Reference https://technet.microsoft.com/en-us/library/ff629463.aspx

I downloaded the Library(it says sql 2008 but seems to work on 2014 too) and ran these in PowerShell:

1 time on 1st web server:

msiexec /qn /lvx* rbs_install_log.txt /i RBS_amd64.msi TRUSTSERVERCERTIFICATE=true FILEGROUP=PRIMARY DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" FILESTREAMFILEGROUP=RBSFilestreamProvider FILESTREAMSTORENAME=FilestreamProvider_1

1 time for every other webservers:

msiexec /qn /lvx* rbs_install_log.txt /i RBS_amd64.msi DBNAME="WSS_Content" DBINSTANCE="DBInstanceName" ADDLOCAL=Client,Docs,Maintainer,ServerScript,FilestreamClient,FilestreamServer

You can find info about these commands in the referenced link about RBS and SharePoint.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.