2

I am having a problem activating the CRM List Component for SharePoint (which is just a .wsp file). I went to Site Settings -> Web Designer Galleries -> Solutions and uploaded the solution. No problem there. Then I clicked Activate in the command bar. On the pop up window, there is an activate button, which on my first try, was clickable. I clicked it. However, the solution does not have a status of Activated.

enter image description here

Also, the Activate button is still enabled in the Commands bar. Deactivate is disabled. So when I click Activate to try again, this time the Activate button within the pop-up is disabled.

enter image description here

Can you offer any advice?

  • Which logs? ULS, IIS? On the SP server? – Paul May 12 '15 at 19:24
  • which browser you are using? did you close the browser and check back if solution is already activated? becuase it take some time to be acitvate – Waqas Sarwar MVP May 12 '15 at 19:24
  • Check event log, then ULS on SP Server – Amal Hashim May 12 '15 at 19:24
  • @WaqasSarwarMCSE I tried both IE and Chrome. Neither worked. I activated the solution, went on a lunch break, came back and it still had an empty status. – Paul May 12 '15 at 19:25
  • did you close the browser? check the ULS logs and Event log...when you first time click on the activate.....another thing just try to delete it and readd... – Waqas Sarwar MVP May 12 '15 at 19:26
2

You cant activate this solution without starting the User Code Services.Sow hen you download the solution from the MSFT site, You will get CRM2015-SharePointList2013-ENU-amd64.exe file, once you extracted it you will get 3 files.

  1. AllowHtcExtn.ps1
  2. crmlistcomponent.wsp
  3. mscrmsharepointeula

Now what should you do inorder to work.

  1. Add the wsp into the site collection( which you already did)

  2. Run the Powershell script on the server(AllowHtcExtn.ps1), this will

    • Starts a user code service. as well as

    • Adds the .htc file extension to the list of allowed file types for the specified SharePoint 2013 Web application.

Now you will be able to activate it.

| improve this answer | |
  • When I ran the PowerShell script that MS provided, on my SharePoint dev server, I got this error - Cannot index into a null array. + CategoryInfo : InvalidOperation: (:) [], ParentContainsErrorRecordExc eption + FullyQualifiedErrorId : NullArray – Paul May 13 '15 at 21:04
  • I m not sure about, I ran the script from browser, open the power shell console as admin...it's worked as a charm. – Waqas Sarwar MVP May 13 '15 at 21:05
  • Okay, I ran the PowerShell console as administrator. I am now getting a new error. The starting of the User Code Service succeeds, but when it tries to enable HTC files, it says - Cannot find an SPWebApplication object with Name, Id or Url: http://internaldev.mysite.com/sites/Dynamics%20CRM. – Paul May 13 '15 at 21:44
  • Is it your webapp or code's? Also try to activate the solution as code service is runnin... – Waqas Sarwar MVP May 13 '15 at 22:24
  • I changed the url used to just http://internaldev.mysite.com and it ran without errors. I'm not sure if it actually enabled HTC files correctly, but I guess that's another topic... – Paul May 13 '15 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.