10

I have an InfoPath Form which submits the text of a textbox and saves it in a SharePoint list. Whenever a user types in more than 255 characters and I want to edit the element in the SharePoint list (e.g. change the value of a custom field) an error appears that the textbox cannot contain more than 255 characters.

It's weird because initially the column can contain more than 255 characters but as soon as I want to edit the element, I get this error.

My question is: How can I turn off the limitation OR how can I display a character counter next to my InfoPath textbox?

Thanks for your help

19

You have to check the "Allow unlimited length" checkbox on the list column's properties page.

  • 1
    Thanks, that works fine if I create a new column. Unfortunately, I can't change the property for an existing column, is it possible to change it? imagebanana.com/view/7ovt483z/Unbenannt.png – aydinch Jun 8 '11 at 14:22
  • 1
    are you sure you are in the list settings and the clicked the list column? Another thing is you might have enough permissions to do this – Colin Jun 8 '11 at 14:24
  • 1
    I think the setting cannot be changed on some default columns. On custom column types you should be able to change this setting even after creation. – Shihan Jul 6 '11 at 8:50
  • 1
    Thanks Colin it worked for me :) I was using a designer form with lots of dynamically created fields in it, was all working fine till today, still cant find out what happened suddenly. – user4686 Sep 7 '11 at 19:34
  • Very helpful answer, +1. One of the reasons I dislike SharePoint. – JᴀʏMᴇᴇ Jan 17 '13 at 17:01
1

Another good option from another thread:

How to increase the number of characters limit in hyperlink column type

  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Asad Refai Apr 11 '18 at 8:53
  • @AsadRefai Internal links are OK :-) – Benny Skogberg Apr 11 '18 at 8:56
  • 1
    Cheers @BennySkogberg :) – Asad Refai Apr 11 '18 at 9:13
  • 1
    @BennySkogberg IMO it should be a comment, not an answer - as it doesn't carry any information other than the link. They might have posted it as an answer as they don't have enough rep to post comments yet. – Nisarg Apr 11 '18 at 18:21
  • 1
    @Nisarg True! I’ll convert tmrw when on PC – Benny Skogberg Apr 11 '18 at 19:05
0

Forget about InfoPath for a minute. Go directly into the SharePoint list settings and update the field properties. Take out the 255 limitation. Save your changes and then open a new InfoPath form and point it at the list. It will pick up all of your previous changes and as well, your field will not have this 255 length limitation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.