7

I'm having a weird issue right now where none of the new events created on this calendar are appearing on the actual calendar. If, however, I change the view to "All Events", it will show my created event. I had been trying to create a conference room/multi-view setup where users pick a room and fill out the new event form with fields I added and it was working fine, but then I made some changes to the form - enough changes where I can't remember what all I removed and added, but that's when it started to be a problem.

It seems to apply to all newly created calendar lists too (because I thought I'd try just removing the problematic calendar list and add a new one, and I still can't see the events on the calendar). I've tried to ensure I've set all of the Content Type columns back to their defaults, I've removed any created views and I still can't get new events to appear on the calendar.

I'm going insane trying to figure out what I did... any help would be greatly appreciated.

4

See if the below threads help in your situation. I've copied excerpt from the 1st link below. Hope this helps!

https://social.msdn.microsoft.com/Forums/sharepoint/en-US/3374c101-e91d-49b2-bd03-00bdd842734a/calendar-view-does-not-display-all-items

https://social.technet.microsoft.com/Forums/sharepoint/en-US/8a18f211-ecff-44c8-93d9-53d1eb36dece/enabling-resource-reservation-causes-calendar-events-to-disappear?forum=sharepointadminprevious

"It sounds like you have switched on the "Group Calendar Options" for your calendar. These add new content types to the calendar ("Schedule", "Reservations", and "Schedule and Reservations") in addtion to the standard "Event" content type. These new content types each come with their own specific behaviour. Yor screen shot showing the Attendees field looks like it's using the "Schedule and Reservations" content type.

To check this, go to the "Title, description and navigation" settings page for the calendar (this is the first option under "General Settings" on the List Settings page). You will see two settings in the "Group Calendar Settings" sections. Set both of these settings to NO. This will remove the special content types from the calendar - you will be left with only the standard "Event" content type, which should then behave like you are expecting (ie, everyone can see all events)."

  • This was exactly it... I thought I checked this, but I guess I didn't... I appreciate it. – RedMageKnight Jan 21 '15 at 16:16
  • Two years later, and this just saved me from a ton of head scratching and confusion. THANK YOU! – Caola Jan 13 '17 at 15:32
0

I had the same issue and ended up just deleting the event CT and replacing it with the schedule CT. If you already have content on the list, be sure to add the new CT and then save your existing content with the new CT, and then delete the event CT.

0

Sometime it happens because of some of the CSS properties. For me following was set on my page and once I removed it then my events started appearing fine in Calendar.

  • { position: relative; //Remove this or set as static}
0

Just an update, There is now a setting for using the list or calendar as a way to share individual calendars with the group. I tried to find the setting to type in but I can't.

That made my events invisible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.