3

I’m having a problem with my Calendar datepicker in Sharepoint 2013. It’s like it is missing some CSS.

enter image description here

And I get the below error in my console :

Resource interpreted as Stylesheet but transferred with MIME type text/html: "http://hub-pilot.com/programs/ftmba/2016/_layouts/15/defaultcss.ashx?ctag=21". iframe.aspx?&cal=1&lcid=1033&langid=1033&tz=-08:00:00.0003650&ww=0111110&fdow=0&fwoy=0&hj=0&swn=Fal…:5

A solution I have tried, but did not work is as follows:

  • Placing Master Page in same folder of masterpage

I have all my styles/layouts/css/js in a separate folder in the masterpage folder. I have this working on one site collection, but for some reason it is not working on this separate one.

Any thoughts?

1

Try creating a root(/) site collection in the web application and see if it fixes the problem. I have seen this issue with SharePoint 2010 under certain situations.

  • I've seen this as well when certain Javascript and CSS files don't download correctly. Have a look at the resources being called and loaded when the page opens. If that is the case you may have a bad cache somewhere (SP servers, or Load balancer) that you will need to clear. – Jesus Shelby Mar 30 '15 at 15:56
0

It looks you created your own master page. Use GhostableInLibrary type in Elements.xml and reactivate feature which includes this master page.

File Path="My.master" Url="My.master" Type="GhostableInLibrary" ReplaceContent="TRUE"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.