I have a rather strange scenario. I upgraded from SharePoint 2007 to SharePoint 2010 and assumed my permissions will pull through correct, note that I am on AD, which didn't quite work the way I expected.

So, I started re-adding my contributors to their respective sites and found that they are no longer permitted to create new sites or pages. The have Designer, Manage Hierarchy permissions set so I fail to see why, so thought I'd dig around the ULS to find out more:

Microsoft.SharePoint.SPException: Microsoft.SharePoint.SPException: Provisioning did not succeed. Details: Failed to initialize some site properties for Web at Url: 'http://blt-webfe-03.ad.za' OriginalException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) > System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

A quick Google search brings back a lot of information around team sites and other nice things but nothing around publishing templates, so I ran this several times to build a quite a big log and found that after the provisioning of Feature {22A9EF51-737B-4ff2-9346-694633FE4416} fails, SharePoint successfully deletes the page, but then complains that my user could not be found in AD?

This is so confusing and I really don't know where else to look. Has anybody else run into this, and come up with a solution?

1 Answer 1


I had same issue - this post http://blog.beckybertram.com/Lists/Posts/Post.aspx?ID=181 solved the issue for me - I had to grant the required users read access to the MasterPage gallery

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.