I have encountered an error in the web export/import routine. The thing is that the feasibility of import seems to depend on the statу of the web.

I have several subsequent export packages of the same web and say #2 works fine (I can see it extracting the contents of the package and the result is that the web is imported) and #3 fails (I don't see the files being extracted and the import fails almost immediately).

Import-SPWeb -IncludeUserSecurity -Path C:\Install\exportweb2.bak -Identity https://test.company.com/sites/home -Force

Log file generated: C:\Install\exportweb2.bak.import.log

Import-SPWeb -IncludeUserSecurity -Path C:\Install\exportweb3.cab -Identity https://test.company.com/sites/home -Force

Log file generated: C:\Install\exportweb3.cab.import.log

Import-SPWeb : Could not find file 'C:\Users\adm_user\AppData\Local\Temp\0cf9aa8f-fc19-401f-a094-0c6cabde6f6b \ExportSettings.xml'. At line:1 char:13 + Import-SPWeb <<<< -IncludeUserSecurity -Path C:\Install\exportweb3.cab -Identity https://test.company.com/ sites/ipms -Force + CategoryInfo : InvalidData: (Microsoft.Share...CmdletImportWeb:SPCmdletImportWeb) [Import-SPWeb], FileN
otFoundException + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletImportWeb

The following is logged:

[23.05.2011 10:07:22] Progress: Initializing Import.
[23.05.2011 10:07:22] Warning: Import requirement file C:\Users\adm_user\AppData\Local\Temp\3\9f0699d5-bb0d-4e27-ab44-6d8f534b0271\Requirements.xml was not found no verifications ran.
[23.05.2011 10:07:22] FatalError: Could not find file 'C:\Users\adm_user\AppData\Local\Temp\3\9f0699d5-bb0d-4e27-ab44-6d8f534b0271\ExportSettings.xml'.
[23.05.2011 10:07:22] Debug:    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
   at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
   at System.IO.FileInfo.Open(FileMode mode, FileAccess access, FileShare share)
   at Microsoft.SharePoint.Deployment.SPImport.DeserializeExportSettings()
   at Microsoft.SharePoint.Deployment.SPImport.Run()
[23.05.2011 10:07:22] Progress: Import did not complete.

The adm_user account is a local administrator on all the machines in the farm except SQL Server and the SPShellAdmin rights have been granted.

There definitely are the Requirements.xml and ExportSettings.xml inside the package, I checked this with my archiver.

I believe this is rather a common trouble to shoot and any help would be appreciated.

3 Answers 3


Check the size of your export package. There is a default cab size of about 25Mb - this used to be a limit you had to increase with stsadm by setting a parameter. With the PowerShell Export-SPWeb cmdlet it generates multiple files if you hit the limit. You may need to change this limit using the CompressionSize parameter to set the cab size (up to a maximum of 1024Mb).


Export-SPWeb http://mysite -Path c:\backup\ExportFile -CompressionSize 1000

I have same error but other resolution - I have missed backup files (if backup size is larger than 25 mb by default, sharepoint backup created multiple files).


I had a similiar problem. I also exported a web (with subwebs) and got several packages. When I tried to import individual packages, I got the error you describe. If I imported the main package though (e.g. exportweb.bak, exportweb.cmp) - it imported the web (and subwebs) fine.

This may not be the exact problem you're describing though, is it?

  • 1
    1. I think this answer should be a comment. Commented May 23, 2011 at 7:13
  • 2. It looks similar to what you describe but the difference is that both packages are generated with the same Export-SPWeb syntax and the difference was in the state of web content and the package file name. Nothing else to my knowledge. Commented May 23, 2011 at 7:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.