3

I'm trying to copy a Production Site over to my Development server using DocAve which I have done successfully many times. But I'm having a problem with a particular site. Even though it copies over correctly when I try to access the site I get the "A Web Part with this ID has already been added to this page" error. Can anyone advise how I can fix this issue?

2

You can add ?Contents=1 to the page url and see what all webpart are installed.

#From
http://portal/Pages/Blog.aspx

#To
http://portal/Pages/Blog.aspx?Contents=1

If duplicates exists then you can select those and delete.

If that didn't resolve, then you can probably remove all webpart and add it using Insert WebPart option.

| improve this answer | |
0

as amal noted you need to add contents=1 to the url page that shows this error! and remove the offending webpart that has the error or is in error state!

it could possibly also be that your using the wrong template when the site is created well i say you i mean avepoint is! The template being used usually must be the same as the one that was used on the source site ;) .

I hate using these third party rubbish applicaitons that claim todo what you can do for free and far quicker! yes they can do easy tasks as they are ok but when it comes to complex migrations or sometimes simple migrations they not only fail they do it in style and time :)

how about do it the ms approved way? use export in powershell or if its 2010 to 2010 or 2013 to 2013 than just export the content database via SQL server. Save the file to the dev enviroment. In the dev enviroment you can create a web application and create a site collection.

now in central admin detach from the content database the webapp you just made. Goto SQL server on dev and overwrite the detatched content database with the one you migrated over!

once complete you can then use powershell to re attach back the content databse.

once complete goto the web application url and you should have a working mirror copy of the origional site without ID missmatch!!

all done! else if your insistant on using docave make sure there is a checkbox that you can tick to change the guids of webparts when it exports so that the ids are different in content database!

Migration of SharePoint from 2007 to 2010/2013

| improve this answer | |
0

Thanks Ali/Amal. I tried the ?contents=1 but I got an error and it never showed me the Web Parts so I wasn't able to delete them from there. Maybe my case is unique but this is how I was able to fix it.

Instead of using DocAve I used PowerShell and exported the site. I then went and created a basic site and proceeded to import the exported site. The process would stop and again give me the duplicate error. So I used the ?contents=1 on the basic site and deleted the Web Parts. Tried importing the site again but with no luck.

So I verified the import log and noticed that the problem was not a Web Part but a document library, the Shared Document library to be exact. So I deleted and recreated the basic site and proceeded to delete the Shared Document library from the basic site. I then tried the ?Contents=1 to delete any Web Part but none appeared on the list. Somehow deleting the library removed the Web Parts associated with it. I then proceeded to import the site via PowerShell and it worked.

Again thanks for your help.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.