When I click on the edit icon nothing happens. No errors, no post back nothing. I ended up turning on the Console in FireBug and it throws this error:

SP.Ribbon.PageState.ImportedNativeData is undefined
     if ($p0 === 'PageStateGrou...['ItemIsCheckedOutToCurrentUser']) { 

The location of the JS is:


I Googled the top part of the error and found only one person who had this problem. Someone suggested they add ?content=1 to the end of the URL. Tried that but no luck.

Has anyone seen this before? Any suggestions?


Ran it in IE and got a little more info:

Message: 'SP.Ribbon.PageState.ImportedNativeData.PageState' is null or not an object
Line: 3468
Char: 13
Code: 0
URI: http://my-pc/_layouts/sp.ribbon.debug.js?rev=lc6eCMZP6gL5LnuSYh0S6Q%3D%3D
  • I had the same problem in a SharePoint 2013 publishing site. I created a page, put into Edit mode, works fine as there are no webparts. Once I have added the webpart and saved the changes, then "Edit" mode doesn't work. Nothing happens, in fact. Check out and put into Edit mode, it works. So Pitso's answer is right. Oct 31, 2017 at 17:32

6 Answers 6


Even if the error points to the ribbon, it is quite possible that the actual cause is a script running before you use the ribbon.

As your custom script was added via a Web Part, the easiest way is to remove the culprit. As you were told, append ?contents=1 to your page URL, and you will be sent to the maintenance page. On that maintenance page, you can select and delete the Web Part that caused the issue.

After you delete the Web Part containing the JavaScript, go back to your page and confirm that the ribbon is now working.

The next step will be to figure out why your script was not working...Start a new question on SharePoint Overflow! (or talk to the author of the script).

  • 1
    So in what way was this answer any better than jorgens? Apr 24, 2011 at 19:22
  • what do you mean, "jorgens"?
    – Christophe
    Apr 25, 2011 at 1:05
  • 1
    I mean Muhimbi :) Apr 25, 2011 at 13:29
  • ok :) Well, Muhimbi provided a clue, not a full answer. Obviously the OP needed more guidance.
    – Christophe
    Apr 25, 2011 at 13:46

I believe it is ?contents=1, you missed out the 's'

  • Hmmm, that took me to an entirely different page. Even if that did work it's not a real solution. People need to be able to edit pages with this web part without putting stuff into the Query String. Apr 24, 2011 at 7:48
  • 1
    You are only supposed to use ?contents=1 when you as designer are experiencing trouble with newly added webparts that need to be removed. Normal users dont have the privileges to do this. Apr 24, 2011 at 8:00

What does the imported webpart do?

Have you modified the ribbon on the page? If so it may help to disable the feature containing the modification.

  • The webpart is an autocomplete textbox. It makes use of jQuery, a bit of custom javascript and SharePoint webservices. I have Custom Web Part Properties also. I haven't made any changes to the Ribbon (intentionally at least...) Apr 24, 2011 at 7:31
  • A thing to try is to remove the webpart and retract the feature that provisions the javascript. If this solves the issuenon the page, you either have errors in inline JS/jQuery or in your javascript Apr 24, 2011 at 8:02

My experience was that the page was created with the SharePoint Server Publishing feature turned on. The site feature was later deactivated and the page could not be edited. Re-activating the feature enabled editing.


We had the same problem. We would try to edit an existing page and it would just sit there.

I clicked on "show ribbon" and it showed the page was checked out to somebody else. I overrode the checkout, and then it appeared I could make changes to the page.

I don't know why it didn't tell me it was already checked out, but apparently it was. Hope this helps.


In case someone is experiencing the same issue, this is how I solved the problem.

  1. Navigate to the page you are trying to edit
  2. On the ribbon click on Page
  3. then click check out

Try to edit your page again

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.