1

I have done some minor fixes to a timerjob, which writes to ULS after every step and error, but, for some reason after last deployment, it fails and is most confusing to me - doesn't write to ULS (even though from progress it is clearly seen that it should)

1
  • Do you have WSS_Log DB up and running? Aug 19, 2014 at 10:04

2 Answers 2

1

Try these lines to write on the Log file:

SPDiagnosticsService.Local.WriteTrace(0, new SPDiagnosticsCategory("Your Category", TraceSeverity.High, EventSeverity.Information), TraceSeverity.High, "My log text");
4
  • Used practically same line, just with other constructor, in past it worked, now it doesn't
    – Vilius
    Aug 19, 2014 at 9:51
  • try to debug the job and see if u reach the log line
    – Nk SP
    Aug 19, 2014 at 9:52
  • It should looking from progress, but problem is that in local machine it works fine, but in production machine it has this problem, so I can't use debugging either
    – Vilius
    Aug 19, 2014 at 9:54
  • try to put the lines after the Execute method declaration. (and after deployment remember to restart SP Timer Service)
    – Nk SP
    Aug 19, 2014 at 9:55
0

The problem is that the farm was on few machines, so the one on which the project was deployed, wasn't the one on which it worked

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.