What's the deal with Deno? We talk with a major contributor to find out. Listen now.
11

In short, there's another web.config file in the LAYOUTS folder in the 14 hive that you need to change, it's set out fairly well here: http://web.archive.org/web/20130909002813/http://www.khamis.net/blog/Lists/Posts/Post.aspx?ID=12


4

You should put your configuration attributes in the web.config located at C:\inetpub\wwwroot\wss\VirtualDirectories and choose the folder of your Web Application. By the other hand you can use the class SPWebConfigModification to make changes in the web.config file programmatically SPWebConfigModification modification = new SPWebConfigModification("...


4

Yes, the nodes are being alphabetically sorted and the Sequence property only applies when the Name property is exactly the same. To fix, use a little XPath trickery to get your nodes to sort in the correct order (first modules[1=1] then modules[2=2]): SPSecurity.RunWithElevatedPrivileges(delegate { SPWebService spWebService = SPWebService....


4

No, you can't have different web.config for different site collections, however you maybe be able to add tweaks e.g. HttpModule and HttpHandlers configurations to it depending on your requirements...


3

Try adding Both Delegate controls and it should resolve your problem.


3

To solve this error you have to change settings in both the web.config file that one is in the IIS folder and the other web.config file which is in the LAYOUTS folder 15 hive. Simply Change: <customErrors mode="Off"/>


3

How many Servers in the Farm? Web site mentioned in the error ( ****.local80) still exist and working? If you have more than one server in farm, simply copy the web.config file from other server for same Virtual directory and re ran the Config wizard. Or Simply delete the Web Application( i am sure your web app not working as missing web.config) or re ...


3

You will not find the file web.config in this folder C:\inetpub\wwwroot\wss\VirtualDirectories\…local80\web.config' The reason is your web.config file is deleted in your port 80. You have to have web.config file in this folder otherwise you will face this problem. I have the problem in port 40786. The solution is delete the website from your iis server ...


3

It sound's like the web applications get a timeout and does not get created correctly. I've had this problem in both production and staging environment, and changing the time-out has worked perfect both times. This is usually because you either have too many Web Applications in your SharePoint Server, or because your SharePoint Server is slow! As part ...


3

Microsoft's pattern and practices group has published guidance, including a hierarchical configuration manager library. The library uses a list or property bags. You can read more at http://www.microsoft.com/spg. (I would avoid web.config - the change management process for web.config in SharePoint is not reliable.)


3

You could store the connection string in an SPPersistedObject which you could then modify via PowerShell. You can also store it in the SPFarm or SPWeb property bag. I prefer the SPPersistedObject. You can see a real-world implementation of that here: https://github.com/Nauplius/FoundationSync/blob/2013/FoundationSyncSettings.cs


3

If you want to redirect to static HTML pages (hosted in a folder at the root of the Web Site in IIS), the following modifications in the web.config (under <configuration>/<system.webServer>) should do the trick for 404 an 500 errors: <httpErrors errorMode="Custom" existingResponse="Replace"> <remove statusCode="404" /> <...


2

Disclaimer: What I put here is my opinion and based on my experiences. I am interested in hearing what others have to say as well. Generally I think Microsoft tends to set settings like this to be conservative to cut down on the number of possible issues. A similar example is the 50 mb file upload limit where users with bad connections may not be able to ...


2

All (related) host named site collections are sharing the same web.config as they are all located under a single web application (= entry within IIS). Look into the web application list (central administration) to find the parent web application and then adapt the relevant web.config within IIS. Please be aware that I'll have impact on all other HNSC.


2

You need to add the web part type as safe control in the web applications "web.config" file and in the configuration > SharePoint > SafeControls section. The general format is like below: Just replace AssemblyName, AssemblyVersion, AssemblyCulture, AssemblyPublicKeyToken, The class name of the web-part and The class name of the web-part with the information ...


2

You will probably find that changing web.config files to store application settings for SharePoint Features is not your best solution. For an alternate solution that may work better for you, please refer to the Applications Setting Manager of the Microsoft Patterns and Practice SharePoint Guidance. SharePoint 2007 guidance includes a section on Managing ...


2

Below are four ways to set another page as your home page: (all four work for both 2007 and 2010) From Site Settings (If the publishing features are enabled) From SharePoint Designer From code / API From PowerShell The first two can be used by Site Owners, the second two can only be used for developers and administrators. Site Settings (if the publishing ...


2

You need to debug properly without changing the settings! firstly, what web.config are you modifying? where is it located and what version of sharepoint are you using? if its a webpart that your using than the web.config you need to edit will be the web applications web.config. goto IIS manager, web sites -> select the website in question -> right click ...


2

While developing for SharePoint 2010/2013 using Visual Studio 2010/2012/2013, Microsoft provides an excellent integration to package third-party assemblies and safe control entries via package designer. Package designer not only helps you with packaging you SharePoint solutions but also allows you to add the assembly references, SafeControl entries and ...


2

You can not have different web.config for different site collection. If you have different configuration for each sitecollection it is better to use site collection property bag


2

The owstimer is a separate executable and runs as a separate process. So it does not look at the web.config for any specific web application. You have to add the configuration to the owstimer.exe.config in the 14\BIN directory. This config follows all the same semantics of the web.config so you can add appSettings etc just like you would to your web.config....


2

You should recreate your central admin web application using psconfig.exe psconfig.exe -cmd adminvs -provision -port 8080 -windowsauthprovider onlyusentlm http://technet.microsoft.com/en-us/library/cc263093.aspx Restore Central Administration Site


2

From maintenance as well as performance I recommend the use of a Configuration Custom List. During the first request, you can pull the configuration values and store it in either SPWeb property bag. Or user HTTPCache. You can decide a time-frame on how long the cached value should be stored (like read the configuration value after 24 hours etc.)


2

As you said, you could store the url of the service endpoint somewhere and then use that info from your event receiver. Two main options come to mind. Web.Config for the associated web application. By using the SPWebConfigModification class, either from a web application scoped feature or a PowerShell script you can apply modifications to the web.config ...


2

In your web application web.config file (C:\inetpub\wwwroot\wss\VirtualDirectories\%webappname%) you have two parameters: executionTimeout - for waiting time (before timeout) (HTTP request timeout) maxRequestLength - for size of file to upload (HTTP request length) For maxRequestLength, there is a limit of 2 Gb in SharePoint 2010. You can set it using ...


1

The MSDN Article about requireSSL=true specifies that A. you must be using forms authentication or the setting is meaningless, and B. that this means that the connection must be secure to transmit the forms authentication cookie between server and client. What you're looking to have happen is an exception be thrown like this when you try to log in: Stack ...


1

create your user control then add to masterpage: <%@ Register TagPrefix=”myUserControl” TagName=”myUserControlPage” Src=”~/_controltemplates/myUserControlFolder/myUserControlPage.ascx” %> now all you need todo is add the control to where ever you want using this: <myUserControl:myUserControlPage ID=”myUserControl” runat=”server” /> very ...


1

I had a similar issue that resulted in having to do a rebuild of my dev box. What I think happened was that the feature reciever I was deploying was not being retracted correctly on all the sites it was being deployed too. It had been deployed to service application sites, web applications, site collections and sites. My guess was because I had changed ...


1

Okay I found a solution with a console app - seems like a previous modification was stuck: SPWebApplication webapp = site.WebApplication; webapp.WebConfigModifications.Clear(); webapp.Update(); webapp.WebService.WebConfigModifications.Clear(); webapp.WebService.ApplyWebConfigModifications(); ...


1

It appears that this is because you are calling ApplyWebConfigModifications() on the wrong SPWebService object. From How To: Modify the web.config file in SharePoint using SPWebConfigModification: Use the ApplyWebConfigModifications() method on the SPWebApplication object you are saving your SPWebConfigModification object to. I don’t understand why this ...


Only top voted, non community-wiki answers of a minimum length are eligible