6

As per your description it seems that there is a problem in your custom Master Page configuration. Also it seems that only Site Permission page is throwing an error. So the possible problem is your custom Master Page is missing some Site Permission relevant tag. Please compare it with the existing Seatle Master Page and check for the missing tag.


4

Well Pedro, while you are right that the master pages are used for different types of pages, you're a little off on which types of pages use which type of master page. Publishing pages in your publishing site will use the site master page that you specify. These are the pages that are stored in the Pages library of your site by default. Publishing pages use ...


2

Aside from any API calls, why not just modify the master pages to include some javascript that sets a variable telling which master it is Var master="masters?asps"


2

You can change the masterpages with Powershell. Taken from this link: All pages, except for publishing pages (which you do not have in Foundation) uses the system master. For system master page: $web = Get-SPWeb http://localhost/ $web.MasterUrl = "/_catalogs/masterpage/mymasterpagename.master" $web.Update() For publishing pages master page: Site ...


2

To hopefully add a bit more value to this thread, it should not be necessary to edit the page in SharePoint Designer to set the master custom.master to overcome your problem - if you do you will open up another can of worms whereby a banner is displayed at the top of each page you have modified which reminds users that "The current page has been customized ...


2

I have solved the problem. It was that all of the publishing pages of my site, in the head, they had: "~masterurl/default.master" And they should have "~masterurl/custom.master". Thankyou @rjcup3 because your link was very helpful for me.


2

Yes, there is a major enhancement for creating custom master page between SharePoint 2010 and SharePoint 2013. SharePoint 2013 introduce the design manager that is a publishing feature that is available in publishing sites in both SharePoint Server 2013 and Office 365. With Design Manager, you can create a visual design for your website by using whatever ...


2

If you just want to add a custom CSS and JS to your master page, then instead of creating a new master page, try the following and check if it works for your purpose. For Custom CSS : Use the Alternate CSS Url to set a custom CSS File. For referring a custom JS file follow this approach - http://spdeveloper.co.in/tipsntricks/pages/referencing-js-files-...


2

You can edit the master page HTML file and then add your CSS & JS references. The best practice is to take a copy of seattle.html (html master page) and then work on that. SharePoint online refer custom css and javascript in MasterPage (Site Assets)


1

It was Enterprise mode that was forcing IE to load on IE8. Modifying the Policy we were able to revert it to IE10.


1

IE 10 screws Up lots of thing. I would either use Chrome or force with IE 11. <meta http- equiv="X-UA-Compatible" content="IE=11" />


1

Please check what master page you have used for you sub site . Apply the same to your Root site collection. Navigate to your sub site , Click on Site Actions->Site Settings Under Master page, check what master page has been applied . Now go to the Root site collection and go to the site settings and apply the same master page as it was for the sub site.


1

As @Aveenav is suggesting, it may be that your custom master page is missing the "ms-dialogHidden" CSS class on the navigation controls that is design to hide these elements in a modal dialog. From a sample master not the css class: <div class="ms-dialogHidden"> <SharePoint:AjaxDelta ID="DeltaTopNavigation" BlockElement="true" CssClass="ms-...


1

Add 'ms-dialogHidden' class to nav and breadcrumb div or section.


1

If you are using Site Pages, you do not have the publishing infrastructure enabled, or the site level publishing features enabled. This created Pages in the Pages library, and these use the site master page. "site pages" are foundation based pages that only use the system master page. You can enable the publishing infrastructure assuming you are running ...


1

The Site Master Page set from the settings page affects (or limited to) publishing pages stored in Pages Library when the Publishing infrastructure is enabled or publishing site template is used. For pages stored in SitePages library, you may want to change the page declaration to use dynamic token as shown below <%@ Page Language="C#" Inherits="...


1

This is expected behavior: The Site Master Page, affects Publishing Pages (/Pages) The System Master Page, affects Wiki Pages (/SitePages) http://blogs.technet.com/b/stefan_gossner/archive/2011/04/13/site-master-page-vs-system-master-page.aspx


Only top voted, non community-wiki answers of a minimum length are eligible