Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

New answers tagged

0

You could add managed rules on the "Category" field to achieve this. 1.Click category field-> Managed Rules-> New-> Action Do not change the condition. Add action "Set a field's value" 3.Set the Sub Category field value. Just leave the value blank.


0

To troubleshoot the issue, check things below: Check the user permission for the users who have the empty or corrupt files on the file level. Remove the users from the document library and re-grant the user permission for those users. Create a new document library and map drive for the document library to check if the same issue will occur.


1

No, and do not expect any updates to React or other SPFx components in SharePoint 2019 (outside of potential security issues).


0

Agreed with Maddy's comment. I just completed a SharePoint 2013 to SharePoint 2016 upgrade. The Office Documents in the WOPIframe contain the wrong URL. All other Search results are good. This worked fine in 2013. My Search Crawlers are configured identically between 2013 and 2016. Seems the server mappings are being ignored, only for the WOPIframe results. ...


1

Tryed all solutions above, and nothing worked. The link below ended up working for me. https://sharelockpoint.wordpress.com/2013/09/09/sharepoint-2013-pre-requisites-install-fail-error-the-tool-was-unable-to-install-application-server-role-web-server-iis-role/


1

If you are married to .NET Core your only real option is the REST APIs, and you are going to have to wire up all the code infrastructure and authentication yourself. So, not impossible, but a bit lower level.


1

Let us go through your questions one by one Now i need to log the errors which occur in the JS to my local drive. First at server side, you would need to write a web service which would takes request from client and writes to file in your local drive(this would be your custom application log file and not ULS log) Second on client side, write a common ...


0

Add your code as a single line or remove any indentation. The content editor will format these elements after saving them and will not create additional tags or characters.


-2

Approach 1: Add an entry in to Tenant Wide Extensions List First deploy your SPFx extension at App Catalog tenant wide. Then make an entry in "Tenant Wide Extensions" list which will be available under App Catalog site content. Go to this link for more info This will make your extension available in the newly created site collection. Approach 2: Add it ...


0

Have you changed the old user information to the new user before? I ever met a similar issue because a user's information was changed and the change was not updated to user information list. You can run the timer job “User Profile Service Application - User Profile to SharePoint Full Synchronization” in CA > Monitoring > Review job definitions. A similar ...


0

If you are new about CAML Query to filter user field, you could use CAML Designer to build CAML: CAML Designer Directly pass the display name as filter value: <ViewFields> <FieldRef Name='Author' /> </ViewFields> <Where> <Eq> <FieldRef Name='Author' /> <Value Type='User'>...


0

You need to choose "yes" for "Update all content types inheriting from this type" when changing Content Type column.


1

You can troubleshoot this issue as following: Make sure that the account who open the InfoPath form has enough permission to access the “not exist” list. Try to customize the InfoPath form without change via clicking “Customize Form” button and republish it, check again. If the issue still occurs, I suggest you check the ULS logs, which would tell you more ...


0

Please check the user information list on the site you are trying to add new user. It is highly likely that those 2 users have the same username and the old one (claudia) has been deleted. the new one was create with the same user account. You can delete that entry from the information list but you will loose the history (like when the user edited something) ...


0

The procedure must be completed by a user that has Site Owner permissions. You could refer to this article for more: https://docs.microsoft.com/en-us/sharepoint/dev/general-development/create-a-workflow-with-elevated-permissions-by-using-the-sharepoint-workflo


-1

By default, you can only use display name or id in CAML queries for users. But, display name is only the default because that's what the field is configured to display by default. If I go to the field's settings and change what's to be show in the field, like so: I can now query by user name or id, so: <View Scope='RecursiveAll'> <Query> ...


1

After half day digging into this issue, finally I found the problem, the AutoSPInstaller creates the managed paths per web application but also creates with the HostHeader parameter which means (according to the New-SPManagedPath) that the managed path applies to all host header site collection. So, to remove it I used the code below: Remove-SPManagedPath -...


0

You could use position CSS property with sticky value (doesn't work with IE). You would iterate over the table HTML rows to update row style. However, since it's a table, you need to know which cell refers to the field to freeze. To do so, we will retrieve all our fields index (cells position): var tableFieldsIndex = new Object; // Contains [fieldName] = ...


1

Regarding this issue while creating dropdown(choice) Column. In column setting select default value by choice and keep that field empty by deleting content in it .so after that while creating item it will show error message as "You can't leave this blank".


0

There is a workaround, you can create a Calculated column with the formula “=NOW()”, this column will update when the item is modified, you can create a simple workflow to update the item with some column value changed.


0

Helped me: run PowerShell script, then re-create Search service application: psconfig.exe -cmd helpcollections -installall -cmd secureresources -cmd services -install -cmd installfeatures -cmd applicationcontent -install -cmd upgrade -inplace b2b -force -wait Or you can try index reset + full crawl of all my content sources, but this method did not help ...


1

For your issue, troubleshoot as following: Clear SharePoint Designer cache and then run IISreset . Increase the UserDefinedWorkflowMaximumComplexity to 10000 setting using SharePoint 2010 Management Shell: $app = get-spwebapplication http://sp $app.UserDefinedWorkflowMaximumComplexity = 10000 $app.Update()


1

Remove the <deny verbs=“*” users=“*” /> You are denying All Users and All Verbs before the evaluation of the other statements in the xml (web.config is an xml file with a different file extension) thereby rendering them moot. Also, sharepoint requires many of the other HTTP verbs you have set to deny. Why are you doing this?


0

I'm not sure about a custom field that can do that, I've never really heard of anything like that being done. That being said, if you can make your class serializable, you might be able to serialize it to JSON and store it in a regular SharePoint Note field.


1

You need to look into modifying the form with InfoPath (you can create different views and display them depending on the value of status column) or if you prefer modern experience you would have to use PowerApp to achieve your goal. There are as well some 3rd Party providers that have this kind of functionality.


1

It's a supported case. Check the https://docs.microsoft.com/sharepoint/install/hardware-and-software-requirements#software-requirements-for-sharepoint-server-2016 : Minimum requirements for a database server in a farm One of the following: * The 64-bit edition of Microsoft SQL Server 2014 Service Pack 1 (SP1) * Microsoft SQL Server 2016 RTM * ...


0

You can't upgrade the version of react in your solution, only SPFx 1.1 is supported in SP2016 on-premises & React is pinned to v15.4.2.


0

Please troubleshoot this issue as following: Go to Sharepoint Designer ->Navigation -> All Files -> Workflows -> Workflowname -> check if the *.xoml and *.xsn files are not checked in. Clear SharePoint Designer Cache Check if there are required fields.


0

I found the fix to this issue by accident after a while: try to open documents (in Word, Excel, Powerpoint...) from Internet explorer first. In this case, authentication works fine. Furthermore, after this step, documents can be properly opened in correct apps from other browsers as well (tested Chrome and Firefox). Most likely there is a Sharepoint-...


1

User get added in User Information list on when When we grant any user permissions to a user, they are added automatically to the hidden User Information list a new item will be created in the User Information List storing some information about the user. Even though if we grant access to any active directory group the group gets added to the ...


0

The only option to modify the approval task form is either using InfoPath or using SharePoint 2013 workflow platform.


0

Your clientContext object does not have a URL. var clientContext = new SP.ClientContext( yourSiteUrl ); or if running in a SharePoint page: var clientContext = SP.ClientContext.get_current(); Otherwise, your code looks nearly identical to here: https://docs.microsoft.com/en-us/previous-versions/office/developer/sharepoint-2010/hh185011(v=office.14) I ...


0

The internal name of the Title column is not always "Title". Which list template was used to create your list? To find the internal name: Go to the list's properties page, in the Columns section, click your column's name. Check the end of the browser's URL to see the internal name. For example, Created By is "Author". ...}&Field=Author


0

OK you are facing a problem i hit in the past that in my case caused a lot of issues. In our case it was bit different. User Management team had an issue with the one of the accounts. So they have deleted it and recreated with same user name. Our farm had a lot of item level permission and that actually caused SP server to grind to a halt. With MS support we ...


0

You could try to associate your workflow to another task list and see if it works.


0

To access the user information list, you should append “/_catalogs/users/simple.aspx” after your site like the URL below. http://yoursite/_catalogs/users/simple.aspx Then you could select the user and delete the user from the user information list. For more detailed information, you could refer to the articles below. SharePoint's hidden user-list - User ...


4

Here's one solution, using numbers: =Date + IF(Hour="12 AM",0, IF(Hour="12 PM",12, (LEFT(Hour,2)+IF(RIGHT(Hour,2)="PM",12,0))) / 24 ) + (Minute/60/24) And another just processing text: =TEXT(Date,"mm/dd/yyyy") & " " & LEFT(Hour,2) & ":" & Minute & " " & RIGHT(Hour,2) The second is probably the best choice, ...


0

I have had similar problems when working with tables or formatting in a content editor web part. To me when I kept trying it eventually worked. Sometimes I would have to wait, then make my changes, then save and it would finally work. Seems like a SP quirk to me.


1

It's not a Migration issue, it's appears to be SP2013 On-Prem has a different UserProfile Service to the SPOnline. Therefore you need to remap the userprofile data within the form itself. Setup new Data Connectors to the new service. I haven't mastered this yet, but I have the same issue with a form that calls the Users Manager. Does anyone have some Old to ...


0

To troubleshoot the issue, you could Disable the loop back check according to the following steps: Click Start->search Run->type regedit->then click OK. In Registry Editor, locate the following registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa Right-click Lsa->click New-> click DWORD Value. Type “DisableLoopbackCheck”, and then press ...


0

In PowerShell, normally you could add an event handler to a .NET object using the Register-ObjectEvent command. More information is in this article: Accessing Mixed-Mode SharePoint Web Applications With CSOM And PowerShell


0

To use Loop in a workflow, you need to make sure your workflow is a SharePoint 2013 platform workflow. If SharePoint 2013 platform is missing, you need to install and configure Workflow Manager for your farm. More information about installing and configuring Workflow Manager, you can refer to: Workflow Manager Configuration For SharePoint Server 2013


1

Remove the app in root site and deleted it from recycle bin, and then add the app again into root site and also in the sub site.


0

The problem was caused because of the Minimal download strategy feature. To fix this: I deactivated the Minimal download strategy feature in the Blog Site Activated the Team Collaboration Lists in the Blog Site.


0

Able to do this. Once you configure a FBA on site. write csom to access a site. while creating a client context please add below code. using (clientContext = new ClientContext(<site URL>)) { clientContext.ExecutingWebRequest += new EventHandler<WebRequestEventArgs>(clientContext_ExecutingWebRequest); ...


0

CSOM ListItem not porovide similiar property like HasPublishedVersion in SSOM: ListItem members A workaround is that creating a web service with SPListItem.HasPublishedVersion and then call the web service from Client Side with JavaScript or add web reference in Visual Studio: How to create an ASMX web service on sharepoint 2010 Using VS2010


0

Can you share the conditions of your workflow? Make sure your workflow was created correctly. By default, Information management policy timer job and Expiration policy timer job run weekly, you need to run them manually in CA to make them run immediately. Also try to use "Content Types" like below:


1

Supported SharePoint Framework version for the SharePoint 2019 is SharePoint Framework v1.4.1. Read this article for details around supported development capabilities in the SharePoint 2019:SharePoint Server 2019 development platform Besides, you could refer to here for each version of SPFx.


0

Can't init HttpContext.Current in Application_BeginRequest based on my testing. You can get it in Application_PreRequestHandlerExecute. Here is my test result(refer http://unabo.blogspot.com/2011/04/override-globalasax-in-sharepoint.html). protected void Application_PreRequestHandlerExecute(Object sender, EventArgs e) { Microsoft....


2

SPFx version 1.4.1 is supported with 2019. This will likely not be updated to any newer version of SPFx. Feature-wise, I don't believe this is documented in a single location. You would need to review each feature release, and even then there are going to be cloud-only features that aren't going to be available in SharePoint 2019.


Top 50 recent answers are included