New answers tagged

0

What’s the permission of the user who want to add the web parts? Go to site settings->site permissions->check permissions, check what’s the permission level that the user assigned. And check if the “Add and Customize Pages” permission is ticked.


0

Just like MHeld said, the main process is to clone your old topology, modify the new topology and activate the new one. You can add and remove the search components at the same time and activate the new topology. Have a check on the official doc: https://docs.microsoft.com/en-us/sharepoint/search/manage-the-search-topology https://docs.microsoft.com/en-us/...


1

I have completely reconfigured entire SSAs in one step (e.g. moving Search away from a WebFrontEnd server, enabling HighAvailability, ...). This is no problem at all. The steps are: Clone your existing topology Modify the cloned topology Activate the cloned topology Optional: Delete the old topology The entire process is described here in great detail: ...


0

I did tests in my environment, but I didn't reproduce your situation. I suggest you remove users with this condition from subsite and then add them again.


1

You need to use PowerShell remoting. Have a look at this: https://www.howtogeek.com/117192/how-to-run-powershell-commands-on-remote-computers/ But with the DSC you should thing about how to automate that process. PS itself has an option for the Pull/Push server which is bit limited. I am using Octopus Deploy (it is 3rd Party Product) to deliver my DSC ...


2

That's the actual design of the SharePoint, we can't delete others post from the Micro feed and even i can't delete my own post from the microfeed list. And per my test, I think that Microfeed list can be deleted only by deactivating the SiteFeed feature.


1

You can troubleshoot as following: Deactivate and re-activate the publishing feature and check again. Go to SharePoint Designer to open this top level site->Lists and Libraries, check if you can view the Pages library. If you can view the Pages library in SharePoint Designer, try to deactivate the publishing feature, delete the Pages library in SharePoint ...


1

Go to Subsite with site collection admin access, Site Settings - > Site Permission -> Check Permission First thing you should see if user has permission set, if not grant permission from here..definitely you are missing something very basic because it should work without issue.


3

You could use DefaultViewUrl property. (get-spsite -identity http://sp13).allwebs.lists | select title, DefaultViewUrl , LastItemModifiedDate, itemcount Update: (get-spsite -identity http://sp13).allwebs.lists | select {$_.ParentWeb.Url}, title, DefaultViewUrl , LastItemModifiedDate, itemcount


0

If you click on "Edit Workbook" can you then edit the file? Try enabling check-in / check-out in one document library to see if the behavior changes.


0

Well, this got bumped to the top by Community, so I guess I'll throw my two cents in here... Now, this is completely untested, but since I have found that you can add fake columns that aren't actually present in the list to a view by altering the ctx.ListSchema.Field collection in onPreRender, I'm guessing that the reverse might be possible - in the ...


0

Since City is not a default list field, you will have to specifically include it in your load call. Title, CostCenter, City, currency SPcontext.Load(items, items => items.include(item => item["Title"], item => item["City"], item => item["CostCenter"], item => item["currency"])); Any time custom columns are being retrieved, they have to be ...


0

Try replacing this line: SPcontext.Load(items); with this: SPcontext.Load(items, its => its.Include(item => item["currency"], item => item["Title"], item => item["CostCenter"], item => item["City"])); That way you are asking for specific columns to be downloaded from server.


1

QueryText is always wild card if you are not specifying any column , it just check for 'Share' keyword in your content and if found will return result, not sure why you need wild card. Wildcard(*) only make sense when you are search values for a particular property. You can add a * for suffix wildcard matching like below. last one is for phrase search so ...


0

"Application error when access /layouts/15/Workflow.aspx, Error=A response was returned that did not come from the Workflow Manager. Status Code = 200" I hit that error after I had used URL Rewrite to modify some headers for security reasons. If you have applied URL Rewrite to the top level of IIS, or any other modified headers at the top level of IIS, ...


1

Please do the following steps as below to troubleshoot this issue: Restart the "SharePoint Server Search 15" service. Make sure there is enough memory and disk space. Reconfiguring Content Processing Component, follow the steps as below: http://stevemannspath.blogspot.sg/2013/06/sharepoint-2013-search-adding-new.html SharePoint 2013 : How to repair a ...


0

We can reduce the amount of data being deleted by the timer job during each run, so I need to modify the daystokeephistory value of the timer job. The following PowerShell script for your reference: $history = Get-SPTimerJob | Where-Object {$_.name -eq "job-delete-job-history"} $history.daystokeephistory = 25 $history.update() $history.runnow() More ...


0

Since it’s a random issue, you can try to clear the SharePoint Designer cache and reconnect the SharePoint site. Then republish the workflow and check again.


0

There a blog about configuring Secure Store Service Application, you can check it with your steps. How To Configure Secure Store Service Application In SharePoint If this issue still exists, you could provide your steps to analysis this issue further.


0

There is one issue that we encountered . The word automation service application stopped working after we applied this CU . Tried this for both the SharePoint 2013 as well as SharePoint 2016 farms. The issue is that the CU revokes the permission of the service account running the application pool of the Word automation service application . So after you ...


0

There is no issue with April 2019 CU and May 2019 CU for sharepoint 2013 in the official documents. Then we recommend that you test those hotfixes before you deploy them in a production environment. More references: April 9, 2019, cumulative update for SharePoint Enterprise Server 2013 (KB4464514). May 14, 2019, cumulative update for SharePoint ...


3

If the SQL server 2008 r2 is not connected to the SharePoint 2013 farm , it will not affect the sharepoint 2013 farm when you uninstall the SQL server 2008 r2 from the SharePoint server. You could uninstall the SQL server 2008 r2 from the SharePoint server as usual. Then you could follow the steps in the articles below to uninstall SQL server 2008 r2. How ...


2

As Robert says I easily can implement that utilizing SPTitleBreadcrumb in almost similar manner. Here is my html code in layout page: <div id="modern-breadcrumb"> <!--MS:<SharePoint:SPTitleBreadcrumb runat="server" RenderCurrentNodeAsLink="false" ...


0

One thing that you can try using Power Shell is configure the Generic credentials from the Control Panel using a service account like this . Then schedule your script to be run from this server and read the credentials like this . Install-Module -Name CredentialManager $managedCred = Get-StoredCredential Let me know if any doubts with this one.


0

The following solution with source code for your reference. sp2010filteredlookup SharePoint 2013 Filtered Lookup Field SharePoint 2016 Filtered Lookup Field


0

You need to run the following command to update the profile photo store and thumbnail versions. Powershell command :- Update-SPProfilePhotoStore -MySiteHostLocation https://mysites -createThumbnailsForImportedPhotos. There is a possibility of this not working for all the users in the first iteration . Run it again and you will see that your problem is ...


1

Updates are displayed here: https://docs.microsoft.com/de-de/officeupdates/sharepoint-updates The currently latest CU is KB 4464514 - April 2019 The problem you mentioned was not due to a SharePoint update but rather .net-Framework.


1

It is recommended to always be on the CU which is 1 month prior to the current month. That way you are on the most stable CU and aware of any issues or exceptions occurring due to the current month CU . I have recently patched my SharePoint 2013 environment with the April 2019 patch and it looks the most stable patch right now . Following is the ...


0

I followed following checklist : - Check Health Analyzer on servers (WFE, App, SQL etc) - Check Search Crawling and indexing - Check Event Logs on all servers. - Check Memory and hard disk consumption on all server. - Check if SQL Back up jobs running successfully. - Check if old logs are clearing up. - Large Lists Throttling Issues - New ...


0

How robust is your 2013 Workflow Manager farm? Single server, shared server, multi-server? If you are running lots of workflows that maybe your bottleneck.


2

Change Alternate Access Mappings in Central Administration Check if the hostname is used in IIS-Binding Change Search Content Sources and perform FullCrawl Check & maybe change MySite Host Location in UserProfileService


0

I've confused regular security update with cumulative updates. KB 4022236 size and KB 4092472 are not cumulative updates. Cumulative updates for SharePoint


0

To troubleshoot the issue, check things below: make sure the account who runs the workflow is in the user profile service application. Re-publish the workflow and check if the same issue will occur. Create a new list and create a new same workflow to check if the same issue will occur.


0

Check the solution by using Asset picker $(document).ready(function () { // With the below line we will be dynamically adding the Browse control next to the textbox where we need to place this. //Replace "controlid" with your actual id of the textbox. $("textarea#controlid").closest('td').append("<div id='btnbrowsectrl' style='display:none'><...


1

.dev is a bad choice for a local tld as it's a "real" tld and owned by google. Chrome (since version 63) will always use https to access .dev domains. See this question for the same problem. I'd suggest you use a different domain. .localhost, .example, .invalid and .test were designed for local development. Also .local works good.


0

This could be caused by Alternate Access Mappings for the particular Zone. I would suggest taking a look at the AAM setup to see if there is anything that will trigger a protocol redirection. The basics of AAM are documented here:- https://docs.microsoft.com/en-us/sharepoint/administration/configure-alternate-access-mappings


1

both KB articles you mentioned are the security updates, in the description page, it mentioned it replace the old security updates. But I would rather compare with SharePoint December CU (KB4461555) vs August CU (KB4032247) . If you go throug each cu, you will notice it include that months Security updates as well as previous. I highly recommend install ...


1

you can have multiple database across multiple SQL server for the same web applications. I have same kind of requirement and working without any issue. Yes farm backup and restore method will work as well, because when you perform the restore it will ask you where to restore. at that time you can tell the sql instance name.


1

Based on the error message (and on command WordprocessingDocument) I assume You are trying to get content of Word documents. Problem is following - DOCX type of documents are OpenXML based so they can be opened as an archive file (for example, with 7zip) and will contain a lot of XML files and relations. This article by Stepan Yakovenko has good cover on ...


1

You could use the following command to remove the user from specific group: $web=Get-SPWeb http://spserver-sp13/sites/TesSite $group=$web.groups["Testme11"] Remove-SPUser -Identity 'i:0#.w|sp13\TestUser' -Web $web -Group $group -Confirm:$False


1

You could search for SharePo* and then will return SharePoint and SharePooint or you could create thesaurus and import in SharePoint Server Create and deploy a thesaurus in SharePoint Server https://docs.microsoft.com/en-us/sharepoint/search/create-and-import-a-thesaurus


0

As Marek said, you can limit People Picker to a certain OU in Active Directory. If a Web application is using Windows authentication and the site user directory path is not set, the People Picker control searches the entire Active Directory to resolve users' names or find users, instead of searching only users within a particular organizational unit (OU). ...


0

Taking a backup of the production DBs and moving them to the Dev SQL server and attaching them to the DEV SharePoint environment is the best option.


2

From my experience that doesn't work. What you need to do is to create a new farm, upload any custom solutions you have, take backup of the content databases and upload them to the new farm sql. After restoring those databases you need to 'Attach' them to SharePoint. One element you might review after that is the web.config people quite often modify it ...


0

You need to configure people picker to search only specific OU in your AD directory. Have a look at this question https://stackoverflow.com/questions/1178248/sharepoint-ldap-filtering-of-people-picker-users


0

To get workflow status, we can use the PowerShell script like below. $siteURL = "http://sp2013/sites/team" $site = Get-SPSite($siteURL) foreach($web in $site.AllWebs){ $wfm=New-objectMicrosoft.SharePoint.WorkflowServices.WorkflowServicesManager($web) foreach($spList in $web.Lists){ $workflowInstanceService=$wfm....


0

You could try to hide the whole TR by CSR, sample code for your reference. <script> (function () { var overrideCtx = {}; overrideCtx.OnPostRender = function(ctx) { var rows = ctx.ListData.Row; for (var i=0;i<rows.length;i++){ //condition //var isApproved = rows[i]["_ModerationStatus"] == "Approved"; //if (...


0

Make sure you at least install CU4 for workflow manager 1.0. Because renewing the expired farm certificates was not allowed before this update. To change Workflow Manager Farm Certificates, you could refer to this article:https://blogs.msdn.microsoft.com/whereismysolution/2017/02/08/changing-my-workflow-manager-farm-certificates/


0

This should not happen, I just checked this scenario it is working correctly. It is only appending when we are making change to that particular field. Somehow your comment column is also getting updated via code, try to edit using OOTB forms..If you are creating new version via code(though not updating comment column). please share code piece, there must ...


0

Try to log in with the search account to the portal. I had once situation when someone has expired my service account by mistake and that was the issue, but the error coming from SP was confusing. On another case I had an issue with the clock synchronization between the servers and domain controller, but then the error coming back as password incorrect.


Top 50 recent answers are included