Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Hot answers tagged

4

Site performance shouldn't really be affected by the size of the documents on document libraries. It's not like SharePoint reads all documents when user accesses the site (unless you have some "latest X documents Content Query Web Part on the front page crawling all doclibs). Obviously you need to pay attention to how documents are browsed - so having list ...


2

If yo want to remove a specific content type use either the exact name in a equals query (note the quotes and the minus): {searchTerms} Path:{Site} -ContentType="My Content Type Name" Or use the content type ID (replace the ID with your own): {searchTerms} Path:{Site} -ContentTypeId=0x0101006090CA8B789FE54589E1936EEC912F6E01 If the content types are ...


1

use the querytext-parameter. It's described in SharePoint Search REST API overview E.g. /sites/OneVSS/_api/search?querytext=(path%3Ahttps%3A%2F%2Fcontoso.sharepoint.com%2Fsites%2Ftest%2FLists%2FEmployee) Also be sure to checkout the nice SharePoint Search Query Tool - it helps to easily test access to the query-api.


1

Have you tried to use refinement filters or wild cards in SharePoint search API? Maybe one of the endpoint given below: _api/search/query?refinementfilters='Title:("micro*")' Reference: SharePoint 2013 REST Api - refinementfilters "Containts" OR "SubstrinOf" operator Or http://server/_api/search/query?query_parameter=value* Reference: SharePoint Search ...


1

You can try this. Add two search navigation webparts in the page Based on the current page, you can hide/show the search navigation webparts accordingly by writing a simple JavaScript that runs on page load. For example , in case of peopleresults.aspx, show the search nav webpart for only Peopleresults and hide everything else.


1

You can troubleshoot the issue as following: Go to Central Administration->search service application->Search schema->Crawled property, check if the relevant column name listed in it. Go to site settings->searchable columns, check if the column is excluded from the site index. Go to list settings->Advanced settings->click “Reindex list” button, then start a ...


1

In my installation this behavior was caused by a hard disk running full. Sharepoint writes into the /Index folder and it can grow rather large. In the moment I freed some space (by deleting some logfiles), the crawler would immediately stop and it freed about 2/3 of the space allocated in that directory. All the other solutions with restarting, IIS ...


Only top voted, non community-wiki answers of a minimum length are eligible