2

This is only settable by using the SPO cmdlets as this is an administrator-level setting. You can use Set-SPOSite. Connect-SPOService https://tenantName-admin.sharepoint.com Set-SPOSite https://tenantName.sharepoint.com/sites/siteCollection -SharingCapability ExistingExternalUserSharingOnly


1

As per Microsoft official documentation at:Set the default open behavior for browser-enabled documents (Office Web Apps when used with SharePoint 2013), Feature ID for Open Documents in Client Applications by Default feature is: 8A4B8DE2-6FD8-41e9-923C-C7C3C00F8295 You can enable this feature using PnP PowerShell like: Enable-PnPFeature -Identity 8A4B8DE2-...


1

I tested your script in my environment which was configured SSL, it worked fine. Also, I tested your script in my environment which was not configured SSL, I got the same error message as yours. So, your issue is caused by you didn’t configure SSL in your environment. Please refer to the following article to configure SSL: Configure SSL for SharePoint 2013/...


1

Just did a test in my SP16, The Official PowerShell example (Get-SPFarm).PerformanceMonitor.DeveloperDashboardLevel = "On" doesnot work. I get the error like this: I find this article with the similar issue: https://techtrainingnotes.blogspot.com/2010/05/sharepoint-2010-developer-dashboard.html You need to use the second one. This works for me. $...


1

Use below code to enable developer dashboard: $ContentService = [Microsoft.SharePoint.Administration.SPWebService]::ContentService $DevDashboard = $ContentService.DeveloperDashboardSettings $DevDashboard.DisplayLevel = "On" $DevDashboard.Update() Note: Make sure that you have an active and running "Usage and Health Service ...


1

I’ve just tested with the same command and it works fine. Try specifying the name of the Database Server and the Content Database in the command and try again: Restore-SpSite “http://mydevsitecollectionpath/” -Path "D:\pathname\12102020.bak" -Force -DatabaseServer <SQL> -DatabaseName <DB> Reference: Restore-SpSite : The operation that ...


1

Currently there is no powershell available to hide the "Get the mobile App" button in SharePoint server 2019. You need to use custom CSS to hide the button using SPFX webpart. Reference: https://n8d.at/remove-feedback-buttons-from-sharepoint-footer-through-application-customizer/


1

You can use Out-Null to remove the output from the pipeline: Connect-PnPOnline -Url $NewSiteUrl -Credentials $cred New-PnPList -Title Newsfeed -Template DiscussionBoard | Out-Null New-PnPList -Title Tasks -Template Tasks | Out-Null New-PnPList -Title Contacts -Template Contacts | Out-Null New-PnPList -Title Calendar -Template Events | Out-Null New-PnPList -...


Only top voted, non community-wiki answers of a minimum length are eligible