19

You have two possibilities in this case that doesn't require code. Variant 1) Change the permission level of visitor When you change the permission level from "Read" to "Restricted Read" your user won't see the site contents anymore Variant 2) Alternate read permission level of visitors You can simply remove the base permission "View Application Pages" ...


16

In order to manage unique permissions for a Securable Object like List or File (via associated List Item) or Folder (via associated List Item) there is a common approach that you could consider: Break role inheritance for a securable object Add/remove the role assignment on the securable object [optional] How to: set unique permissions for a File via REST ...


16

At least there is a workaround that will work fine (although I don´t like workarounds). You can set the group setting "Who can view the membership of the group" in SP-Group-Settings to "Group Members". Then only members of the group can see the members of that group. Luckily you can ask if the current-user has the right to view a groups membership. So if the ...


14

No, you cannot elevate privileges in JavaScript CSOM, nor would you want to. Remember there is nothing stopping end users from crafting their own scripts and running them via a developer tool like IE's Developer Tools or Firebug. If you could elevate privileges via JavaScript, it could mean disaster on your Farm as regular users could just write a script ...


13

Go to http://siteUrl/_layouts/15/people.aspx?MembershipGroupId=0. From here, you can delete a user from the Site Collection. It should be noted that the user will remain in the User Information List (dbo.UserInfo) table in the Content Database the Site Collection resides in. This is for referential integrity purposes. They are simply marked as deleted.


12

1.Select Site Actions > Site Permissions 2.Check the box next to the person or group you want to modify 3.Select the Edit User Permissions button


12

You can provide permissions to following groups : All Authenticated Users: All user accounts which can be recognized by SharePoint Online, both for internal and external. All Users (Windows) : User accounts from Federated domains. All Users (membership): All user accounts from Office 365 Online Services.


12

Probably it occurs since you are using App-only policy type for authorization . According to App authorization policy types in SharePoint 2013: App-only policy—When the app-only policy is used, SharePoint checks only the permissions of the app principal. Authorization check succeeds only if the current app has sufficient permissions to perform the ...


12

The simple process of setting item level permission is not available for SharePoint 2013 workflows. The only way I was able to do was through REST api called under Appstep. There are 2 calls made: BreakRoleInheritance AddRoleAssignment This blog by Yuri Leontyev​ ​ over at spssite.pro can be a good start. Excerpt: BreakRoleInheritance​ ...


11

Try below code: This will remove group permission full control $web = get-spweb http://url/to/your/web $group = $web.SiteGroups["Owners"] $ra = $group.ParentWeb.RoleAssignments.GetAssignmentByPrincipal($group) $rd = $group.ParentWeb.RoleDefinitions["Full Control"] $ra.RoleDefinitionBindings.Remove($rd) $ra.Update() $group.Update() $web.Dispose() This will ...


11

Try to create a custom permission level with at least add and view items as the following; To create a permission level Open the site collection site (the root site not a subsite) Go to site setting. below Users and Permission > Click on Site Permission. From the above ribbon, > click on permission level to be able to create a new permission level. For ...


10

Run your browser in elevated mode and the problem is resolved.


10

I think essentially what you want is a combination of these two things (found under List Settings > Advanced Settings); This allows users to only view and only edit their own records/entries in the list. EDIT: As discussed in comments below, you will also need to grant your 4 users "Cancel Checkout" permissions for them to be able to see all ...


10

Below worked for me: Steps: 1) Open Excel File. 2) Go to ribbon, select DATA and select From Other Sources, and click on From OData Data Feed. 3) In ‘Data Connection Wizard’ form, provide appropriate REST link and click on Next. REST Link format to get Sp Group users: https:// Your SP2013 Site /_api/Web/SiteGroups/GetById(9)/Users 4) In Next form, ...


10

RIGHT click on IE hold SHIFT and then RIGHT click again on IE LEFT click "Run as different user" login Repeat 1.- 4. for other users :)


10

Create a custom permission level by copying the contribute permission level and remove Edit items option. To create a permission level Open the site collection site (the root site not a subsite) Go to site setting. below Users and Permission > Click on Site Permission. From the above ribbon, > click on permission level to be able to create a new ...


10

Yes, you can restrict a few users to upload or add a new document by managing unique permission for your library as the following: Go to your library > Library Setting. Click on Permissions for this document library From the above Ribbon, > Click on Stop the inheritance. Then click to Grant Permission to provide a unique permission for specific Provide ...


9

Run the link of Central Administration as administrator. This helps getting you correct permissions in Central Administration


9

Through permissions there is no way to differentiate between being able to add files and add folders. But you still have two options: If your document libraries are set up with the right folders and nobody should add new folders then you can just go into Library Settings|Advanced Settings and set Make "New Folder" command available? to No. If you then ...


9

You can add Permission level at the top level site , So Make sure that you are now on the root site collection > Go to site Setings> Users and Permissions > Site permissions > From the above ribbon you > click on permission level You should now see Add a Permission Level


8

In SharePoint 2013, go to: Site Settings -> Site Permissions. Then select the group you want to edit via the checkbox, and click Edit User Permissions.


8

PowerShell is ideal for this. You can use something like this get the information you want. $siteUrl = "http://.." $site = Get-SPSite $siteUrl $site.RootWeb.SiteAdministrators $site.RootWeb.SiteGroups | Select Name, Owner, Roles $site.RootWeb.RoleDefinitions | Select Name, BasePermissions If you want to loop through all webapplication you could use code ...


8

Everyone was what worked for me EDIT Everyone is a default group that contains all authenticated and guest users that can connect to your network.


8

This often happens when you have the "require checkout" option enabled on the library. To check this, try uploading a file and see if it immediately gets the little green overlay on its icon, indicating that it is checked out. From the Library Settings page, click the link to manage files with no checked-in version. You should see a view of all the ...


8

Try to share the Root SharePoint Site to Group A As Limited Access to Can view specific lists, document libraries, list items, folders, or documents when given permissions. And as contribute to the SharePoint list that has the workflow with its related Task List and History list. You may also need to check "How to elevate Workflow permissions in ...


8

This is not possible. Admins will always have full permission over the entire site collection. The reality is that with any system somebody has to be the admin, and being the admin means having both privilege and responsibility, and it also means that the users have to not only trust, but believe in their bones that they can trust the admin, and ...


8

You can create your own permission level same as contribute, but without edit option. Below is the link for reference. https://technet.microsoft.com/en-us/library/cc263239.aspx


8

You can use that Standard available Contribute Permission profile Your "View Own Items" restriction is a setting on the List, not in the Permission profile


7

Late answer but, The User Profile is not responsible in this case. SharePoint recognizes AD security groups and attaching permissions to these groups will cause the permissions to be granted to the User. Unfortunately, due to SharePoint caching the user's memberships on login, changes made to a security group are identified only after the cache has expired,...


Only top voted, non community-wiki answers of a minimum length are eligible