Hot answers tagged

12

Use content editor web part:- (http://www.sharepointanalysthq.com/2011/03/embedding-pdfs-into-sharepoint-2010-pages/) First you need to find the URL to the PDF that you wish to view, after that you are ready to go! Step 1) Add a Content Editor Web Part to the page Step 2) Click on the ‘Edit HTML Source’ button for the Content Editor Web Part (not the ...


6

Install the May 2017 PU and try that. There was a bug, though I thought it was exclusive to 2013 with opening files where the path contained a space.


5

This is controlled by the installation of Acrobat itself, not SharePoint. By default, PDFs open in the browser but many corporate installs force it to open in a separate window for support reasons. Many users do not realize they are viewing a PDF instead of a web page and get confused when the normal web tools do not work properly. The bigger the ...


5

You also need to install the iFilter from Adobe in order to allow SharePoint to index the PDFs. The configuration changes you made simply tells SharePoint to index PDF, but the iFilter is actually what does the work. Start here: http://support.microsoft.com/kb/2293357


5

First, what you have asked is not related to the SharePoint Permission. Second, unfortunately, the PDF auto conversion is not available in SharePoint. The available options that may satisfy a few of your requirements are: From the beginning, you should upload your document as a PDF file. Or you can open your word document first in the browser then save it ...


4

Copy the address of a PDF file in a document library. (via the ellipsis) Go to a web part / wiki SharePoint page. Insert Web Part Media and Content > Page Viewer Web Part > Insert Edit web part keep web part settings as "web page" paste URL in the URL field click apply (resize web part height if need be) save page Office Web Apps if installed and connected ...


4

There is no OOTB facility with SharePoint Online to restrict specific file extensions in SharePoint Online. The only ways are: Create an event handler which will check the file extension. Create a workflow for the same.


4

Try to make sure the following: In your document library setting > Advanced setting, make sure that the Opening Documents in the Browser is set to Open in the client application. Make sure that each user has Adobe PDF client application installed. Make sure the web application Browser File Handling setting is set to Strict not Permissive in central ...


4

You can always enable the feature "Open in client application", and set your default app as Acrobat reader.


3

I have not seen anyone create a workflow capable of converting word files to PDF out of the box, but i have seen third party solutions that enable workflow features like this in SharePoint. read this link, http://blog.muhimbi.com/2012/02/convert-document-types-using-pdf.html


3

This is a known issue. It can be fixed by going to the Web Application General Settings and setting the Browser File Handling to permissive. I've also been told that it can be left at strict, but through PowerShell, add a white list exception for PDFs. I haven't stumbled across that though.


3

Ah. My literal use of the configuration instructions document was the problem. It suggested adding this line to the docicon.xml file: <Mapping Key="pdf" Value="pdf.gif"> This xml fragment doesn't close the tag, so my resulting xml document wasn't valid. Closing the tag like so <Mapping Key="pdf" Value="pdf.gif" /> And restarting IIS solved ...


3

If you're running SharePoint 2010 enterprise then you should use word automation services see Convert Word Document to PDF Using SharePoint and Word Automation Services


3

The syntax you want to use would be something like this: <object data='url/to/file.pdf' type='application/pdf' width='600' height='600'> <p>It appears you don't have a PDF plugin for this browser.</p> </object>


3

We raised the issue with Microsoft Support and apparently it's a bug. Will know more soon. In the meantime, the fix is to disable PDF's from being rendered in OWA: Get-SPWOPIBinding –Application "WordPDF" | Remove-SPWOPIBinding -Confirm:$false Control whether PDFs open in Word Web App or the default PDF reader http://blogs.technet.com/b/office_resource_kit/...


3

as Nadeem Yousuf said, I also generate report in SharePoint with SSRS approach check this link : http://msdn.microsoft.com/en-us/library/6a3b7fc3-3d91-4d12-8371-42ea12e74517 basically, you develop button at webpart with specified url, when the url is hit, it will automatically generate format based on your choice, example : PDF for pdf, WORD for doc, ...


3

This is working: <script src="https://code.jquery.com/jquery-1.7.2.min.js" type="text/javascript"></script><script> $(document).ready(function() { $("a[href$='.pdf']").removeAttr('onclick').attr("target","_blank"); }); </script>


3

As per my understanding, browser simply call the default application of the system. Set Adobe Acrobat as default PDF application of the system and it should work.


3

If the PDF files are opened in the browser, then it means you have either configured the Permissive mode in Browser File Handling, or added the PDF extension to the allowed MIME type list. (see Option #1 and #2 in this post for details) To have the PDFs opened in Acrobat, you should disable the Permissive mode (and set it to Strict mode) and if it is ...


3

I would create a new view in the library, sorted by modified date descending, with an item limit of 1. This will get you the most recent file in your view that you can use in the web part on the home page.


3

You may reference Microsoft.Office.InfoPath, then utilize the .Export this.CurrentView.Export(@"C:\MyView.pdf", ExportFormat.Pdf); for more details, visit https://msdn.microsoft.com/en-us/library/microsoft.office.infopath.view.export.aspx


3

You could try adding the #toolbar tag to your embed source <object><embed src="https://communitie0Control%20Towers%20EMEA.pdf#toolbar=1" height="850" width="1100" type="application/pdf"></embed></object>


2

You could set the web application browser file handling setting to strict. This means that SharePoint will tell the browser to open the file in the client application, instead of opening it in the browser itself.


2

You could sort of game the system. Instead of giving people stock contribute permissions with delete privs, create a custom permission without it. Add an additional metatada column to the list that acts as a delete option. When modified, you replicate any metadata to a separate custom list via workflow then use an impersenation step to actually delete the ...


2

For full story see SharePoint 2010 and Pdf Integration Series – Part 1 The short story either set Browser File Handling to Permissive Go to SharePoint 2010 Central Administration > Application Management > Manage Web Applications Select the row of your web application Click General Settings in the ribbon Scroll down to Browser File Handling and select ...


2

If you run WSS3, the registry setting should include folder 12 not 14. Is that a typo in this post, or did you add the wrong path?


2

You can do this at the list level in SharePoint 2010. Try this... $web = Get-SPWeb https://domain-name.com/site/web $list = $web.Lists["Library Name"] $list.BrowserFileHandling = "Permissive" $list.Update(); Gets a value that specifies the override of the web application’s BrowserFileHandling property at the list level. http://msdn.microsoft.com/en-us/...


2

Not out of the box. You would need to write your own PDF processor that accomplishes this either in an Event Receiver where the generated PDFs go. You could also create a custom action that you use instead of the word automation services to convert to PDF and accomplish this at the same time.


2

The path to the icon is inserted at the time you created the post and unfortunately it is not dynamic. You have to edit the posts prior to adding the PDF icon and update the path to the proper icon image file. All new post after the PDF icon was added will show correctly.


2

You can try to see if a permssion issue. Change the permission of the headers from the browser. Please, go to the Central Administration, then Manage Web Application. Select the WebApp where you have the pdf files. Then Click on the Ribbon on General Settings, General Settings again. In the PopUp, in the section Browser File Handling, click on Permissive. ...


Only top voted, non community-wiki answers of a minimum length are eligible