Hot answers tagged

9

You can do this by simply creating your custom permission level and setting it up for your document Library. You need 2 actions: Allow only upload files but no Edit. (Go to Site Settings-> PSite permissions->Permission Level->create Permission level). Hide library new button from both ribbon and top bar Use below script using script ...


5

Simple, just enable the option Allow management of content types on the Advanced Settings page of the document library.


5

DvG's answer covers the user permission for "Upload only", +1 for that already. The CSS-change given along hides the New-button which should totally restrict the actions available below the "New"-button. However, if you still want to have the button there for the "New folder"-functionality, the CSS's should only hide the other available options and leave ...


4

You need to deploy a separate server dedicated to Office Web Apps that does not have SharePoint installed on it. In order to edit files in the browser, it requires a license that you can get through Volume Licensing. Getting the Office Web Apps installation now requires you to go through Volume Licensing, even though the product itself is free for read-only....


4

I ran into the same issue today while patching an OWA 2013 server. The last patch, and many before that, ran without issues. Another OWA 2013 server that was on the same patch level also didn't experience this issue - seems kind of random so far. The fix was to add the OWA admin module to the PowerShell module path on this OWA server: $p=$Env:PSModulePath $...


3

You can use the same WAC server/farm for your SharePoint farm that you currently use with Lync. Simply run New-SPWOPIBinding -ServerName wac.example.com to hook up SharePoint to WAC.


3

You can delete this Site Collection as it was only used for Office Web Apps 2010. Office Web Apps 2013/Office Online Server do not use a Site Collection for caching purposes.


3

It really comes down to this: Are you load-balancing and doing high-availablity in SQL Server? Or do you solely rely on OWA rather than Office clients? If you are, then you might as well do load balancing in OWA. In my opinion, OWA is an added convenience for end users, and if the server happens to go down for any reason, users (especially a size that ...


2

First I'll suggest you to read this good article on how to setup OWA in I-frame. IF it doesn't resolve your issue, you can also retrieve the Email subjects with the help of REST call and them format it in HTML to display it on your Page using CEWP. But for this to take place outlook and SharePoint should be on the same domain. Kindly read this article


2

How did you setup your web app farm? If you didn't use the FQDN that is why you can't connect over it. Also check the zone bindings when you bind to SharePoint and make sure you are pointing at the URL where you will access web app farm.


2

This behavior could be caused if you have your Alternative Access Mapping (AAM) Default Zone set to use protocol http while your OWA is set to use HTTPS. One solution I found is to change the Default Zone to use HTTPS. Change the Default Zone by going to Central Administration > Application Management > Configure Alternative Access Mapping > ...


2

Office Web Apps 2013 cannot be installed on the same servers as SharePoint 2013. It needs to be on its own hardware (but can be virtualized). If you are going to build with high availability in mind then you'll need more than one server and a load balancer. In addition, if you are going to publish your SharePoint farm on the internet then you'll need to ...


2

You can run the below command to change the external url to the desired one. Set-OfficeWebAppsFarm -ExternalURL "url" Set-OfficeWebAppsFarm


2

Looks like this is actually possible. You need to activate SPUserLicensing and then apply the available licenses to your AD groups. See this post from Wictor Wilen for details. Enable-SPUserLicensing #Mapping for Windows Authentication $ADmapping = New-SPUserLicenseMapping -SecurityGroup "Enterprise Users" -License Enterprise $ADmapping | Add-...


2

As far as I'm aware what you have discovered is the only way around this issue. As soon as you add even a single WOPI binding (even just view) your new button behavior is replaced. You can try this by removing all bindings and checking the library, then just enabling view for say an Excel sheet. Those document options will pop right back up. As far as ...


2

OfficeWebApps (OWA) always need to be installed on a separate Server. So we first have to find out where it is installed. Execute Get-SPWopiBinding in a SharePoint Management Shell on your SharePoint Server. You will find your OWA-Hostname in the attribute ServerName Execute Get-SPWopiZone. Note the protocol (HTTP or HTTPS) Then connect to your OWA-Server, ...


2

If its working in some cases, it means the OWA is working and there could be something wrong on SharePoint side. The update you have mentioned contains an issue with SharePoint 2013 where it do not work with the sites or the files path that have spaces in their URLs. For example, OWA will work: http://webapplication/sites/subsite/WithoutSpace OWA will not ...


2

You can follow the steps below to troubleshoot your issue: clear SharePoint config cache and do IISRESET. Update the proof key by PowerShell command “Update-SPWOPIProofKey”. If the issue exists, try to rebuild the binding using PowerShell command as below: Remove-SPWOPIBinding –All:$true New-SPWOPIBinding -ServerName <ServerName> -AllowHTTP


2

from the image clearly the Antimalware Software is causing the issue on the server. You have to make sure that antivirus exclusion properly implemented on the server. Check this For loadbalancing, its depend upon you load balancer settings. If it detect high CPU and take the server from LB then you will not see the issue with routine work.


1

Yes, you have to run the config wizard after the installing the above updates, As rule of thumb when ever apply any updates in SharePoint 2010 farm, please run the psconfig wizard to complete the update process. Why we recommend / require to run the Configuration Wizard also for Security fixes


1

Have you installed Windows Powershell for Office Web Apps Server? https://technet.microsoft.com/en-gb/library/ee890080.aspx From your error, it looks like you don't have the cmdlets installed.


1

It turns out that the way to accomplish this is to set all the WOPI bindings except the "View" binding. If you have already been messing with the bindings, I would start by removing them all and adding them back: Get-SPWOPIBinding –Application "WordPDF" | Remove-SPWOPIBinding -Confirm:$false New-SPWOPIBinding -ServerName "your-server" -Application "WordPDF"...


1

Finally I solved it. Cause: When I checked inspect element for custom page layout, i found that it was referring Item_default.js and callback was set for Item_default_hoverpanel.js. i.e. onfocus="EnsureScriptParams('SearchUI.js', 'HP.Show', 'ctl00_PlaceHolderMain_ctl01_csr4_item', 'ctl00_PlaceHolderMain_ctl01_csr4_hover', '~sitecollection\...


1

Another case is just encountered where it shows the same error but its due to a recent update by Microsoft. A recent update in OWA 2013 created an issue with SharePoint 2013 where it do not work with the sites or the files path that have spaces in their URLs. For example, OWA will work: http://webapplication/sites/subsite/WithoutSpace OWA will not work: ...


1

I assume you're running Office Web Apps farm 2013 (which is very different from Office Web Apps 2010). Run the PowerShell script Get-OfficeWebAppsMachine and see the output healthy/unhealthy If it's healthy, you can see whether you allow HTTP or HTTPS requests to you OWA-farm by running Get-SPWOPIZone If you require HTTPS you can still test HTTP and see ...


1

As the error message says, you have some reference to SharePoint on the server, even if you have removed SharePoint from it. My suggestion is to reinstall Windows Server 2012 R2 from scratch making sure you don't have any reference to SharePoint at all. It's a bit of work, bur it usually pays off to make things right from the start. I once tried to install ...


1

I'd use the command Get-OfficeWebAppsFarm and copy the entire block. Use that for your New-OfficeWebAppsFarm going forward. The important parameters are: -InternalURL -ExternalURL -CertificateName -AllowHTTP -EnableEditing


1

Turns out, if you have Allow management of content types set to Yes, you don't get the pop up. Turn it off, and voila, back to normal. Don't remember seeing that documented anywhere.


1

if you still need an answer for it, here is my solution (without any other app or paid solutions) : Connect your Sharepoint Calendar to Outlook, and then in Outlook, right-click on this calendar, Share, Send this calendar via email (or whatever it is in English), and send it to yourself. It will generate an offline .ics file of the current Sharepoint ...


1

outlook synch will be removed only from SharePoint Online. Not from SP on premise. You can still synch a contact list (SP) with contacts in Outlook.


Only top voted, non community-wiki answers of a minimum length are eligible