A message from our CEO about the future of Stack Overflow and Stack Exchange. Read now.
6

If I understand correctly you can retrieve field form filed collection of a list and set Indexed property to true $web = Get-SPWeb http://sharepoint $spList = $web.Lists["ListName"] $spField = $spList.Fields["FieldName"] $spField.Indexed = $true $spField.Update()


5

An indexed column in SharePoint makes sense to improve performances. If your list contain a lot (~1000s) of records, and you often query (filter or sort) by a given column, you can index that column. That way, when displaying a filtered/sorted view (based on this column), SharePoint does not have to loop throuh all the items to decide whitch ones to display (...


5

NO, Index the columns that you search and filter on, try and stay at a maximum of 2. This works exactly like a database, the more indexes the slower updates and additions become. Columns that you might want to index are: Any column that appears in JOINS or WHERE statements.


4

It should not affect the refiner since the refiner is working against the search index, not the list's index


3

Here is the Pwershell code to get indexed column names: $web = Get-SPWeb -Identity http://aissp2013/sites/team $list = $web.Lists["Employees"] foreach ($field in $list.Fields) { if ($field.Indexable) { if ($field.Indexed) { Write-Host $field.Title } } }


3

'Multiple Lines of Text' field cannot be indexed as it's an Unsupported Column Type. See here - Enforcing Uniqueness in Column Values. Indexing the field is separate from search 'crawling' which is needed for Searches (& its results). Make sure the column has a managed property - see : Automatically created managed properties in SharePoint Server 2013. ...


2

If your data source is within a site collection, use a Content Query Web Part and filter on the Task content type, or otherwise use SPSiteDataQuery. If it's split across site collections, you can only use search, and the indexing can only occur on a content source, as Anita mentioned.


2

It isn't possible to update the searchindex for just one item. An incremental crawl is necessary to update the index. Maybe it's possible to build the webpart not using the searchindex?


2

You can disable the limit for the administrator, or for a certain time frame to create the index. It most likely is that the number of items created happened so quickly that by the time the indexer was ready to run, it was more than 5000 items so it couldn't run. In a normal case where under 5000 items are created in a day, the indexer will have no problem ...


2

Once over 5000, REST becomes the best method I've found so far to programmatically manipulate data. It will take your request and return data in batches of 200, if more items satisfy your condition, it will give you a new URL to call to get the next page of data. I've used this to batch update a library of 150K+ files with no trouble. Everything else there ...


2

CSWP might work best. Indexes do not work as you have more than 20k items. With CSWP you could use the Path parameter like Path:https://sp.company.com/somesite/somelibrary/, or some other filtering such as Site parameter to only return results from the libraries you're interested in.


2

It indeed seems that reindexing did the trick. Just had to wait a little while. On the site, click Settings > Site Settings. Under Search, click Search and offline availability. In the Reindex site section, click Reindex site. A warning appears, click Reindex site again to confirm. The content will be re-indexed during the next scheduled crawl.


2

I can only partially answer your question. I can't speak to the questions surrounding the managed metadata columns or metadata navigation, but I can try to clear up some of your confusion over indexed columns and the list view threshold. The way to manage large lists is to create a view that has a filter using an indexed column that will return less than ...


2

As you probably are aware use of Indexing is meant to increase performance, particularly in querying, filtering and sorting in large lists, avoiding database scanning, etc. But also over-doing could fall in other extreme (beyond the actual limit of 20), e.g. remember that each update in the structure would require adding a row in NameValuePair table in ...


1

There are two known ways to by pass List View threshold By changing resource throttling value in Central Admin - This not recommended approach By creating indexed columns. Using List Settings add fields you are filtering to Indexed Columns. A list supports 20 indexed columns, so you can try adding more fields to improve the performance.


1

Indexes are associated with List. So you need to modify the list and add index. You can automate this using PowerShell. $site = Get-SPsite http://siteurl foreach ($web in $site.AllWebs) { #foreach ($list in $web.Lists) for ($i = 0; $i -lt $web.Lists.Count; $i++) { $list = $web.Lists[$i] foreach ($ct in $list.ContentTypes) ...


1

The fields MediaService*** are related to Image Analysis functionality. SharePoint o365 automatically analyse the image and update these columns example the location MediaServiceLocation. They are metadata columns related to an image.


1

It's normal behavior, you can't add indexes to columns if the total number of items is more than 20,000 in SharePoint Server. Workaround to manage large lists Create views with a filter that only shows items less than 5000 items. Using folders to organize data but it should also hold items less than the List View Threshold. Move the exceded list items to ...


1

Clarification questions... (too many characters for a comment) Can you toggle to another view without getting the error? For list indexing, try creating additional indices (event name, start date, category, etc). For Page Editing: Can you navigate to a separate page and go into edit mode? I'm assuming this is a publishing site collection. If not, try ...


1

Changing the view is not sufficient, you also have to add an index to the list. List settings -> create an index


1

No. The field TaskOutcome is not indexable.


1

Consider the below points before you start indexing your List/Library Creating an index requires accessing all items in the list Each column being indexed consumes extra resources in the database and adds some overhead to every operation to maintain the index. If your list item count exceeds the List View Threshold or the item count is in millions, its ...


1

Try using SPList.GetDataTable method MSDN: https://msdn.microsoft.com/en-us/library/microsoft.sharepoint.splist.getdatatable.aspx public DataTable GetDataTable( SPQuery query, SPListGetDataTableOptions flags, out SPListItemCollectionPosition position ) With this method you can read with a single query all the information in a c# datatable. ...


1

Have you set the User Profile Property to "Indexed"? Have you set the Managed Property to Searchable? I haven't tested it, but the data type MAY matter. Are you using Text, Integer or Decimal? Once you get it working you may want to look at using the "Complete Matching" flag on the property, unless you want parial matches to work as well. Also, If you ...


1

I use the following function to add an index Function AddIndex () { Param ($list,$InternalFldName) try { Write-Host "Updating index for list: $list"; $fldToIndex =$list.Fields.GetFieldByInternalName($InternalFldName); try { ...


1

I think the content type hub is a red herring here - I suspect you have an index set on one of those altered columns. Go to List settings for the lists affected and click "Indexed Columns" below the Columns section. Find the offending indexes and remove them. Then create a new template and try to spin up a new site with the new template.


1

I solved a similar problem by switching my CAML comparison value type query against the WorkflowInstanceID from Type="Text" to Type="Guid". Perhaps you could change your value type to Integer like so: q.Query = "<Where><Eq><FieldRef Name='DefectID' /><Value Type='Integer'>" + DefectID + "</Value></Eq></Where>"; ...


1

I know this is an old post but I found it while looking for help so someone else may. I've done testing with SP 2013 and this is what you need to know... Hitting 5,000 does not effect your ability to search..it only effects your ability to 'browse' using views. Any view based on a list that have 5,000+ records, MUST have an INDEXED column as the FIRST ...


Only top voted, non community-wiki answers of a minimum length are eligible