9

This is not a bug. If you have more than one web part on a page then you must click the one you want the ribbon for.


9

Try using !important after your rule to override the inline style: #s4-titlerow{ display: none !important; }


8

Adding to iambriansreed's solution, you can put the comments in Literal controls around the SPSecurityTrimmedControls to prevent SPD from adding the extra rubbish. For example: <asp:Literal runat="server" text="&lt;!-- "/><SharePoint:SPSecurityTrimmedControl PermissionsString="EditListItems" runat="server"><asp:Literal runat="server" text=...


8

Users with read permission doesn't have the right to read files and documents in draft mode and minor versions. Users with contribute permission level can see draft mode and minor versions. That's why you need to publish files before visitors (with read permission only) can access the updated major version (1.0, 2.0, 3.0 and so on). If you don't have a ...


7

After long investigation I found solution. It is both SharePoint and IE 8 specific problem. IE 8 loads styles in different order, than IE 10. In IE 8, after my custom css, class .ms-core-needIEFilter was loaded. The class has gradient inside. I added to my custom CSS following code: .ms-core-needIEFilter #suiteBarLeft { background-color:transparent; -ms-...


7

Apparently, this is a common problem (I'm surprised that nobody already had a custom solution). Apparently, this is what causes the problem: When you add a web part to the standard list views, the page is no longer classified as a list view page, but instead it is classed as an application page. Katrina over on Stack Exchange posted this solution. ...


7

I believe the only difference is their page layout and navigation. Seattle is what we're used to from 2010, and Oslo is new, moving the left nav to the top, and removing the top navigation all together. Oslo has a wider layout for your content.


7

You will need something like this: <Module Name="Masterpage" Url="_catalogs/masterpage"> <File Path="Masterpage\mynewmasterpage.master" Url="mynewmasterpage.master" Type="GhostableInLibrary" Level="Published" ReplaceContent="TRUE"> <Property Name="Title" Value="My New Masterpage" /> <Property Name="UIVersion" Value="15" /...


7

Like Amal said, it's not easy with CSS, because FontAwesome already uses :before and :after. One possibility is to solve this with JavaScript on runtime. Try something like this: function AppendMenuFontAwesomeIcons() { var elements = document.querySelectorAll('ul[id^=zz][id$=_RootAspMenu] li span.menu-item-text'); for (var i = 0; i < elements....


7

Creating Custom Master Page for Hosted Apps Create a Module in your project to add the master page that you just created above. Add your custom master page to this module. You will need to modify the elements.xml file so that your master page will go to the master page gallery of your app as below: <File Path="ModuleName\CustomMasterPageName.master" ...


6

**SOLVED ** The problem is related to 'Scripting Capabilities' being turned off by default for the root site collection in Office 365. https://support.office.com/en-us/article/Turn-scripting-capabilities-on-or-off-1f2c515f-5d7e-448a-9fd7-835da935584f?ui=en-US&=amp&rs=en-US&ad=US Although it mentions turning on scripting through the Sharepoint ...


6

SharePoint has difficulties dealing with protocol-less URLs. Have you tried changing them to https?


6

Browse tab is particularly useful when you have top navigation enabled. Browse tab hides the ribbon and shows the top navigation. Hope this helps.


6

As per your description it seems that there is a problem in your custom Master Page configuration. Also it seems that only Site Permission page is throwing an error. So the possible problem is your custom Master Page is missing some Site Permission relevant tag. Please compare it with the existing Seatle Master Page and check for the missing tag.


6

Best practice to customize the MasterPage. First of all take backup of Seatle.master. Create new MasterPage from existing one Set the new MasterPage as default MastePage When you copy Seatle.master, it will produce 2 files. First will be *.master and second will be *.html Don't try to update the *.master file. Always open the *.html file and customize the ...


5

I would advise against this...I would also advise against having an exact copy of the coreV4.css file. Having both these files is going to beef up the load times and increase the needless amount of code the browsers need to go through. Change your CSS registration to the following line. I also always add it after the CoreV4.css not that it makes a ...


5

Try adding the path, as you have done in Name also, in After. Or since you have the css files directly in the 15, remove the path from the Name property. First option: <SharePoint:CssRegistration runat="server" ID="Custom2" Name="/_layouts/15/Custom2.css" After="/_layouts/15/Custom1.css" /> Second option <SharePoint:CssRegistration runat="server"...


5

The problem is with the use of OnDemand=true. If you set that property than you are asking Sharepoint to only load the scripts on demand i.e. when you explicitly call them. This techique is used to reduce the amount of scripts loaded at page load. When applied script can be requested to execute by using SP.SOD.execute or SP.SOD.executeFunc methods. .master ...


5

If you enable publishing feature, you can’t edit .master directly, you should edit .html only suggested by Aakash Morya. If you create a site collection(eg:Team Site) and don’t enable publishing feature, you could copy default .master page and do customization.


4

Since your master page is now unghosted (= customized = not anymore retrieved from the file system), you'll have a newer version. You can roll back to a previous edition (v1.0 as provisionned by MS) to put you back in a working state. Go to {Your-Site-Collection-Url}/_catalogs/masterpage/Forms/AllItems.aspx, select the v4.master, history and roll back to a ...


4

You are trying to hide the PlaceHolderPageTitleInTitleArea ContentPlaceHolder. This PlaceHolder does not just hold the title, but certain other things as well. Don't hide the placeholder in the master page. Rather create yourself a new Page Layout and hide whatever you dont want to see from the following within the PlaceHolder: <asp:Content ...


4

Medes, Don't remove the PlaceHolders from MasterPage, bad bad practice! As they are used by SharePoint internally to place content accordingly on the pages... Below URL gives the list of Default Content Place Holders and information that is kept into them [It is for SharePoint 2010, but I hope not much changes are there]: Working with content placeholder ...


4

You could place the whole navigation area in a ContentPlaceHolder in the master page, if it's not already in one. The ContentPlaceHolder is a control, used in master pages, which can specify content seen in all pages that uses that master page, but also allows pages to simply override this content, if they need. So, let's say you have the navigation markup ...


4

Type in the URL ~site/_layouts/ChangeSiteMasterPage.aspx and you should get to the same place.


4

These links are loaded dynamically using the delegate controls so you wont' find these link in master page. To hide these links, add the following to your css file referenced from your master page (suggested) or add it to your master page. <style type="text/css"> #Suite_MainLink_ShellMail, #Suite_MainLink_ShellCalendar, #Suite_MainLink_ShellPeople, #...


4

If you're on on-prem environment, you can customize the SuiteBar, there's a delegate control for the SuiteBar which you can override. For SP2013 online environment, you'd need to use jQuery to add links to it and CSS for changing color, font and styles.


4

The steps for changing the colour in SharePoint Online are: Navigate to Site Content --> Style Library --> desired language Create a new CSS file (if you already have a custom file you can append to that) Add the following CSS styles #O365_NavHeader, .o365cs-nav-rightMenus, #O365_MainLink_NavMenu Change the colour to suit your theme, note because ...


4

Page Title is rendered as Try this .ms-core-pageTitle { font-size:2.77em; white-space:nowrap; color:pink; /*Let us test colour*/ font-size:9.77em;/*make it huge*/ /*You edits here*/ } Override the above in you master page or custom css file.


Only top voted, non community-wiki answers of a minimum length are eligible