9

This sometimes happens because the timer job CreateProductVersionJob didn't run as expected and you can try to restart the SharePoint timer service in services.msc. If that doesn't do the trick, you run the PowerShell script Get-SPProduct -local. Even if it is a Get-script it does update the ConfigDB. It also forces the CreateProductVersionJob to start an ...


8

I run one at SharePoint Updates. Todd Klindt runs another.


7

You don't have to install November 2016 CU before installing May 2017 CU, as May 2017 CU includes the Feature Pack 1. This CU also includes Feature Pack 1 which was released with November 2016 CU. Source: https://blogs.technet.microsoft.com/stefan_gossner/2017/05/09/may-2017-cu-for-sharepoint-server-2016-is-available-for-download/


6

From http://www.toddklindt.com/blog/Lists/Posts/Post.aspx?ID=224 To see which build your products are, go to Central Administration > Upgrade and Migration > Check Product and patch installation status. (/_admin/PatchStatus.aspx) To see which build your databases are, go to Central Administration > Upgrade and Migration > Review database status (/_admin/...


6

Yes, Service Pack 2 contains all Cummulative Updates and Hot fixes before it.. including SP1 Install SharePoint 2010 Service Pack 2 the right way SharePoint Server 2010 Service Pack 2 has been released (Updated July 31st, 2013)


5

When you install the executable for a Cumulative Update (CU), you have not actually upgraded your servers yet. The PSConfig.exe (Command Line), or the SharePoint Products Configuration Wizard (GUI), will need to be run to upgrade both the running binaries, and make any changes to the SharePoint database schemas provided in the CU. In this case, you have the ...


5

if you follow couple of things then you will get better time. Make sure search crawl is stopped and unscheduled it. Make User Profile Sync is stopped, Also stop (if any) custom jobs or Content Deployment. Stop the followings services on the all server in farm in the same order. Disable the IISAdmin and SPTimerV4 service Shut down IIS Admin and Timer ...


5

Get-SPProduct -local doesn't actually return whether you are missing some updates. Instead as described in the TechNet: Returns a list of the SharePoint-related products installed in the farm and the versions of all updates installed for each product. However to understand why this affects the Configuration Wizard's execution the command's steps should ...


5

this is known issue in sharepoint 2013 and 2016. You can safely ignore it. But if you want to get rid of this message then please run this run command. psconfig -cmd -upgrade inplace b2b -force Hopefuly, Microsoft will fix this in upcoming CU.


5

As a recommended approach, you should not install the SharePoint Designer on the SharePoint server, reason is same as you mentioned. SharePoint Designer is client application and you can connect to both farm from you local machine( as long as that machine on network) as long as you have to permission on the site collection.


5

There is no way to uninstall the CU from SharePoint. You have to rebuild the farm and restore from the backup. But in your situation, you dont need to worry, simply install the SharePoint server CU on top of Foundation everything will be ok. You will be safe. On side note, SharePoint Server bits include the SharePoint foundation binaries in it.


5

Yes you are right, the build number for April 2017 CU is 15.0.4919.1003 But I advise you to don't trust the build number in Manage Servers in Farm, it often gives you a wrong indication about installed fixes. Stefan Goßner discussed the reason in details at SharePoint patching demystified I quoted some One reason might be that you looked at the KB ...


5

July 2017 CU is enough for you. Here is more information about updates.


5

I have installed tons of SQL-Server Updates on lots of SharePoint farms. SharePoint never got broken. But if you heavily rely on that environment, you should have a testing-environment that matches prod environment as close as possible. You can install updates there and check if everything works as expected. Checklists are very helpful to standardize this ...


4

That's correct! if you ever need to confirm which update/revision of SharePoint you are running, without accessing the binary files themselves, these version numbers correspond to the version numbers reported in SharePoint Central Administration. You can find this by going into the Operations tab, and under Topology and Services, select Servers in Farm. ...


4

You can install the CU on each server at the same time, but you will need to run the PSConfig one at a time. Doesn't really matter on the order. Microsoft has more detailed guidance on this at: Install a software update (SharePoint Server 2010)


4

This is a common pitfall and a good reason to look into your backup routines, especially before patching as there is no way to uninstall a patch. Sadly, the only easy way would be if you have a test/staging farm where you have the same patch level as the site collection were at during the backup, restore it there and then move it to a separate content ...


4

According to MS, SharePoint does not have a single, specific build version (https://blogs.technet.microsoft.com/stefan_gossner/2016/08/23/sharepoint-does-not-have-a-build-version-full-stop/). The reason is due to SharePoint being made up of different sub products. Some update the farm version, others update the version in the config db and others simply ...


4

The root cause of your issue represented in you have installed September 2015 CU before installing August 2015 CU. September 2015 CU has been released without "Server" or "Uber" packages that mean if you are not in an urgent need for a fix included in September 2015 CU you should consider waiting for a CU release that includes "Server" or "Uber" packages. ...


4

SharePoint 2016 doesn't have 'CUs', instead they're Public Updates, which are similar in function, but different in that the recommendation is to apply Public Updates as soon as possible and keep current with them, unlike the CU process which was 'apply only as required'. There are no separate security updates for SharePoint 2016, that's correct. And with ...


4

First, you got this error message "The expected version of the product was not found on the system" Because of the cumulative update that you are trying to install ("April 2013") is lower than the current build number of your farm that is "The SharePoint version is SharePoint Server 2013 SP1 (15.0.4569.1506)," Second, it's known issue that occurs when ...


3

Looks like this a common issue. I had same issue after researching why Search wasn't working and only returning an error message. You could fix the issue by following instructions here: http://blogs.msdn.com/b/opal/archive/2010/04/18/track-sharepoint-2010-installations-by-service-connection-point-ad-marker.aspx But, you don't want to leave as is. You can ...


3

you can use command "net start sptimerv4" in command window when the wizard is starting phase 9/10, then you can see it's work fine!


3

On MSDN there is a nice document, Software updates overview. Wether you build a new farm or upgrade a farm always review the result documentation created by the proces: The (upgrade) log files SP2010 Products and Technologie Configuration Wizard (PSconfig.exe) PSCDiagnositics log file Central Administration site check update status page You ...


3

This is very much common issues now days. Couple of things to try to force SharePoint that all servers having SP. run this command on the server where CU missing Get-SPProduct -Local if still facing the issue, try to reboot the server


3

AppFabric CU(latest is CU5) is basically for windows server. So this should apply to all server in the farm irrespective those server are part of Cache cluster or not. It is normally good practice that all server should be on the same patch level. The process here is that you need to patch one machine at a time according to these steps: Shut down the ...


3

This CU includes all SharePoint 2013 fixes released since SP1, That's mean you all set and your farm is up to date. For SharePoint foundation, You don't need to install the SharePoint Foundation separately if you have Server installed and Install the Server CU. So you all set here as April CU for server include all hot fixes till SP1 and also include the ...


3

You can install the CU bits in parrellel on all server in farm to avoid the long wait time, But for the config wizard you cannot run more than 1 thread. As per my personal experince, i always start from Central admin and then followed by other Apps servers and WFE at the end. Please have a look on this answer. Recommended way to install CU and Update on ...


3

You rang? :) I have a SharePoint 2013 list at http://www.toddklindt.com/sp2013builds and SharePoint 2010 at http://www.toddklindt.com/sp2010builds. I also maintain two Twitter acccounts, @sp2010patches and @sp2013patches if you want push updates. tk


3

Due to the SharePoint SP1 is not inculde the update for language Pack,So I think that the main issue : you are not installed the Language service Pack SP1 for Français after you installed SharePoint 2013 SP1 . So try first to install the Modules linguistiques pour SharePoint Server 2013 SP1 - [Français] then install the CU OCT 2015


Only top voted, non community-wiki answers of a minimum length are eligible