8

When giving anonymous access to a publishing portal or a site with the publishing feature activate, there is an additional feature getting activated called ViewFormPagesLockdown. This feature prevents anonymous users from gaining access to certain areas of a site. That includes list forms. From the blog: This feature still exists in SharePoint 2010 and ...


7

unfortunately, afaik (& tested) the REST services are only working for authenticated users. You'll need to create a bridge service calling with credentials the native ones if you want to provide that functionality but since you're authenticating your request, are you sure it's not an authentication issue ? Does the target username / password combination ...


7

Make sure that the script files are checked in, published and approved.


7

Unfortunately not. You are only allowed to have one public web site collection in Office 365. If you try to add a subsite to your public site, you'll see the text "This site does not have any subsites." On team sites you can allow sharing with external users who don't need to sign in. In a way, this is anonymous too, but you can't share the entire ...


6

One very common workaround I see is that you use an authenticated user to pull the Request that you need, then write it to a document library that allows anonymous access. Because most SP does not accept .json as a file type, just save it as response.txt Then, in your public site, anonymously read from that document library: $.ajax({ url: "/documents/...


5

If you enable anonymous access to your site (or parts of it), you still need to deactivate “Limited-access user permission lockdown mode” Site Collection Feature if you want those users to be able to dive into Lists or Libraries. Enable anonymous access in “Authentication Providers” (Central Administration > Application Management) Grant rights to ...


4

I assume that by saying pages what we created using Visual Studio you mean application pages created in Visual Studio and deployed to _layouts directory. If you want to make such page anonymous, you have to change base class in your code behind. By default, application pages inherit from LayoutsPageBase class, and you have to change it to ...


4

The answer is quite simple. Open the Master Page (Normally V4) Find the following control : <SharePoint:ClusteredSPLinkButton id="idNavLinkViewAllV4" runat="server" PermissionsString="ViewFormPages" NavigateUrl=...


4

You're only option is to contact Microsoft Support in a new service request from the Office 365 Admin Center with your Correlation ID. Ref: How to find more Info on Correlation ID for Office 365 SharePoint Online site These are your support channels in Office 365.


4

By default, SharePoint is secure! Generally, your farm should be up to date with security fixes that bundled with the MU or the CU. Sharegate wrote a good article about How to make SharePoint Secure. that summarized as the following: Run the Microsoft Security Assessment Tool & Best Practice Security Analyzer Tool from Microsoft Only enable the ...


3

You can disable the Access permission to remote interfaces to the anonymous users, follow this: Navigate to the site (or sub-site) where you wish to enable anonymous access. Go to Settings - Site settings. Under Users and Permissions, click on Site Permissions. Under the Permissions tab, click on Anonymous Access. Choose whether you want ...


3

Anonymous Access Sharepoint 2013 Custom Appliaction Page - Step-1 : Open the Central Admin and go to Manage Web Application (under Application Management) . Step-2 : Choose the Web Application you want Anonymous Access for and click on Authentication Provider . Click Default Step-3 : Check Anonymous Access & Click OK . Step-4 : Open Visual Studio ,...


3

Inspired by this post: https://sharepoint.stackexchange.com/a/36311/17191 I finally got it to work. After: SPList list = web.Lists.TryGetList("Messages"); I've added the line: SPContext renderContext = SPContext.GetContext(HttpContext.Current, null, list.ID, web); and now anonymous user can access a site with this control (without actually having any ...


3

In such situations, the only viable (i.e. open to evolutions) approach would be to deploy an applicative page (or Web service) in _layouts via a WSP. That is, a WSP with server-side code. That page/Web service would hold all the logic/intelligence/business (with elevation if needed, or as the anonymous user to preserve security, but at least you'll be ...


3

"Anonymous" means two things: From a technical point of view (or "identification/who are you?"), you must set "Anonymous" access in IIS. This is for IIS to allow any un-authenticated request to come in, and display the FBA logon page, without IIS interfering for authentication. This means IIS does not handle anymore the authentication through Windows-...


3

RunWithElevatedPrivileges elevates the code block to the Web Application App Pool Account. You need to ensure that account has access to the User Profile Service. I should point out RWEP is generally a bad idea.


3

Try below steps to enable CSOM for Anonymous users: First give permissions at Web application level Steps: Go to Central Administration Go to Manage Web Application Select your Web App Click on Authentication Providers in the ribbon Click zone "Default". Uncheck "Require Use Remote Interfaces Permission" Give permissions on site Steps: Go to Site ...


3

Original post : Anonymous Access: SharePoint 2013 Custom Application Page Try the below steps: Step 1: Open the Central Admin and go to Manage Web Application (under Application Management) . Step 2: Choose the Web Application you want anonymous access for and click on Authentication Provider . Click Default, Default Step 3: Check Anonymous Access ...


2

Make sure that your application page inherits from UnsecuredLayoutsPageBase and that anonymous access is enabled for the IIS site running the SharePoint application.


2

In addition to the configuration changes I described in my question, to enable the moderation of anonymous comments while at the same time preventing anonymous users from seeing each others unmoderated comments, I had to create a custom list event receiver. The ModerationEventReceiver class from SPAdrian's Office 365 Anonymous Access Manager Sandbox ...


2

$authprov = Get-SPAuthenticationProvider -WebApplication [web application URL] -Zone [zone] # Check the AllowAnonymous property: $authprov.AllowAnonymous Should return true or false http://myspworld.wordpress.com/2012/05/31/anonymous-claims-authentication/


2

Listdata.svc service usage requires an authenticated connection. For your public site, I do recommend implement your custom service (be it a simple asmx service, rest service, wcf service) or create a custom generic handler (eg: listdata.ashx) that will return, in a similar fashion to what you would receive from listdata.svc the expected content. You can ...


2

In the code behind you can set the Author field, which is Internal Name for Created By field.. You can do something like: SPUser user = web.EnsureUser("<User Login Name>"); listItem["Author"] = user.ID; listItem.Update();


2

Few things that you should see: Make sure the default page is checked-in and approved (if its checked-out or pending for approval, it won't be available to anonymous users) Make sure all items in Style Library/Site Assets are checked-in and all these libraries have Anonymous Access (sometimes Style Library/Site Assets are not inheriting permissions from ...


2

After much trial and error, I found that ARR has an option that is not on by default when adding a Server Farm: 'Reverse Rewrite Host in Response Headers' under the 'Proxy' section. Once this was turned on, all links pointed to the correct locations!


2

I was not able to find any way to do that using the standard either PowerShell SnapIn or the CSOM/REST, so i looked under the covers. From tracing the code in the code-behind of that AuthenticationPage in the CA, here is a script that does decent job via Reflection. Param( [parameter(Mandatory=$true,ValueFromPipeline=$true)] [Microsoft.SharePoint....


2

I used to solve this issue by turning on anonymous search results cache, it's under "setting" in CSWP (you can configure it in CSWP or check the link below for more advanced tricks.) https://blog.mastykarz.nl/anonymous-search-results-cache-sharepoint-2013-public-websites/ [Mar-28 Updated]


2

Check the User of Application pool of the current web Application(In the IIS). Go to Central Admin => Manage service applications => User Profile Service Application => Administrators => Add => User of Application Pool which is mentioned in the step 1 => Select Full Control and Save it. You will see the users anonymously. Please check image for the more ...


2

I have reproduced this issue. To resolve this issue, you should deactivate ‘Limit-access user permission lockdown mode’ site collection feature (Site Settings > Site collection features).


2

Your only option is to remove anonymous access to the list, but it will prevent any response from anonymous users. Go to list permissions, stop inheriting permissions and remove anonymous access.


Only top voted, non community-wiki answers of a minimum length are eligible