Questions tagged [xslt-list-view-web-part]

XsltListViewWebPart class in Microsoft SharePoint Foundation derives from the XSL-based DataFormWebPart class. It replaces the ListViewWebPart class as the default view type in list views, although it generates equivalent HTML for the same view settings.

Filter by
Sorted by
Tagged with
1
vote
0answers
232 views

How to pass ID of selected row in custom list view web part in label of share point 2013

I have created a XsltListViewWebPart using server side object. Now I have to pass the ID of the selected item into a label. I want to pass the ID without JavaScript. This is my code for provider ...
1
vote
1answer
1k views

How to prevent column filter/sort PopUp menu in List View (XsltListViewWebPart) from being “cut off” when the web part has a fixed width/height

(This is for SharePoint 2013.) I am having a hard time figuring out the "css magic" to prevent the "Pop Up" menu (than appears when you click on a Column in a List View) from "cut off". Basically, ...
1
vote
1answer
533 views

SharePoint 2013 search center result displays the html code from a multiple text line field

I have a list library that contain two columns: Title: Single line of text field type Body: Multiple lines of text field type I am experiencing a problem related to the way search results from the ...
1
vote
0answers
56 views

Image Rendition option not available for XsltListViewWebPart

I have added my custom image library web part on my default home page programmatically. Now when I tried in default view of image libary. It shows image rendition option as below: It will not show ...
1
vote
0answers
234 views

Sharepoint Custom List conditional formatting date comparison

I am having an issue when creating conditional formatting using SharePoint Designer 2010. When the @Complete_x0020_Date is less than or equal to @Negotiated_x0020_Date, it will color the @...
1
vote
0answers
369 views

Date format in XSLT List View web part

I have a list with a calculated column which adds 5 days to the Created date. The date calculates correctly on the list but when displayed via XSLT it subtracts 1 day. I have found many different ...
1
vote
1answer
154 views

Date field won't show with ItemStyle.xsl

I'm pretty new user of SharePoint and i work with SharePoint 2010. I try to show the "StartDate" column of a page in my XSL template but it won't show. I put the column in the webpart configuration ...
1
vote
1answer
241 views

CQWP not showning fields to display

My Content Query Web Part does not display anything under "fields to display" I've been adding custom xsl:template <xsl:template name='MyStyle' match="Row[@Style='MyStyle']" mode='itemstyle'> &...
1
vote
0answers
64 views

Sorting by column heading in a grouped DVWP

I have created a data view in SharePoint Designer and applied 3 sorts, with the first one being a group function. Additionally, I have turned on the ability to sort by column heading. When the page ...
1
vote
2answers
582 views

XsltListViewWebPart when sorting retrieves all the data instead of from the Query

I've been trying out the XsltListViewWebPart for SharePoint Foundation 2013. So far I have been able to display my list according the the CAML query defined. Here is my acsx code below: <...
1
vote
1answer
234 views

XSLT not passing via javascript function

I'm using a DFWP and customising to send values to javascript function. I've managed to pass certain types of variables from XSLT to Javascript using the below code. <a><xsl:attribute name="...
1
vote
0answers
346 views

Can you make an XSLT group by itself through lookup?

Recently I figured out this nice grouping template that I will paste below. Now I am wondering: my list is really simple: Title Parent (= lookup to Title of this list) I would like to this list to ...
1
vote
0answers
249 views

SP13: Dataview Webpart &nbsp

I have a Dataview Webpart that is used in a page that originated in SP07 however was migrated to 2013 version. Looking at the xsl script there are no hard spaces are indicated by using &nbsp or &...
1
vote
0answers
222 views

Move Custom list form between environments(Dev, UAT, PROD)

Environment : SharePoint 2010 Enterprise I have created custom list forms(new, edit, disp) in my development environment. In the CustomEditForm I have inserted XSLTListView webpart(Child List) below ...
1
vote
0answers
98 views

Adding a XsltListViewWebPart to a custom web part page causes an issue

Currently we are developing a custom page with many of the for-mentioned web parts added via the module file related to the default.aspx page. Nothing major special seems to work nicely. However ...
1
vote
0answers
872 views

XsltListViewWebPart: select default view

I'm trying to configure an XsltLisViewWebPart for deployment to a SharePoint site. I'm provisioning the views beforehand using: List oList = clientContext.Web.Lists.GetByTitle(list.Title); ...
1
vote
1answer
999 views

How to find out number of distinct rows when using XSLT data view web aprt

Hi i know that we can find number of rows in XSLT data view web part by using this expression <xsl:variable name="Rows" select="/dsQueryResponse/Rows/Row"/> <xsl:value-of select="count($Rows[...
1
vote
1answer
171 views

Filter XSLT ListView with metadats as tags

My goals A documents library has a Metadata column. In a webpart page, user selects (through select2) several metadatas as tags. the tag(s) (one or many) are sent to a XSLT ListView XSLT ListView ...
1
vote
0answers
513 views

How to read XSLT list item of a list view web part in SharePoint designer 2010 using jquery

I have a requirement to get data from one list(e.g., A) and display in some other list's (e.g. B) custom display form(e.g. CustomDispForm.aspx). Here I am going to do this with the help of jQuery SP ...
1
vote
1answer
57 views

List view for FastSearch result with xslt in SharePoint 2010

Can SharePoint FAST search result be populated in list view web part (document library list view web part) using xslt? Is it possible?
1
vote
0answers
803 views

Multiple filter value webpart connection problem

We currently try to connect a custom webpart with a list view webpart. The aim is to send multiple filter values to the list view. The problem we have is that the list view does only use the FIRST ...
1
vote
1answer
440 views

External List : XsltListViewWebPart not loading view (Team Site)

Scenario: I have external list and I want to show specific view on team sites homepage. I add XsltListViewWebPart with featurereceiver because I can init specific settings and view to it when creating ...
1
vote
0answers
332 views

Is there an option to convert to XSLT view for Calendar Webpart?

I am trying to modify the calendar view of a document library. However, there doesnt seem to be an option for showing the name of the document on the calendar. I would like to have users click on the ...
1
vote
0answers
243 views

Does JSlink work in ListViewByQuery Control?

I added a ListViewByQuery control in my Application page. I added few ViewFields using SPQuery, I customized the rendering of those fields using JSlink, The fields are showing properly in ListView, ...
1
vote
0answers
2k views

XsltListViewWebPart onet problem in SharePoint 2013

I´m migrating a site from SP 2010 to SP 2013. I have a XsltListViewWebPart included in the onet of a page. In SP 2010 it works properly, all the categories appears and when I click on it, it expands ...
1
vote
1answer
170 views

How to Modify the Author name in Blog Categories (categories.aspx)?

I have copied blog.xsl and created Blogwrittenby.xsl to override the author name and display default author name. It works well for all other places except when we see categories. Any help would be ...
1
vote
0answers
372 views

Dynamically changed view of XsltListViewWebPart (in the custom form)

I have a form with custom XLV: <WebPartPages:XsltListViewWebPart ID="Xlv" runat="server" />, AFAIK, the view for this webpart is stored in the list as hidden. When user open form, the XLV query ...
1
vote
0answers
107 views

Remove ECB from XsltListViewWebPart

I have created XsltListViewWebPart programatically. I want to remove ecb on list items, I know this can be done by changing xsl of the webpart but I am getting null in it. Is there any way to do this?
1
vote
0answers
623 views

Connect XsltListViewWebPart with multiple providers

I have two lists defined: A: Projects (with a lookup column to B) B: Customer For list A I have two listviews: Open Projects Closed Projects Now I have a webpart page with three ...
1
vote
0answers
1k views

SharePoint 2010 OOTB filtering and sorting is not working in XsltListViewWebPart in Arabic

I am working on a multilingual site in English and Arabic. I have some pages with XsltListViewWebPart to view custom lists with no more than 12 fields to display. These are connecting webparts and ...
1
vote
0answers
741 views

Target Audience does not work with site SharePoint groups for XSLT List View web part

On some xsltlistview web parts, whenever I try to set the target audience to use one of the SharePoint site groups (These are groups created when you create a new site), it tells me that it does not ...
1
vote
0answers
208 views

xsltlistviewwebpart - view edit delete (ribbon) with filter

Is it possible to enable view, edit and delete (on the ribbon), when there is a filter applied? Thanks, David Esteves
1
vote
0answers
305 views

Disable Modal Dialogs from XSLTListView

i need to disable some modal dialogs for the form display in a listview. At the list settings I have disabled the modal dialog (NavigateForFormsPages="TRUE"). For the items of the list it works fine. ...
1
vote
1answer
216 views

Copying code over in Sharepoint Designer 2010 and changing it, deletes code from the original file, how can I fix this

Suppose I have two files, A, and B respectively. Everytime I copy xsl code from file A to B and modify the code in B and save it. The code in A gets removed (all except for the WebPartZone tags and a ...
1
vote
0answers
254 views

Web part only displays after refreshing page?

I've got a web part that displays one item in a list in a custom view. When going to the page that houses the web part, it errors, giving me a "Unable to display this Web Part. To troubleshoot the ...
1
vote
0answers
665 views

XSLT Transform failed: 0x80004005 : Type Mismatch UrlDirName

I get the following error in SharePoint Designer design mode when I add a thumbnail field to a xsltlistviewwebpart Any ideas on how to avoid? In addition, i want to modify the output of the ...
1
vote
1answer
802 views

Why updating of InplaceSearchEnabled of the listview webpart does not reflect on the page?

We have a script that generates pages that contains list view web part. The script sets the InplaceSearchEnabled of the web part true, but when we check the pages, the search box does not appear. I ...
1
vote
1answer
81 views

Add new announcement link viewable by permissions

I created a Content query web part on my home page which is from an announcement list from a sub site. I wanted to add the "Add new Announcement" link below it, but only viewable to those who have ...
0
votes
3answers
7k views

XSL to customize XsltListViewWebPart - Sharepoint Foundation 2013

I have created an external list. After it's rendered, link for each item looks like the following: <a class="ms-listlink ms-draggable" onfocus="OnLink(this)" href="http://swsudc07:9100/_layouts/...
0
votes
1answer
2k views

xsltlistview overiding the column headings using Xsl Link

I have a listview webpart that used specific columns. Changing the names of the columns is not an option. Our users are insisting that the heading for these columns be updated, so I am thinking of ...
0
votes
1answer
618 views

Custom NewForm or EditForm

If I use SharePoint 2013 Designer to create a new form, e.g., NewForm1 or EditForm1, and then open it up in (in the Designer) I can further modify the XSL in the DataFormWebPart that will render the ...
0
votes
1answer
66 views

Viewing List Data via CQWP, need XSLT to modify the content look in CQWP Webpart

Viewing List Data via CQWP, need XSLT to modify the content look in CQWP Webpart Detailed explanation: I've created a List and its working fine. Created a CQWP webpart to fetch the List data and ...
0
votes
3answers
4k views

hiding duplicates in a SharePoint view

I have a list with the following information: I have attempted to create a table of contents by grouping results in the following manner: However, as you can see, I have duplicated results in this ...
0
votes
1answer
786 views

XsltListViewWebPart is not displaying proper view when added programmatically

I am adding an XsltListViewWebPart from code behind, my code is: static void Main(string[] args) { SPSite site = new SPSite("http://bipc11:1234/sites/publishing1"); SPWeb ...
0
votes
4answers
3k views

Anonymous users denied access to XSL stylesheet

I have a XSLTListViewWebPart on a page and it is linked to an XSL stylesheet located in the Style Library. Anonymous users have read access to the Style Library. When a logged in user views the page, ...
0
votes
1answer
494 views

CAML Query Where Items are Approved is Ignored

I am working with some custom web parts recently. Those web parts will only display items which have been already approved. To get the items, I use CAML Query and filter the modstat value like: <...
0
votes
1answer
101 views

List aggregation formatting problem

I'm a bit of a SharePoint beginner, so please forgive me if this is a very basic question. I have a parent site with a number of identical team sites below it. The requirement is that each team site ...
0
votes
1answer
540 views

Content Query Web Part / XSLT Variable Name

I am trying to create my own item style for the content query web part. I need to create a variable to display. The following for title works ... <xsl:variable name="DisplayTitle"> <xsl:...
0
votes
1answer
350 views

SP2010: Hide a list view webpart on a page based on user group

I've 2 list view webparts on a page where I'm using query string URL to filter data. I wanted to display one of the webparts based on permission. Setting the target audience to a specific SP group ...
0
votes
1answer
59 views

Cannot filter imported XSLTListViewWebPart

I am having difficulty getting filters to stick on my XSLTListViewWebPart (XLV) using Sharepoint Designer 2010. I am working on a single site collection that contains two sub-sites, a Document Center ...