Questions tagged [workbench]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
24 views

Calling document.body.innerHTML+= causes all other JS to stop working

I am attempting to make a very simple web part that allows me to add a <script> tag to the bottom of the <body> element. I am in the stage of using gulp serve to test my part in local ...
0
votes
2answers
234 views

How to stop gulp serve / workbench?

I just started my first SPFx project on SharePoint 2016. After I key in gulp serve the workbench prompt up. My question is, how to exit the workbench? In my DOS prompt it seems gulp is still ...
1
vote
1answer
443 views

Workbench issues with spfx 18.2 and react 16.8.4

I have recently updated a number of modern spfx webparts to spfx 18.2 and this morning when I try to debug in workbench (locally and on tenant) I am getting serve errors in relation to react and react-...
0
votes
0answers
201 views

New spfx web part (1.4.1) requests WsaUpload.ashx, gets 403

I just generated a new web part using the Yeoman generator for SPFx 1.4.1, and am debugging it in the hosted workbench. We are using SP2016, On Prem. I am seeing console logging that looks like this: ...
0
votes
0answers
112 views

local workbench vs hosted workbench

I would like to use the kendo react libraries in my web part. At the moment I am just using the following example to test the dropdown list. Data and Value Binding While its working fine in my ...
0
votes
0answers
157 views

Error loading SP-webpart-workbench during SPFX webpart tutorial

I have been trying to walk through the tutorial "Build your first SharePoint client-side web part (Hello World part 1)", and I have found it to be quite troublesome. I've worked through many of the ...
4
votes
1answer
3k views

SPFx webpart workbench on localhost is not connecting

After creating a new project with SharePoint generator I can not connect to my workbench on localhost (ERR_CONNECTION_RESET) via HTTPS! I have tried numerous changes in internet settings and in ...