Questions tagged [web-template]

A type of template specific to website design.

32 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
0answers
1k views

SharePoint 2013 Site Template Issue while creating new Site

I have created a Site Template using "Save Site as template" SharePoint option. While creating a new site using the Custom Site Template facing the below issue. Previously I was able to create the ...
3
votes
0answers
3k views

Upgrade SharePoint 2010 WebTemplate to SharePoint 2013

I had a SharePoint 2010 project that deploys a WebTemplate to the farm. I upgraded the project to make it compatible with SharePoint 2013 and updated the solution in SharePoint farm. Now, when I try ...
2
votes
2answers
1k views

URL/Link to sharepoint members group of subsite used as web template

Is there a simple way to create a link that points to the default "members" group of a subsite? I'm creating a subsite web template and would like to have a link for future site managers that goes ...
2
votes
0answers
181 views

Template of Sharepoint Sites in Sharepoint 2013 created by CRM Microsoft Dynamics

At work I have got a CRM Microsoft Dynamics. At work we have got a lot of projects. When the new project is created in CRM we want to make a new site or site Colection for only this project. With a ...
2
votes
0answers
44 views

How to use Web Template in sharepoint 2010

I have created a Web Template named "My WebTemplate" in Visual studio 2010 and deployed successfully to http://somesite. Now in http://somesite web application. I want to create a site that uses "My ...
1
vote
0answers
114 views

TopNavigationBar is null when deploying solution through Visual Studio

I am having problems with adding navigation links via a Feature Receiver. Just as a background, I have a feature (FeatConfigureNav) which is activated automatically via a web template. This sis a ...
1
vote
0answers
19 views

Web template does not uploaded in the solution gallery

I have created a web template using the default.aspx,defaultdws.aspx and ONET.xml file from the sts folder. I didn't get any error while deploying but the template doesn't get uploaded in the solution ...
1
vote
1answer
99 views

How to find site/web template title based on site url

I've applied a custom web template in a site. How to retrieve the template title based on site url in c#? FYI: My Custom Web Template name is "{guid}#MyNewTemplate" and title is "MyNewTemplate", ...
1
vote
0answers
24 views

How to create two child subsites one under the other by using web template?

I have this senario where I have to create a sub site and beneath that there will be another subsite created at the moment user creates the top subsite. Ex: Site1 (On siteCollection user will create ...
1
vote
1answer
32 views

Why SaveSiteAsTemplate is hidden

In sharepoint 2010 it was able to Save site as template. But in sharepoint 2013 we should Inaktivate Publishing feature to be able to show this link. I know that there is some workarounds But my ...
1
vote
0answers
341 views

Error when applying custom webtemplate to a sitecollection

I have created a webtemplate from an existing sitecollection by using(save as template). I then imported this template to VS and changed some things in Elements.xml and onet. Now when I try to apply ...
1
vote
0answers
51 views

Problem loading pages as a site owner when Minimal Download Strategy (MDS) is active

We have created a custom teamsite webtemplate, which has some extra site columns, contenttypes, lists and libraries. No fancy stuff. However we got some complaints that sometimes, not always pages ...
1
vote
0answers
34 views

Default.aspx via code?

Would it be possible and recommended to add a custom Default.aspx (when no publishing nor wiki front page are enabled) via code (remote provisioning) vs adding it via a Module declaratively? are there ...
1
vote
0answers
49 views

Migration of custom Default.aspx (Web Template)

I am considering to change the Default.aspx (no publishing, no wiki welcome page) via Web Template (for self-service site creation) in SP2013. I am wondering if this would have effect on future ...
1
vote
1answer
522 views

Navigation Option Within Web Templates and Onet.xml

I have created a web template which deploys and creates subsite when used. Problem : I am trying to get the navigation setting to work as the image below The current Onet.XML being used to create ...
1
vote
0answers
59 views

Can I use a provisioningProvider to a custom web template?

I have problems with the sequence of my logic. I have featere1 where I have my custom webtemplate. Then I have feature2 where I have implemented my default.aspx page. Feature1 is activating feature2. ...
1
vote
1answer
46 views

What should be the provisioning model?

What should be the provisioning model for supporting only 2010 and above, if: it needs to include custom SharePoint security groups it would be deployed to multiple unrelated SharePoint installations ...
1
vote
0answers
89 views

Newly created web template is invisible

I have created a new web template (contains a elements.xml and onet.xml) which is based on team site. I have deployed the .wsp file. However when I go to "New Site" under Site Actions I cannot see my ...
1
vote
0answers
48 views

Web template using an old version

I've copied the same question I found in an answer in this link because it is happening to me: when I create a new site using powershell or code, it is using an old version of the template. Not ...
0
votes
1answer
24 views

JS code for web template only working for full control user

I deployed the control list with paging and item template for using the with Content Search Web Parts, we have realized that users with no Full Control are not able to run the logic in these templates....
0
votes
0answers
50 views

SharePoint Sandbox Solution Error

I have developed web template in visual studio sandbox solution. Sandbox solution is worked fine in on premises but when i am going to activate WSP and create new sub site using this web template i m ...
0
votes
0answers
44 views

Edit link not visible in Quick Launch after site provisioning using custom web template

I am using a custom web template to create a site based on team site template, but it is not showing the edit links on quick launch and top navigation. This is the element of the web template: <...
0
votes
1answer
425 views

How to attach a web provisioned event receiver to a web template?

I have created a web template using the onet.xml and elements.xml. I have created a web provisioned event receiver, but it is not really attached to my custom web template. When I create a site the ...
0
votes
1answer
596 views

Custom web template not showing in SharePoint online

I have created one sandbox solution in which I am deploying custom web template. It runs successfully when I check the .wsp in the on-premise but when I upload the solution to the Office 365 site and ...
0
votes
0answers
69 views

Creating a feature however manifest does not contain GUID ID

Currently I am creating four custom features within a visual studio sharepoint 2010 project. Within the manifest there is no ID generated once the feature has been created for two of the features. All ...
0
votes
1answer
352 views

SharePoint 2010 MUI

I have created a web template from scratch which is based on the OOTB Team Site. Essentially, I have copied over the Onet.xml content of the OOTB Team Site and used it as -it - is in the Onet.xml of ...
0
votes
1answer
310 views

Documents list not exsists when activating feature

I have created a custom web template based on Team Site and added a SPWeb scoped feature to add a List View WebPart to it. It throws an exception when it comes to web.Lists["Documents"] and says ...
0
votes
1answer
223 views

Why the “group work lists” like “announcements, links, tasks, events” are not exist when my feature eventreceiver is triggered?

I have created a custom web template where I activate the webfeature "Group Work Lists". I have also a event receiver where I would like to do some logic. I try to get the splist item of one of my ...
0
votes
1answer
458 views

Why I can not add a list to some webpart zone in my custom web template home page?

I have created a custom web template and it will be deployed by feateure1 for example. Then I have also a module with inside of it the default page declaration. This module will be deployed by ...
0
votes
1answer
122 views

Can I deploy and use my new custom web template at an existing site collection?

I am using sharepoint 2010 and VS2010. I have crated a custom web template and when I deploy it I need to create a new site collection where my custom template will be available if I create a new sub ...
0
votes
1answer
297 views

Is it possible to use a custom web template inhirited from teamsite template, in a publish site template?

I am using sharepoint 2010 and VS2010. I have implemented this tutorial for creating a custom web template, and it works: http://usmanmughal.wordpress.com/2011/04/26/how-to-create-web-template-in-...
0
votes
1answer
99 views

How to create new webtemplate, inherited from another custom web template?

I have a sharepoint 2010 portal styled by someone else. If I am in my sharepoint portal and try to create a new site I see 2 templates. First one is publishing site and the other is a custom template ...