We’re rewarding the question askers & reputations are being recalculated! Read more.

Questions tagged [web-template]

A type of template specific to website design.

Filter by
Sorted by
Tagged with
2
votes
2answers
2k views

URL/Link to sharepoint members group of subsite used as web template

Is there a simple way to create a link that points to the default "members" group of a subsite? I'm creating a subsite web template and would like to have a link for future site managers that goes ...
0
votes
1answer
626 views

Custom web template not showing in SharePoint online

I have created one sandbox solution in which I am deploying custom web template. It runs successfully when I check the .wsp in the on-premise but when I upload the solution to the Office 365 site and ...
0
votes
0answers
12 views

How to use a custom Document Workspace web template instead of the native one?

I would like to use another web template for the Document Workspace web site because the native template has native design that doesnt match the parent web template. When creating a document ...
1
vote
1answer
256 views

How to create site collection with blank site template in SharePoint Online

Is there any way to create a site collection in SharePoint Online using the blank site template, STS#1 via PowerShell? I have attempted to do so already using the New-PnPTenantSite cmdlet and ...
1
vote
1answer
76 views

WebTemplate for 'saved sites a template'

I am using MS Flow to POST a HTTP request to SharePoint to create a Sub site when an item has be entered into a list. I want to create this sub site using a site template I have saved. I am trying ...
0
votes
2answers
57 views

Need to create site definition with pages, libraries and subsites

can we create a site definition with publishing page library, sub sites with blog and wiki template and then custom columns(like taxonomy field)? I want to understand which approach is better in SP ...
0
votes
1answer
24 views

JS code for web template only working for full control user

I deployed the control list with paging and item template for using the with Content Search Web Parts, we have realized that users with no Full Control are not able to run the logic in these templates....
0
votes
2answers
5k views

403 Forbidden immediately after creating web

I can't tell exactly what's causing the 403 Forbidden error (that's literally all of the information I have in the browser regarding the error) but this is the scenario: I navigate to my application ...
1
vote
0answers
121 views

TopNavigationBar is null when deploying solution through Visual Studio

I am having problems with adding navigation links via a Feature Receiver. Just as a background, I have a feature (FeatConfigureNav) which is activated automatically via a web template. This sis a ...
4
votes
4answers
616 views

Publishing Site “Save site as template”

How to save site as template for a Publishing Site? I do not understand how this is done.
4
votes
1answer
442 views

How get Site Template name in SPSite, and Web Template name in SPWeb using C#

I`m trying to analyse sharepoint site. In SPSite Level, I want to get Site template name, and In SPWeb Level, I also want to get web template name. But I am a newbie in SharePoint, I`m not sure ...
1
vote
0answers
19 views

Web template does not uploaded in the solution gallery

I have created a web template using the default.aspx,defaultdws.aspx and ONET.xml file from the sts folder. I didn't get any error while deploying but the template doesn't get uploaded in the solution ...
0
votes
1answer
8k views

Template for intranet portal free download 2013 [closed]

We need to create an intranet portal and I need a free good template to use which has almost everything an intranet portal has . Is there any site which I can download it?
0
votes
1answer
122 views

SP2013 DatePicker iframe is missing height and left in style attribute

I have a Webtemplates Solution based on the PROJECTSITE template and the seattle.master. After deployment all site collections based on my template will be provisioned by powershell in an automated ...
0
votes
1answer
310 views

Documents list not exsists when activating feature

I have created a custom web template based on Team Site and added a SPWeb scoped feature to add a List View WebPart to it. It throws an exception when it comes to web.Lists["Documents"] and says ...
1
vote
2answers
1k views

After creating a Web Template the pageTitle becomes hidden, how can i access pageTitle from onet.xml

I have created a Web Template but I haven't quite gotten my head around the Onet.xml file. I've Added some custom Web Parts and basically done most of the things that people suggest one would ...
1
vote
1answer
100 views

How to find site/web template title based on site url

I've applied a custom web template in a site. How to retrieve the template title based on site url in c#? FYI: My Custom Web Template name is "{guid}#MyNewTemplate" and title is "MyNewTemplate", ...
0
votes
0answers
50 views

SharePoint Sandbox Solution Error

I have developed web template in visual studio sandbox solution. Sandbox solution is worked fine in on premises but when i am going to activate WSP and create new sub site using this web template i m ...
1
vote
2answers
255 views

WebProvisioned event handler is firing twice and subsite does not inherit the parent's top navigation

I have created an web event receiver but the webprovisioned event handler fires twice. I have set the scope to web, but it still fires twice. Problem 1 This is elements file: <Elements xmlns="...
0
votes
0answers
44 views

Edit link not visible in Quick Launch after site provisioning using custom web template

I am using a custom web template to create a site based on team site template, but it is not showing the edit links on quick launch and top navigation. This is the element of the web template: <...
0
votes
1answer
447 views

How to attach a web provisioned event receiver to a web template?

I have created a web template using the onet.xml and elements.xml. I have created a web provisioned event receiver, but it is not really attached to my custom web template. When I create a site the ...
1
vote
0answers
24 views

How to create two child subsites one under the other by using web template?

I have this senario where I have to create a sub site and beneath that there will be another subsite created at the moment user creates the top subsite. Ex: Site1 (On siteCollection user will create ...
0
votes
3answers
2k views

Get-SPWebTemplate doesn't show my template although it should

I have an issue, basically I've installed a web template and it was installed fine. When i try to create a website I see this template in the list and I can choose it and based on this template create ...
0
votes
1answer
51 views

Custom site template not including all titles

I have a custom site template, that I made by first creating a site, a couple of doc libraries and custom lists, and put some webparts on the "frontpage" that shows certain views in these doc libs. ...
0
votes
1answer
164 views

Migrating Web Template to new Site Collection, errors saving as new Template

I was asked to migrate a site collection that included a web template for creating subsites to a new site collection. To do so, I downloaded the .wsp solutions from the old collection and uploaded ...
1
vote
1answer
1k views

Transfer custom web template to new site, features not activated-Sharepoint 2013

I have a web template created in site collection A and have been requested to copy that web template to site collection B. To do this, I downloaded the web template solution by going to the solutions ...
0
votes
1answer
88 views

What to Import from WSP to build Web Template solution in Visual Studio?

I'm trying to create a custom web template for SharePoint 2010. The client has already configured a prototype web site in SharePoint, which is essentially a standard blog site, with some ...
0
votes
1answer
821 views

Get Custom Web template name programmatically , Sharepoint 2013

I am trying to get the web template name that is being used currently in order to create the site. I have created and EvenReceiver and overriding WebProvisioned. in this method i would like to get ...
3
votes
0answers
1k views

SharePoint 2013 Site Template Issue while creating new Site

I have created a Site Template using "Save Site as template" SharePoint option. While creating a new site using the Custom Site Template facing the below issue. Previously I was able to create the ...
1
vote
1answer
32 views

Why SaveSiteAsTemplate is hidden

In sharepoint 2010 it was able to Save site as template. But in sharepoint 2013 we should Inaktivate Publishing feature to be able to show this link. I know that there is some workarounds But my ...
1
vote
0answers
342 views

Error when applying custom webtemplate to a sitecollection

I have created a webtemplate from an existing sitecollection by using(save as template). I then imported this template to VS and changed some things in Elements.xml and onet. Now when I try to apply ...
1
vote
0answers
51 views

Problem loading pages as a site owner when Minimal Download Strategy (MDS) is active

We have created a custom teamsite webtemplate, which has some extra site columns, contenttypes, lists and libraries. No fancy stuff. However we got some complaints that sometimes, not always pages ...
2
votes
0answers
183 views

Template of Sharepoint Sites in Sharepoint 2013 created by CRM Microsoft Dynamics

At work I have got a CRM Microsoft Dynamics. At work we have got a lot of projects. When the new project is created in CRM we want to make a new site or site Colection for only this project. With a ...
5
votes
2answers
9k views

How do I get the real Web template name and Id from a web?

I'm creating a tool that will "clone" webs inside a site. It reads child webs of a set web and displays them as templates for the user to select from. I've however run into a problem when I try to ...
7
votes
3answers
4k views

Site Contents link in Quick Launch below Edit link (SharePoint 2013)

I'm creating a custom WebTemplate. I added the following NavBars to the template: <NavBars> <NavBar Name="SharePoint Top Navigation Bar" Url="" ID="1002" /> <NavBar Name="...
1
vote
2answers
1k views

Custom webtemplate - default webparts are missing

I have created my custom site, which contains custom WebTemplate, Master Page and Page. However, I don't have any SharePoint webparts to select. When I check my Web Part Gallery it's empty. "There ...
2
votes
2answers
4k views

Custom Web template based on Team Site is empty

Following is the process I followed to create a Custom Web Template based on Team Site in SP 2013. I opened VS 2012 created an "empty SharePoint project", added an "Empty Element", changed its ...
1
vote
1answer
1k views

Enabling Navigation and SharePoint Publishing Infrastructure

I have activated SharePoint Publishing Infrastructure feature provisioned through my web template. But the Navigation (my libraries in QuickLaunch bar) was not visible after publishing feature ...
0
votes
1answer
1k views

Missing default.aspx when creating site-collection from web template - 404

I have a custom web template that I use to create a new site-collection. I get the success message, but when I continue to site/default.aspx I get a 404 "The page you're looking for doesn't exist.". I ...
1
vote
3answers
6k views

What is Site, Web, Site Template and Web Template in SharePoint?

Can anyone please tell me what the difference is between Site and Web in SharePoint. Also what is Site Template and Web Template?
2
votes
6answers
5k views

How many root site collections we can create

I have a simple question just to remove my confusion. In one web application, can we create multiple root site collections ? I have 3 different custom web templates, and for each template, I want to ...
0
votes
1answer
152 views

Cannot add links to global navigation on a site created from a custom web template in Sharepoint 2010

I have created a webtemplate that I use to provision a sitecollection site which works fine but when I try to add an Heading or link to the Global Navigation through UI it's not working correctly: ...
1
vote
1answer
1k views

SharePoint 2013 Web Templates Masterpage not found

I created a new web template for SharePoint 2013 (as Farm solution, because it has to be selected when creating a new site collection). The site collection creates succesfully. But when I navigate to ...
8
votes
1answer
350 views

Easy and maintainable way to create templates for sites?

What is currently the best way to add a template for site collections and subsites? Background: Vesa Juvonen wrote a good blog post in 2010 about declarative web templates over site definitions. ...
0
votes
1answer
237 views

powershell to check web template in sharepoint

I want to check on which webtemplate site is created. Like for site "xyz/abc.default.aspx" , I want to check on which web templated it was created. Can anyone provide me the powershell command to ...
2
votes
3answers
3k views

Problems adding webparts to a page in the correct order

I would think there's something supersimple I'm missing, but I can't find where I'm going wrong. I have a feature deploying a default.aspx page with two CQWP webparts. I use the AllUsersWebPart ...
1
vote
2answers
959 views

Provision list view for discussion board

I have provisioned a publishing page through a feature and andded an instance of a discussion board web part to the home page, this works fine. How can I make sure the web part chrome is set to ...
0
votes
1answer
365 views

GetWebTemplates: Input string was not in a correct format

I've created an generic http handler (ashx) that creates sites based on a particular custom web template I have created. However I'm getting a strange error when I execute the GetWebTemplates method. ...
3
votes
1answer
579 views

Restrict the usage of a custom web template for sub-sites creation only

I created a WebTemplate in Visual Studio and deployed it as a farm solution (I couldn't create a sandbox solution because it needs to deploy a custom master page and other stuff to the GAC). Now it ...
3
votes
2answers
1k views

updating CustomMasterUrl of rootweb and subweb

I've created a web template and as part of the provisioning process I set the SPWeb.CustomMasterUrl. I do this in code. When I create a site collection using this template it works fine but if I try ...