Questions tagged [stsadm]

STSADM is a command-line utility for configuring SharePoint

0
votes
1answer
473 views

importing a site to a new site collection error

I tried using STSADM to export / import a site definition, it exported properly, but when i tried to import it, it gave me fatal error that couldn't find a webtemplate #id**** with LCID 1033, both ...
3
votes
2answers
1k views

stsadm.exe crashes on all commands

All of a sudden, stsadm has stopped working, crashing on all commands it is run with (even -help!) e.g. > stsadm.exe -help Unhandled Exception: System.ArgumentNullException: Value cannot be null. ...
0
votes
1answer
3k views

attach content db to SharePoint Server 2010

I need to migrate the WSS3.0 SP2 + Project Server 2007 SP2 based farm to a SPS2010 SP1 + Project Server 2010 Sp1 farm. I create a new farm (new VM on hyperV 2012) SPS2010 based (build 14.0.6028.1000) ...
4
votes
5answers
12k views

I cant delete or restore a site collection or repair database

When I try to do a restore of a site collection, restore-spsite -Identity https://xx/10014628/ -Path D:\SiteCollectionBackups\10014628.bak -Force -Confirm I get: restore-spsite : <nativehr>...
3
votes
2answers
696 views

Where are deployed solutions being used?

I'm in a MOSS 2007 environment and am looking to find a way to see where solutions listed in the stsamd -o enumsolutions are activated in site collections. How would I go aout finding out where these ...
3
votes
1answer
3k views

After site collection restore, site cannot be crawled?

We have a SharePoint 2007 site collection that some permissions were accidentally deleted from. It was impossible to determine how it was originally setup, so we decided to do an STSADM restore from ...
2
votes
1answer
191 views

Is stsadm output guaranteed to be XML?

I have a tool that programmatically invokes stsadm.exe and parses the results. The output looks like XML, so I've been using an XML parser to read it. One of my customers ran my tool on a French ...
2
votes
3answers
3k views

SharePoint restore fails because of newer version

I have installed SharePoint 2010 SP1 on my local developer machine. I wanted to copy a site collection from one of our productive servers (which hasn't SP1 yet but the December 2010 Cumulative Update)...
2
votes
3answers
11k views

People Picker and fltering by certain AD Groups

I have a scenario where a client wants to filter in the People Picker what AD Groups are available to choose from. For instance, when selecting what AD User/AD Group can be added to an Alert on a ...
1
vote
1answer
627 views

Automating Site Collection Creation

I have a need to allow non farm administrators to be able to create site collections using a very specific site definition. These people will not have access to central admin and so require a custom ...
1
vote
2answers
802 views

Schema.XML not found in 12/Template/Features/myfeature

I am trying to create a custom list feature, what I did is created feature and then i build a solution out of it using this tutorial Creating a Solution file for Feature when it creates a .wsp file ...
1
vote
3answers
291 views

Solution deploying 'succesfully', yet doesn't..

MOSS 2007 :) I am having problems deploying a webpart.. This webpart was successfully installed and deployed on a similar environment with no problems. However when trying to deploy it in its ...