Questions tagged [sharepoint-server]

SharePoint Server is the Microsoft product "SharePoint Server".

Filter by
Sorted by
Tagged with
0
votes
1answer
35 views

Theme color was changed after visiting site collection

I have SP 2019 on-prem environment. Created the subsite using Communication Template (As of now I was unable to create the Subsite using Communication Template so I found some trick to create it - ...
1
vote
3answers
66 views

Open SharePoint list items in edit mode

When users click on Title field from AllItems.aspx page, I want to redirect them to EditItem.aspx instead if DispForm.aspx page. I have written following code. It's working fine for first 30 items(...
4
votes
1answer
35 views

Sharepoint List change notification incorrect

I have setup an alert on a Sharepoint list for when new items are created or any changes etc. I have noticed that when someone changes any field on the form, all of the text area fields show a change,...
0
votes
1answer
18 views

Modern List view is not showing for Document library even enabled New Experience

I have SP 2019 farm, the document library migrated from MOSS 2007 is showing classic page even "New Experience" enabled in List Settings
0
votes
0answers
13 views

Custom itemStyle.xls comments field not showing

We recently migrated from 2007 to 2016. I have landing pages that contain content query web parts that rollup custom fields from sub pages. I'm not getting all the custom values, specifically the ...
0
votes
0answers
48 views

Uploaded an aspx page, getting the “Sorry something went wrong. File Not Fount.” message

I copied and pasted an .aspx file to my siteassets folder. When trying to access, I receive the "Sorry something went wrong. File Not Found." message. Is an .aspx page not a simple upload and click ...
0
votes
1answer
25 views

Auto-Increment Number Field in a SharePoint List - But Not The Popular Solution

I need to create an auto-increment field with a standard amount of digits. The format needs to be like this T000001, T000002, T000003, ......T000010, etc (7 Digits). When it gets to the 10th record ...
1
vote
1answer
37 views

Set list to standard view instead of quick edit mode

All of my lists are in Quick Edit view by default and I want to change it to be the Standard View by default (see standard view image below). I read a solution that tells me to go to Advance ...
0
votes
0answers
9 views

Open New Item link only in mobile view in SharePoint 2013 Foundation

I have a site collection in SharePoint Server 2013 Foundation and have mobile view turned off because several users look at the site collection with iPads and need full functionality. However, we also ...
0
votes
1answer
32 views

Client Side Rendering Issues

I have developed some modifications against SharePoint list new/edit forms using CSR, as many other times everything works as expected. Code has been tested in two different environments and works. ...
0
votes
2answers
38 views

Installed PU/CU on all farm servers but SharePoint thinks it's missing from one of application Server

Recently I find one issue in my Central Admin, i.e "Product / patch installation or server upgrade required on one of our Application Server. Even I did run the PowerShell cmdlet Get-SPProduct -local ...
0
votes
2answers
48 views

SharePoint User Profile property is not updating in User Information List

I have SharePoint 2019 environment migrated from MOSS 2007. I have also configured the User Profile service application and sync all users from AD. For some reason the User Property like "Title / ...
0
votes
0answers
43 views

Office Online Server for SharePoint 2019 return Unhealthy

We installed Office Online server on Windows Server 2019. We are able to preview the documents in the browser without any issues. However (Get-OfficeWebAppsFarm).Machines return the health status as ...
0
votes
1answer
30 views

User Profile Synchronization Service not starting for sharepoint 2010

We have a sharepoint clone mess up, in which systems admin made a clone of sharepoint app server, but we quickly remove the newly cloned server and configured CA to other App server as it stopped ...
0
votes
2answers
32 views

Generate site Urls in Sharepoint 2016 without /sites after the domain name

I have a site collection in SharePoint 2016 with the following URL. https://xyz.com/sites/testclassic and I have created a page test.aspx and with managed path it generates the following URL. https:...
0
votes
2answers
26 views

How to make a SP2013 subsite (not site collection) read-only?

Is there any way to make a SP2013 subsite (not site collection) read-only? I know you can make a site collection read-only using site policies but how can one make a subsite Read-Only without altering ...
0
votes
0answers
95 views

Office Online server 2016 high memory usage

I realise this has been asked before but I've been adding and adding memory to our server with no difference. Our OOS server (single server connected to a SP2016 estate) is currently at 24Gb memory ...
1
vote
0answers
28 views

Sharepoint 2013 - use a dedicated Search server as a dedicated crawl server?

I'm having a SharePoint 2013 enterprise farm with the following servers and roles: Application server 1 - Hosts CA and all the services (expect search). (32 GB ram, 4 cores). Application server 2 - ...
0
votes
0answers
18 views

Sharepoint 2013/PowerShell : Error on item list update with batch

I'm trying to synchronize a list item using a batch from a first site to another site (SharePoint 2013). I tried the PowerShell code (available down below) with 3 list item. The first one did work but ...
0
votes
0answers
12 views

Associations Between Service Apps (Not Proxies) and Proxy Groups

I am confused regarding the relationship between service applications (not service application proxies) and proxy groups. I understand the concept of service app proxy groups, and how they are used to ...
0
votes
0answers
18 views

SharePoint New Icon Indicator for Custom Pages

I have a custom layout page where data is loaded in SPGridView. In the SPGridView, I want to indicate new items using inbuilt SharePoint New indicator green icon. I have written following code to ...
0
votes
0answers
29 views

SharePoint 2019(On-Prem) on Windows Server 2016 | Claims authentication login issue with 3rd party SSO

I am using claims authentication in my SharePoint 2019 web application and the claim provider is OKTA. This SSO integration is working successfully i.e. User get redirected to OKTA for authentication;...
1
vote
1answer
42 views

Can we add multiple preconfiguredEntries to a SPFx web part for use on SharePoint Server 2016?

I'm finding that no matter which web part I try to add, only one of the preconfigured entries is ever added to a page. Have I done something wrong in my web part manifest.json file, or does having ...
0
votes
1answer
18 views

Nest tasks under sections within a list

I'm using SharePoint 2013 and I am attempting to nest a bunch of tasks within sections for each person (IE: item). For example: I'd like John Doe to have 3 tasks within HR, 3 tasks within Admin, and ...
3
votes
2answers
64 views

SP2013 - Standard 2010 Approval workflow fails on start , cancelled by System Account

I have seen this question asked several times, here or somewhere else on the Internet, but none of the solutions presented worked for me. What I have : SharePoint 2013 OnPremise Workflow Manager ...
0
votes
0answers
28 views

sharepoint is loading working on it dialog for no reason

sometimes when i am trying to fill up a form in sharepoint webparts, suddenly sharepoint will show "working on it" and reload the page so my entered data will gone. why it is happening and how can i ...
0
votes
2answers
35 views

How to change SP 2016 link to logo

How can I change the link to the logo of a SharePoint 2016 site? Currently, there is a logo but it isn't even linked up. The masterpage has been slightly branded using design manager. I know it's ...
0
votes
0answers
27 views

A Membership Provider has not been configured correctly. Check the web.config setttings for this web application

SharePoint 2010 environment with Form-Based Authentication gives below error which used to work while trying to access "FBA User Management" in site settings. I tried to restarting SharePoint timer ...
0
votes
1answer
19 views

Why does clicking the tabs inside a Content Editor Web Part cause my page to refresh?

I'm back with more questions. I recently wrote up some HTML (to create a set of three tabs) and put it on the page with the HTML Form Web Part. But now, whenever I click on one of the tabs in order to ...
2
votes
3answers
51 views

How to write internal column names to host

At the moment I m trying to use this: Add-PSSnapin microsoft.sharepoint.powershell #Get Web $web = Get-SPWeb http://... #Get List $list = $web.Lists["List1"] $list.DefaultView.ViewFields | Write-...
0
votes
2answers
35 views

SharePoint 2013 - Replace Master Page Header Color with Image

I would like to replace the Master Page header background color with a banner/image. Can this be done? Do I make the change on the master page or in css?
0
votes
1answer
18 views

SharePoint and OpenID Connect

We are today using SharePoint Server and have a newly implemented OpenID Connect (OIDC) provider (certified) which we would like to use to authenticate/authorize users with. Is it possible to use ...
1
vote
1answer
64 views

CSOM C# Copy Library from one Site Collection to another with all folders / subfolders intact

Any help would be appreciated here. Below is my attempt to copy files and folders from one site collection to a completely different site collection. The structure from one side to the other should ...
0
votes
1answer
30 views

How to add non list based OOTB web parts with JSOM Sharepoint 2013

I am attempting to add a Query String Filter Url Web Part to a page programmatically with JSOM and am hitting a dead end. I see how you can add a web part if you already have the XML like in this ...
0
votes
2answers
43 views

Why does my Content Editor WebPart (CEWP) work in a page in Edit mode, but not in published mode? [duplicate]

I recently added a Content Editor Webpart with code for an accordion. When I'm using it in on the page in edit mode, there are no issues. For reference, the end of the URL looks like this: /sites/JI/...
0
votes
0answers
33 views

Error running import-spweb on SharePoint 2013

When trying to restore a site, to a site on the same Site Collection (even when trying to restore to the original site) using the following we are getting an error. We've narrowed the error down to ...
0
votes
1answer
18 views

rbs(remote blob storage) wont disable

target is to upgrade sharepoint 2013 to 2016. i have backed up the contentDB and restore it it will mount in new web app in 2016 farm but there s some problem: first. it kinda seem like it mounted ...
1
vote
1answer
32 views

SharePoint 2013 stretched farm latency

I'm planning to stretch our SP farm. I'm going to move 1 WFE and 1 APP to another data center. Distance between data centers less than 10 km. Based on this article there are strong requirements: ...
0
votes
1answer
28 views

How to get the user added date/time to the SharePoint Group

I want to get the details (date/time) of when a particular user added to the particular SharePoint group. Can anyone help
1
vote
2answers
35 views

SharePoint mapped Layouts/15/Images folder/image.jpg - not showing up

In my SharePoint 2013 site, where I am deploying few of the images in the layouts/Images/Test and when I am trying to access it on sharepoint, I am just seeing an 'X' mark. Where as there are few ...
0
votes
1answer
31 views

Can I delete and recreate a list (from template) with the same ID as the list before?

I have to show a report daily, which was pulled out of an excel file (importExcel). This works so far. To reset the ID, I daily delete the list and recreate it from a template which I created. It ...
0
votes
1answer
25 views

SharePoint custom filed type

I need some help to show me how to create SharePoint custom field type? does anyone have any resources so I can read. Regards
1
vote
2answers
38 views

Hide column display name on sharepoint list display form using jquery

How to hide the column display name in the sharepoint list display form using jquery. I do not want to hide entire field. I want the control to be displayed but only the display name has to be hidden. ...
1
vote
4answers
120 views

Access denied after upgrade from SP 2016 to SP 2019

I've been preparing an upgrade from SharePoint 2013 to 2019. So far I've managed to attach the database to 2016 and successfully upgraded it. I was able to use the site collection without any ...
1
vote
2answers
45 views

Converting Document Sets to Folders

Users in my organisation have been reporting issues accessing some of their document sets. After investigating the issues I've found that in each of them, the user has changed the content type of the ...
1
vote
0answers
16 views

How to Fetch Predecessor Lag and Parent.Id using ProjectServer Getting Microsoft.SharePoint.Client.PropertyOrFieldNotInitializedException

Below is the code that I use. using (ProjectContext projContext = new ProjectContext('pwa url')) { projContext.AuthenticationMode = ClientAuthenticationMode.Default; projContext.Credentials = ...
1
vote
0answers
42 views

pnp.js - Join 2 sharepoint lists using camlquery

I am facing issue with joining 2 sharepoint lists using pnp.js. I have 2 lists, the first one named "Phasen" have 2 columns, Title, Wow. The second list named "Projects", have 2 cloumns - Title, ...
0
votes
2answers
29 views

How can I use export to excel and get the full file path?

In the past when I used export to excel the full path was shown as "../../../../../../../../Departments/EIDepartment/Shared Documents/Area Class Reference/FIGURE 2.pdf", which I could use as a ...
0
votes
1answer
25 views

Changing list column width with Script Editor doesn't break line

I have a webpart that has a list with columns. To change the width of these columns I inserted a Script Editor and used this code: <style> .ms-vh-div[displayname='Beschreibung'] { width: 450px;...
0
votes
1answer
34 views

How to fix cloned SharePoint 2010 App server window VM Mess up

Our system admin cloned our SharePoint 2010 App server window VM. Now search service and user profile service is not working, don't know what else. how we can fix this mess up. Is it fine if ...